Video Screencast Help

Software portal opens in Chrome even though IE is default browser

Created: 26 Dec 2012 • Updated: 09 Jan 2013 | 4 comments
SonicGT's picture
This issue has been solved. See solution.

When I have chrome and IE installed on a workstation IE is set to the default browser but the portal is still opening in chrome when using the link, any thoughts or suggestions?

Comments 4 CommentsJump to latest comment

Dmitri Dragunov's picture

 

Hi,
 
Seems that this is because default registry key has been changed by Chrome in "HKEY_CLASSES_ROOT\http\shell\open\command" after you set it as default browser. And IE not changed it back after it was set it as default browser.
 
As workaround you may change this registry key to:
"C:\Program Files\Internet Explorer\iexplore.exe" -nohome
 
And Software portal will be opened in IE untill user do not set the Chrome as default browser again.
 
Regards,
Dmitri

 

 

SOLUTION
SonicGT's picture

Strange, this is the reason though, not sure why it doesn't change back

RGluck@cityhospital.org's picture

1. Start, click Run, type Regedit in the Open box, and then click OK.
2. Browse to HKEY_CURRENT_USER\Software\Classes\.html
3. Right click the value for the .html key and select Modify…
4. Change the value from "ChromeHTML" to "htmlfile"
You can also check under HKEY_CLASSES_ROOT
Look for \. HTM and \.HTML adjust the default settings to reflect “htmlfile”

Possibly check under all html settings under current user and HKEY_Classes_Root htm, html, shtm, shtml. Google Crhome even once uninstalled still kepps reg settings. The bad part is you dont need Admin rights to install Chrome so it can be very detrimental to your network if certain sites only work with Explorer.

SonicGT's picture

Yea we are actually using application metering to block the chrome install unless approved, so the population is very small that has chrome.