Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Software Updates still scheduled after saying installed and a reboot

Created: 20 Jul 2012 | 2 comments
GarethNZ's picture

Hi, I've got an issue with 1 (1 that I know of) PC, it's receiving Software Update policies ok, downloading the files ok, scheduling ok, reporting that the updates are installed (with exit code 3010 reboot required), after the reboot the updates are all scheduled again.

I've run the Software Update Cycle manually a few times and it always shows they are all installed with exit code 3010, but after a reboot status = Update Sechuled again.

If I double click an update and choose the "download history" tab and click a link under "Source location" I get manually install the the update and after a reboot the Software Updates tab shows that update as installed.

There is 1 update that fails, but that's the same on my PC and the others all installed fine:
<event date="Jul 21 10:48:02" severity="1" hostName="PSPC2309" source="SoftwareUpdateAgent" module="PatchMgmtAgents.dll" process="AeXNSAgent.exe" pid="1868" thread="3628" tickCount="4056774"><![CDATA[Failed to apply software update [MSWU-431]:outlfltr2010-kb982726-fullfile-x86-glb.exe]]></event>

Log attached,I don't konw a lot about Patch Management logs but it looks ok, runs through it's checks, installs updates, says if reboot is required
<event date="Jul 21 10:51:55" severity="4" hostName="PSPC2309" source="SoftwareUpdateAgent" module="PatchMgmtAgents.dll" process="AeXNSAgent.exe" pid="1868" thread="3628" tickCount="4290183"><![CDATA[Return code (3010) indicates a reboot is required. Update may not be rescheduled until after reboot]]></event>

PC is running Windows 7 SP1 32bit
I have reinstalled the SMA

thanks

Comments 2 CommentsJump to latest comment

Roman Vassiljev's picture

Hi GarethNZ,

Could you please provide some additional details?

What is the version of Patch Management Solution in your case?
Could you please attach more Agent logs captured during SWU cycle before restart, restarting and after restart?
Please also provide us with assessment log from client where issue is observed.
(Go to directory C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache\,
Attach 2 files: STPatchAssessment.log & STPatchAssessment.xml)

Thank you in advance,
Roman

GarethNZ's picture

Hi Roman, as I was testing this morning it was the first time I was actually infront of the PC and I could see the full boot process, the Windows "Configuring Updates" message changed to "failed to configure Windows Updates", so I actually think it's an issue with Windows rather any Symantec issue. thanks anyway.