Video Screencast Help

Solaris 10u10 Zones and Storage Foundation Version 6.0

Created: 05 Feb 2013 • Updated: 07 Mar 2013 | 7 comments
This issue has been solved. See solution.

I have a Solaris 10u10 system with Veritas Storage Foundation version 6.0.100 and I'm trying to create a non-global zone.

The non-global zone doesn't completely come up because the VRTSvlic package creates a dependancy on the svc:/milestone/multi-user but the the vxfsldlic service is set to disabled.

Does anyone know how to get around this problem?

Discussion Filed Under:

Comments 7 CommentsJump to latest comment

Venkata Reddy Chappavarapu's picture

Did you configure your zone after created?

You can configure your zone by logining into its console.

# zlogin -C <zonename>

For another window reboot the zone.

 

Thanks,

Venkat

 

Venkata Reddy Chappavarapu,

Sr. Manager,

Information Availability Group (VCS),

Symantec Corporation

===========================

PS: If you are happy with the answer provided, please mark the post as solution. You

g_lee's picture

You can enable the vxfsldlic service so the system continues to multiuser:

svcadm enable svc:/system/vxfs/vxfsldlic:default

either log into console with zlogin -C as Venkat suggest above, or you can run from the global via:

global# zlogin <ZONE> "svcadm enable svc:/system/vxfs/vxfsldlic:default"

Note: if you are not planning to use ODM in the zone you may want to disable this service after you enable vxfsldlic (vxodm is enabled by default and depends on vxfsldlic so will try to start after enabling vxfsldlic)

svcadm disable svc:/system/vxodm:default

If you do want to use ODM in the zone, see this technote:

http://www.symantec.com/docs/TECH158632

 

EDIT: found the reference:

Veritas Storage Foundation and High Availability Solutions 6.0 Virtualization Guide
https://sort.symantec.com/public/documents/sfha/6....

-> Storage Foundation and High Availability Solutions support for Solaris Zones

-> Software limitations of Storage Foundation support of non-global zones

-> The svc:/system/vxfs/vxfsldlic service is not enabled in non-global zones

https://sort.symantec.com/public/documents/sfha/6....

--------------------
When the VRTSvxfs package is installed on a host where the zone is configured, the svc:/system/vxfs/vxfsldlic service does not start automatically for the configured or installed non-global zones. As a result, the svc:/milestone/multi-user service may enter the maintenance mode, after the VRTSvxfs package is installed.

Workaround:The following commands are used to enable the svc:/system/vxfs/vxfsldlic service in the non-global zones:

svcadm enable svc:/system/vxfs/vxfsldlic

svcadm clear svc:/milestone/multi-user

svcadm enable svc:/milestone/multi-user
--------------------

If this post has helped you, please vote or mark as solution

derekmceachern's picture

Thanks for the responses. I've been playing with this a little and yes, I can enable the vxfsldlic service either from the global zone or the zone and it will come up.

I was looking at the documentation that you pointed to and in one section it seems to indicate that for certain operations you need to create a lofs to point to the licenses.

zonecfg:myzone> add fs
zonecfg:myzone:fs> set dir=/etc/vx/licenses/lic
zonecfg:myzone:fs> set special=/etc/vx/licenses/lic
zonecfg:myzone:fs> set type=lofs
zonecfg:myzone:fs> end

If I do this the vxfslidlic service ends up in mainteance mode and I don't seem to be able to clear the error.

This really seems like a major bug to me that just having the packages installed in the global zone will prevent non-global zones from starting normally.

g_lee's picture

From memory, the lofs for licenses is only required if you're planning to use the licensed features in the zone (eg: ODM) - if you're not using those features just enabling the vxfsldlic service (at initial boot) should suffice.

If this post has helped you, please vote or mark as solution

jdangelo_symc's picture

For Version 6.0, the LOFS workaround for /etc/vx/licenses/lic is not required.  Having these entries will in fact cause the issue you are facing.  Please refer to the following technote for details on how to resolve this.

http://www.symantec.com/business/support/index?page=content&id=TECH176182

Joe D