Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Solaris 11.1, SAS LTO6, Neo 400s library, can not bring into NetBackup

Created: 30 Jan 2013 • Updated: 08 Feb 2013 | 12 comments
This issue has been solved. See solution.

Here is the problem according to hardware and software support people from respective companies:

I've posted the same question on Oracle Support Forum yesterday and have seen no valid responses.

We have purchased a new backup solution for a satellite office.

The hardware includes a NEO 400s tape library with two SAS LTO6 drives.

The SAS card in the Solaris 11.1 x86 server is an LSI SAS9200-8e PCI Express to 6Gb/s HBA.

My backup software is Symantec NetBackup 7.0.1

After building out the 11.1 x86 box, installing the SAS HBA and connecting it to the Neo 400s, I get the following from the OS when I check hardware config:

root@sf-backup:~# cfgadm -al
Ap_Id Type Receptacle Occupant Condition
c8 scsi-sas connected unconfigured unknown
c9 scsi-sas connected configured unknown
c9::rmt/0 tape connected configured unknown
c9::scsi/changer/c9t5000E1114 med-changer connected configured unknown
c10 scsi-sas connected configured unknown
c10::rmt/1 tape connected configured unknown
sata0/0::dsk/c7t0d0 disk connected configured ok
sata0/1 sata-port empty unconfigured ok
sata0/2 sata-port empty unconfigured ok
sata0/3::dsk/c7t3d0 disk connected configured ok
sata0/4 sata-port empty unconfigured ok
sata0/5 sata-port empty unconfigured ok

And the /dev/rmt directory shows

root@sf-backup:/etc/init.d# ls -lrt /dev/rmt/*cbn
lrwxrwxrwx 1 root root 89 Jan 18 15:34 /dev/rmt/0cbn -> ../../devices/pci@0,0/pci8086,2e21@1/pci1000,3080@0/iport@80/tape@w5000e1114d83d002,0:cbn
lrwxrwxrwx 1 root root 90 Jan 18 15:34 /dev/rmt/0dcbn -> ../../devices/pci@0,0/pci8086,2e21@1/pci1000,3080@0/iport@80/tape@w5000e1114d83d002,0:dcbn
lrwxrwxrwx 1 root root 89 Jan 18 15:34 /dev/rmt/1cbn -> ../../devices/pci@0,0/pci8086,2e21@1/pci1000,3080@0/iport@40/tape@w5000e1114d83d005,0:cbn
lrwxrwxrwx 1 root root 90 Jan 18 15:34 /dev/rmt/1dcbn -> ../../devices/pci@0,0/pci8086,2e21@1/pci1000,3080@0/iport@40/tape@w5000e1114d83d005,0:dcbn

So from the OS, I can see the tape drives and I can see the media changer (see cfgadm -al). HOWEVER, when I try to bring these devices into NetBackup via the "wizard", the backup software can not see the library at all.

According to NetBackup support, the issue lies in the identification of the device (see /device tree) as a "tape@WWN". They claimed that NetBackup must have a device tree of "st@WWN". Until the OS can see the library/tape drives in this format, NetBackup will not see the library.

My question: Is there a way to change the devices path so that the hardware comes in with a path that includes "st@WWN" instead of "tape@WWN" or, even better, is NetBackup support just wrong and their is another way to see the hardware from this backup software?  Is there a way to bring in the library manually without going through the wizard?

Any help would be greatly appreciated.

Comments 12 CommentsJump to latest comment

Nagalla's picture

hi,

Solaris 11 is not suppported with 7.0.1 for master and media servers.

minimum of 7.1 is required solaris 11 to be a media server.

solaris 11 master server is supported from 7.5.0.3

please check sort for more info

https://sort.symantec.com/netbackup

 

Please upgrade your Netbackup to latest versions, and see how it works .

 

patrick.melton@usamobility.com's picture

Thank you for poining that out.

I understand that this support matrix does not show that Solaris 11.1 is supported with 7.0.1.  This same matrix does not show that NetBackup 7.0.1 supports LTO6 drives.  Maybe I'm just having a case of hopeful thinking.  I was hopeing that since this OS and tape drive technology are fairly new that they simply had not updated their support matrix. 

I have no problem standing up a Solaris 10 server to use.  (I'm downloading OS software as I type this.)   Does this also mean that NetBackup 7.0.1 is not going to work with my LTO6 drives?

 

Nagalla's picture

I am seeing NEO 400s tape library in 7.X compatablity list as supported.

patrick.melton@usamobility.com's picture

Please ignore the last whiny update.  I'm downloading 7.5 now and will update this post after I update my NetBackup software.  Thanks again for your help.

Andy Welburn's picture

I'm downloading 7.5 now and will update this post after I update my NetBackup software.

 

& then 7.5.0.4:

http://www.symantec.com/business/support/index?pag...

Marianne's picture

Good decision to first upgrade to NBU version that supports your OS.

After NBU 7.5.0.4 upgrade, the device config wizard will probably still not pick up devices.
This is perfectly normal since NBU on Solaris uses its own sg driver to scan and use devices.

Use these steps to rebuild the sg driver: 

 

# cd /usr/openv/volmgr/bin/driver
# /usr/openv/volmgr/bin/sg.build all 

Install the new sg driver configuration:

# /usr/bin/rm -f /kernel/drv/sg.conf
# /usr/openv/volmgr/bin/driver/sg.install

Check/verify config:

# /usr/openv/volmgr/bin/sgscan

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

patrick.melton@usamobility.com's picture

All, Thanks for your ongoing help in this matter...  I've upgraded till here is where I stand now:

OS: Solaris 11.1 x86

root@sf-backup:/dev/rmt# uname -a
SunOS sf-backup 5.11 11.1 i86pc i386 i86pc

NBU: Version 7.5.0.4

root@sf-backup:/usr/openv/netbackup# cat version
HARDWARE SOLARIS_X86
VERSION NetBackup 7.5.0.4
RELEASEDATE Sun Sep 16 11:43:30 CDT 2012
BUILDNUMBER 20120916

Marianne was exactly right that this did not solve any issues.  Drives still show in device tree as "tape@WWN" instead of "st@WWN"

During the course of the 7.5 install I got the following message:

devfsadm: driver failed to attach: sg
Warning: Driver (sg) successfully added to system but failed to attach

WARNING: /usr/sbin/add_drv failed.
         There may be no SCSI devices on this machine

Kind of expected that based on what Marianne said.

After the 7.5 install, I launched the Java Admin Console and confirmed that I couldn't utilize the wizard to conect with the drives or library.  "The wizard could not detect any removable media devices attached to the host."

I then closed the Admin Console and performed the upgrade to 7.5.0.4.

I was a little concerned when I repeatedly saw things like the following during the 7.5.0.4 upgrade:

Extract /root/netbackup_7.5.0.4/VrtsNB_CLT_7.5.0.4.Solaris.tar.gz usr/openv/netbackup/client/Solaris/Solaris10
Extract /root/netbackup_7.5.0.4/VrtsNB_CLT_7.5.0.4.Solaris.tar.gz usr/openv/netbackup/client/Solaris/Solaris9
Extract /root/netbackup_7.5.0.4/VrtsNB_CLT_7.5.0.4.Solaris.tar.gz usr/openv/netbackup/client/Solaris/Solaris_x86_10_64

/root/netbackup_7.5.0.4/VrtsNB_7.5.0.4.preinstall: Running. Hardware/OS Type=Solaris/Solaris_x86_10_64

I saw and see nothing for Solaris 11.1, but kept going with hope...

After install I again launched the Admin Console and just as Marianne said... no bueno.

So I tried the suggestions she made in the above post.

Stopped NBU (/etc/init.d/netbackup stop...process table shows clear of netbackup processes)

root@sf-backup:/etc/init.d# cd /usr/openv/volmgr/bin/driver
root@sf-backup:/usr/openv/volmgr/bin/driver# /usr/openv/volmgr/bin/sg.build all
The file ./st.conf should be appended to /kernel/drv/st.conf.
A reboot may be necessary to create any new device files.
Created file ./sg.conf.
Created file ./sg.links.
root@sf-backup:/usr/openv/volmgr/bin/driver# /usr/bin/rm -f /kernel/drv/sg.conf
root@sf-backup:/usr/openv/volmgr/bin/driver# /usr/openv/volmgr/bin/driver/sg.install

        Copied files to /kernel/drv/amd64.

Doing add_drv of the sg driver

devfsadm: driver failed to attach: sg
Warning: Driver (sg) successfully added to system but failed to attach

WARNING: /usr/sbin/add_drv failed.
         There may be no SCSI devices on this machine

root@sf-backup:/usr/openv/volmgr/bin/driver# /usr/openv/volmgr/bin/sgscan
root@sf-backup:/usr/openv/volmgr/bin/driver#
 

From this point I'm lost.  Driver successfully added but failed to attach?  The drives are there!

HELP?!?!

 

 

 

 

patrick.melton@usamobility.com's picture

One final note to add to the above update.  After the commands suggested by Marianne, I rebooted the box.  Since that time, the NBU server has not launched correctly.  I get a persistant bpstsinfo -UPDATE
in the process table:

root@sf-backup:/etc/init.d# ps -ef|grep netbackup
    root  3832     1   1 16:42:16 ?           0:00 /usr/openv/netbackup/bin/admincmd/bpstsinfo -UPDATE
    root  3735     1   0 16:41:54 ?           0:00 /usr/openv/netbackup/bin/bprd
    root  3845  3286   0 16:42:21 pts/1       0:00 grep netbackup
    root  3650     1   0 16:41:52 ?           0:00 /usr/openv/netbackup/bin/bpcd -standalone
    root  3647     1   0 16:41:52 ?           0:00 /usr/openv/netbackup/bin/vnetd -standalone
    root  3742     1   0 16:41:55 ?           0:00 /usr/openv/netbackup/bin/bpdbm
    root  3739     1   0 16:41:54 ?           0:00 /usr/openv/netbackup/bin/bpcompatd
    root  3807     1   0 16:41:57 ?           0:00 /usr/openv/netbackup/bin/bmrbd
 

Admin console cannot connect and the other NBU processes will not start with a /etc/init.d/netbackup stop and start.

Marianne's picture

Firstly - there is no need to stop NBU to rebuild sg drivers.

Your issue seems similar to something my friend experienced. 
He logged a call with Oracle support and received this response:

******************************************************************************

well... you are facing the issue described in document i mentionned in the previous note

I ve been reading through the bug :

7090061 Backup software unable to detect library/tape devices attached to SAS2.0 HBA(both mpt_sas and pmcs) 

there is not any improvement since the comment from doc 1435929.1

"CR 7090061 - 'Backup software unable to detect library/tape devices attached to SAS2.0 HBA(both mpt_sas and pmcs)

Basically Solaris changed the driver stack and they only allow one driver attach per device, but Symantec depends on two drivers to attach (sg and st).
The sg driver is too entrenched in Symantec's code to change and so far Solaris hasn't been willing to revert back.
The issue has been escalated through management, but we don't have any time frame on a potential solution, or as to whether there will be a solution."

---

For now the only solution to fix this issue is to replace the 6GB SAS HBA with a 3GB SAS HBA.
The explanation is that the 3GB SAS HBA is using the mpt driver, while the 6GB SAS HBA is using hte mpt_sas driver 

I can attach the SR 3-5959149981 to the CR 7090061, to add your customer to the list of client impacted by the issue

You could try too to disable mpxio in the mpt_sas.conf file, but i dont give much chance to that solution as it is not reported as a Work Around on the Oracle side

****************************************************************************

Seems you need to log a support call with Oracle and in the meantime replace the 6 GB HBA with 3 Gb HBA.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
patrick.melton@usamobility.com's picture

Marianne, you were exactly right.  I went back to my vendors with your comments and suggestions.  Overland (maker of the NEO 400s) agreed that the issue was the 6Gb/s card and recommended I swap it out with a 3Gb/s card, but couldn't explain the reson behind this need as you have.

The vendor has now supplied me with two 3Gb/s cards.  I put one in a SUN V245 and installed Solaris 10 (8/11) and the other one in a desktop running Solaris 11.1 x86.  In both cases, the drives and the robot came in with devices names of st@ instead of tape@ and in both cases, NBU 7.5 and 7.5.0.4 were able to see the library and the tape drives.

On a side note, NBU 7.5 didn't have the correct drivers for the LTO6 drives, but NBU 7.5.0.4 did.  Once I upgraded to 7.5.0.4, I was able to bring both the library and the drives into NetBackup. 

Again, thank you all for your help in resolving this issue.  Excellent forum!

Yasuhisa Ishikawa's picture

Great job, Marianne!

Patrick, plase mark a solution for Marianne's post.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Andy Welburn's picture

Glad to see you got a resolution Patrick. Have marked Mariannes post as the solution for this - gives her the kudos she deserves and will help anyone that's in the same boat as you in the future.