Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Solaris 11.1 uninstall VXVM 6.0.1 in liveboot from CD

Created: 04 Feb 2013 • Updated: 07 Mar 2013 | 2 comments
This issue has been solved. See solution.

I have Solaris 11.1 x86 box with VXVM 6.0.1.

Last my action was try to install patch VXVM 6.0.3 on VXVM 6.0.1.

On preparation stage installer could not stop all modules :

    vxio failed to stop on smc
    vxdmp failed to stop on smc

And installer give suggest reboot system. After trying reboot system I got panic cycle. Single mode is not help.

Now I try to explore possibility to remove VXVM from livecd boot.

Which steps I already made:

1) Boot from sol-11_1-live-x86.iso

2) As root, zpool import -f rpool

3) ....

On step 3 I dont' know what to do next. I trying to chroot into be, which I mount with "beadm mount solaris /a" but I can't delete VXVM with standart methods.

Comments 2 CommentsJump to latest comment

g_lee's picture

When you say you "can't delete VxVM with standard methods", do you mean the steps mentioned in the SF 6.0.1 Installation Guide under Uninstallation of SF, or are you referring to something else?

https://sort.symantec.com/public/documents/sfha/6....

eg: do the pkg uninstall steps from the 6.0.1 install guide work, or are they also failing?

(may need to modify cmd/add options to use the alt root)

# pkg uninstall VRTSodm VRTSdbed VRTSfssdk \
VRTSvxfs VRTSsfmh VRTSob VRTSaslapm VRTSvxvm \
VRTSspt VRTSperl VRTSvlic

You could try to log a support case; as Solaris 11.1 is known to be incompatible with SF6.0.1 there may not be much else that can be done, but they may be able to suggest what to do/not to do in future?

eg: TECH202397 http://www.symantec.com/docs/TECH202397 (provided by Tony in your earlier 11.1 post here https://www-secure.symantec.com/connect/forums/sol...)

--------------------
Need clean installation of SFHA on Solaris 11.1
Issue: Solaris 11.1 is incompatible with SFHA 6.0.1
Solution: Install SFHA 6.0.1 software on Solaris 11.1 but DO NOT configure SFHA (As part of the installer, answer NO when asked to configure SFHA). When SFHA 6.0.1 is installed, upgrade to SFHA 6.0.3. Once upgrade is complete, configure SFHA
--------------------

If this post has helped you, please vote or mark as solution

SOLUTION
Roman Kuznetsov's picture

Yes, you are correct. I was tried to run uninstall script. But in chrooted environment script exited with error.

After all my attempts to make system working, I reinstall whole system, disable native multipathing (stmsboot -d), install SFHA 6.0.1, then install 6.0.3. And now all working correct. Even odm is not panics!