Video Screencast Help

Solaris10 client: Exclude List - Does not work

Created: 08 Apr 2011 • Updated: 24 May 2011 | 16 comments
This issue has been solved. See solution.

Hi Team,

One  of our master/media server (Windows 2K3 x64 EE | NBU 6.5.6) is backing up the excluded list of Solaris10 client (6.5.6). Below is the exclude list info.

/usr/openv/netbackup/exclude_list

/hgfs >> exclude_list.

Also, is there a option for creating global exclude list on Windows master server for Unix clients?

Regards

Rizwan

 

Comments 16 CommentsJump to latest comment

Zahid.Haseeb's picture

One  of our master/media server (Windows 2K3 x64 EE | NBU 6.5.6) is backing up the excluded list of Solaris10 client (6.5.6). Below is the exclude list info.

Follow the below link too for this properly.

 

is there a option for creating global exclude list on Windows master server for Unix clients?

http://www.symantec.com/business/support/index?page=content&id=TECH66046&key=15145&actp=LIST

 

Exclude and include list for Windows clients are held in registry keys and can be managed from the Master Server/administration GUI via Host Properties > Clients > Windows Client > Exclude Lists tab.  Prior to NetBackup 6.5.3,

Any comment will be appreciated. Mark as Solution if your query is resolved
__________________
Thanks in Advance
Zahid Haseeb

zahidhaseeb.wordpress.com

Nicolai's picture

I also see you have a "." in the exclude_list example in your'e post - is it a typo or do you really have named the exclude list "exclude_list." if yes rename the file to "exclude_list"

You you use the "." when you tailor the exclude_list with policy name - e.g. exclude_list.UNIX_FS - Then the exclude list will only work when the policy UNIX_FS kick in. A exclude list named "exclude_list" work for all policies.

You can also follow this tech note on how enabling bpbkar debugging, this way you can see how the bpbkar process determine what to backup and what to exclude:

http://www.symantec.com/docs/TECH31513

 

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

rizwan84tx's picture

The file is exclude_list there is no "."

Best Regards,

Rizwan

J.H Is gone's picture

/usr/openv/netbackup/exclude_list

/hgfs >> exclude_list. 

 

you have an exclude_list in netbackup dir

but what is that second line all about?

do you want to exclude the hgfs directory?

then the content inside of your exclude_list would be

/hgfs/

I don't have to know how to spell....I work on Unix.
NetBackup 7.0.1 - AIX & Windows

Andy Welburn's picture

i.e.

cat   /usr/openv/netbackup/exclude_list

There is no global exclude list unfortunately for any OS, altho' NB does exclude certain filesystems etc by default.

rizwan84tx's picture

Hi Andy,

 

Currently im out of office, will update the file content very soon!

Best Regards,

Rizwan

Vino.J's picture

Im working in Rizwan's Team.. The content of exclude_list is /hgfs

Marianne's picture

If backup selection is ALL_LOCAL_DRIVES with Allow Multiple Data Streams and /hgfs is a separate mount point, then a backup job will still be generated for the mount point, but only the empty mount point will be backed up (something small like 32 Kb).

Streams are generated right in the beginning of the job when the master requests bpmount output from client. Exclude list is only evaluated once the client needs to start generating the data streams.

Ensure bpbkar log exists on client for confirmation and/or further troubleshooting.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Vino.J's picture

Created bpbkar logs for the Server. Herewith I have furnished the error recieved :

Logs:

"

17:37:07.217 [8611] <2> read_exclude_list: INF - Reading /usr/openv/netbackup/exclude_list.Unix

17:37:07.218 [8611] <4> bpbkar: INF - BACKUP START

17:37:07.218 [8611] <4> bpbkar: INF - Estimate:-1 -1

17:37:07.240 [8611] <2> bpbkar add_to_filelist: starting sizeof(filelistrec) <112>

17:37:07.240 [8611] <4> bpbkar: INF - Processing /

17:37:07.262 [8611] <16> bpbkar: ERR - Cannot lstat hgfs. Errno = 5: I/O error"

Marianne's picture

Do you have a space between / and hgfs in exclude_list?

Please carefully check contents of exclude_list as well the location and/or spelling of hgfs  folder.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Vino.J's picture

checked and found that there is no space between / and hgfs.

Marianne's picture

This error is returned by the OS: "Cannot lstat hgfs."

Please double-check the location and/or spelling of hgfs  folder.

Please check with command such as 'ls -l /hgfs' and/or 'du -sk /hgfs'.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Andy Welburn's picture

GENERAL ERROR: Getting "Cannot lstat/lstat64 <filename>. Errno = 5: I/O error" during backups.
http://www.symantec.com/business/support/index?pag...

There are a few additional things you could possibly try under "Resolution"

rizwan84tx's picture

I browsed VMware forums and got the below info

HGFS - Host Guest File System, that gets installed while VMware tools installation for ESX based VMs which is a Bug as per VMware.

HGFS is required to enable file share between Guest OS and Host OS for VMware Workstation.

I guess unmounting this File system must not harm the guest at all. Before we try that; we will try link posted by Andy and update you soon.

Best Regards,

Rizwan

rizwan84tx's picture

Un mounted /hgfs in guest VM and deleted fstab entry for the mount. VM had no impact and no error found in backup aswell.

Best Regards,

Rizwan

SOLUTION