Video Screencast Help

Some SD Users only see Mobile View

Created: 12 Sep 2012 • Updated: 09 Oct 2012 | 5 comments
This issue has been solved. See solution.

We're running ServiceDesk 7.1 SP1 and I have several users, who upon login, are presented the mobile login, and mobile view portal pages. Trying to navigate to any non-moble page results in an error (can't remember it off hand). They are running IE9.

I have them open IE Developer Tools (F12), and look at the current "Browser Mode".  It's set to IE9 Compatibility view.  If I change the browser mode to IE9, IE8, or IE7, the page refreshes and they now see the standard portal view pages.

Anyone come across this issue? I can't very well tell the other odd thousand or so users to open Developer Tools and change their browser mode. I'm guessing I can add a strict <!DOCTYPE> somewhere, but any idea where I would do it?  In the IIS directory? Which page?

Any help would be appreciated.

Thanks

Comments 5 CommentsJump to latest comment

reecardo's picture

If possible, request a SP1 rollup.

The problem is that SP1 release is looking for particular strings in the USER_AGENT string of the browser. Unfortunately, these strings are not updatable by the user in the release build.

In the rollup, these strings have been moved to the web.config of ProcessManager so admins can modify them... it will look like this:

<add key="MobileBrowserStrings" value="midp,j2me,avant, ..." >

So if admins aren't concerned with mobile, they can set the line like this:

<add key="MobileBrowserStrings" value="" >

EDIT: Misspoke the 1st time... personally, I'd set the line to something that'll never happen in reality, like:

<add key="MobileBrowserStrings" value="FakeMobileStringYaddaBlah" >

lucsz's picture

Hi,

I have the same issue, some users are redirected to the mobile site. When I made changes like reecardo wrote - every single user is being redirected to the mobile site.

So I've decided to delete the line from web.config:

<add key="MobileBrowserStrings" value="midp,j2me,avant, ..." >

Now, the issue is no longer an issue :)

Can I have problems with SD after removing this line from web.config?

Lukasz

reecardo's picture

SD uses the same ProcessManager that Workflow uses, so it's perfectly safe to do this for SD as well.

toomas's picture

Unfortunately, this is a known issue. We have seen this mostly with some versions of IE8 and occasionally with Firefox 3.5, but it can happen to other browsers as well.

KB article: 
TECH182221: ProcessManager portal loads as mobile page in IE8 browser.
http://www.symantec.com/docs/TECH182221

As reecardo stated, contacting Symantec Technical Support and requesting the Workflow 7.1 SP1 Rollup is probably the best solution. The change made there is the detection logic is moved from being hardcoded to be configurable.

Without the rollup, the only way to change the behaviour is to make sure none of the detection strings are present in the client browser UserAgent string.

SOLUTION
alexanderyanes's picture

Hello. I had the same problem, but I found this KB article:

http://www.symantec.com/business/support/index?page=content&id=TECH182221

the mentioned route  in above page, for the register key, is not necesary the same path. In my case, I found it in this key:

HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\ Post Platform\

then, delete the string value “msn OptimizedIE8” , and it worked!

I hope it's util too.