Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

SQL Agent backup contains no data

Created: 11 Apr 2008 • Updated: 02 Mar 2009
Every weekday night we run a Working Set backup on some of our larger file servers that we don't have time to do a full backup on, but we always set the SQL Agent bit of the backup to be "Full - Backup entire database or filegroup". However, reading through our backup logs it seems that nothing is actually getting backed up. Example :
Set Information - AVDC-TARDIS   Backup Set Information   Family Name: "Media created 11/03/2008 19:00:04" Backup of "AVDC-TARDIS " Backup set #10 on storage media #1 Backup set description: "Tardis (Daily)" Backup Method: Full - Back up entire database or filegroup Microsoft SQL Server Agent: Started
Backup started on 11/03/2008 at 23:11:22.
Backup Set Detail Information   Backup completed on 11/03/2008 at 23:11:32.
Backup Set Summary   Processed 0 bytes in  10 seconds. Throughput rate: 0.000 MB/min
This backup set may not contain any data.
 
Now the backup reports that it has finished with a state of "Successful", so we didn't spot this problem for ages (yes, I know, I should be paying more attention to the logs!)
 
The weird thing is that when we do a Full Backup over the weekend, all the databases back up successfully, like so:

Backup Set Summary

Backed up 36 databases Processed 9,992,444,924 bytes in 9 minutes and 6 seconds. Throughput rate: 1047 MB/min

Anyone seen anything like this happen before?



Message Edited by Steven Robinson on 04-11-2008 02:08 AM