Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SQL authentication failed

Created: 25 Sep 2012 • Updated: 26 Sep 2012 | 6 comments
This issue has been solved. See solution.

Hello,

i wonder if BE admin guide is complete about the SQL pluggin, i explain:

i have many SQL in my environment, i can connect to instance successfully, but to databses themselves, i've got a failed test for all my databases.

I create an account with all rights (domain admin, sql admin, local admin, SQL service group)

I install last version of agent 14.0.1798

I check all requirements listed in admin guide

SQL database has to be published on AD?

What Admin guide mean by: BE server must have access to SQL installation?

So now i wonder what could block authentication, i try to launch the debuger, here the output:

MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.738[Job         ] TestResources, Sent VSN, Resource:srv-aut-sql\Microsoft SQL Server Instances, ID:d058afc8-cba6-4b10-afce-8cbeb510d2c7, CredFlags:Success, Attempted.
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.741[Job         ] Consider to continue testing, ParentResourceName:srv-aut-sql\Microsoft SQL Server Instances, ResourceName:srv-aut-sql\MSSQLSERVER DisplayName:srv-aut-sql\MSSQLSERVER, Flags:IsContainer, IsDevice, UsernameOptional, PasswordOptional, Selectable, ResourceIsVirtualizable, ResourceSupportsSinglePassDr, DSSSResourceType:Sql2Server DSSSResourceSubType:DpmRoot, uint:1
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.741[Job         ] Continuing test, ParentResourceName:srv-aut-sql\Microsoft SQL Server Instances, ResourceName:srv-aut-sql\MSSQLSERVER DisplayName:srv-aut-sql\MSSQLSERVER, VMNetName:, VMState:0, VMState:0x00000000
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.741[MetaData    ] QueryMetaData : 484354848
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.741[MetaData    ] QueryMetaData starts: MDQ_BackupResourceBrowsing_View
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.762[MetaData    ] QueryMetaData ends: MDQ_BackupResourceBrowsing_View rc=0 numrows=0
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.770[Job         ] TryBrowseTR localizedException: ConnectionName:srv-aut-sql\MSSQLSERVER, ResourceType:srv-aut-sql\MSSQLSERVER, LogonID:f3dd0a09-8375-4322-bccc-842cefbaff08.
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.770[Job         ] BrowseRecursive,  Error:MsgID:Message_UnableToConnect,  ReasonID:Reason_Generic
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.785[Job         ] TestResources, Sent VSN, Resource:srv-aut-sql\MSSQLSERVER, ID:3db1a88c-4c1d-418e-a26f-75487fff0cc9, CredFlags:Attempted, PromptUserHint.
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.788[MetaData    ] ReleaseMetaDataConnection : 484354848
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.895[Job         ] TestResources, Sent VSN, ResourceContainer: ID:e401441a-a65e-49f3-83b7-f9c08b096822.
MANAGEME: [09/25/12 15:01:30] [0029]     09/25 15:01:29.910[Job         ] Sent completed VSN for TestResources: ffb03b87-058f-4185-9b3b-4c17f39bf9e8, Canceled:False.
BESERVER: [09/25/12 15:01:33] [6016]     09/25/12 15:01:32 -1 SecurityBO: Successfully setup RAWS certs.
 
 
Any help will be apreciate, we are not able to backup any SQL database since few weeks. These databases were previously well backuped, but now that customer administrators works on AD ans security, no means to do my job, and they don't see what could block BE :)
 
Thx

Comments 6 CommentsJump to latest comment

Jaydeep S's picture

Was there any change in any permissions as such cause if it was working, it should be working. You could see if these articles help -

http://www.symantec.com/docs/TECH68586

http://www.symantec.com/docs/TECH130255

Cause to backup the SQL database, the BE account needs permissions on the SQL Databases and also the Database files (NTFS permissions)

It would be more helpful, if you could post the error in the job log or the resource credentials tab

Sush...'s picture

Hello Nic,

    try to perform the SQL UDL test as per the following technote

http://www.symantec.com/docs/TECH24708 : How to perform a quick test connection to the Backup Exec SQL instance.

In the UDL test try to connect to the remote SQL instance which needs to be backed up. Also login into the Backup Exec server the user which is used for the backups.

Thanks,

-Sush...

Hope this piece of Information Helps you... and if it does then mark this response as Solution....!!!

nicnictout's picture

I try to add role serveradmin and sysadmin to my user, no changes.

The message returns by BE when i try to backup this database is (translate from french):

link impossible to this ressource, check if it still available, change selection...

Even my DBA is going crazy, he cannot understand why it is not working whereas user has all privileges !

nicnictout's picture

Ok i try your tutorial Sush,

it's working perfectly, i am able to connect to any database with your tips, but in BE 2012, my issue isn't solved!

Authentication tests are always in fault...

Jaydeep S's picture

nicnictout could you please check the SQL Agent Log from the SQL Management Console for any possible errors.

Also you could start sgmon.exe (RAWS install folder) on the SQL server with RAWS debug to be captured along with capture to file and then perform the authenticaton from Media Server. Once this is done, please post that log. This should give us a better idea.

nicnictout's picture

Hi guys,

we finaly find the root cause !!

We didn't put the SQL databases in mixte mode, now it's working fine.

Of course we keep the account will all privilegies: sysadmin, local admin, remote admin, we give him my boss' black mastercard, and the RED phone to keep in touch with God, and it decided to work properly... :)

Thx anyway for your help, and have a nice day !

SOLUTION