Video Screencast Help

sql database failed with error code 17. 83 via SAN client

Created: 04 Dec 2012 • Updated: 07 Jan 2013 | 9 comments
NBU_13's picture
This issue has been solved. See solution.

Hi,

I have issue with Sql database backup with SAN client.

I have Linux media server (FT media server) and Windows client (SAN client)

File system backup are running fine and its completed successfully with this SAN client, but sql database backup job are failed with status1, due to one of the database (db.master) geting fail with error code 17,83.

 

NUMBER_DATA_BUFFERS_FT : 32

SIZE_DATA_BUFFERS_FT - 262144

and then I restarted sql database backup from SAN client,

Once database backup job has started, its running 4 child jobs + 1 parent job, 3 child jobs are successful and one child job has failed with erros as below

3-Dec-12 17:26 - Error bptm(pid=19800) Could not open FT Server pipe: pipe open failed (17)
03-Dec-12 17:26 - Info bptm(pid=19800) EXITING with status 83 <----------
03-Dec-12 17:26 - Info bpbrm(pid=19795) got ERROR 83 from media manager
media open error(83)

and parent job has completed with status code 1

as per job details,

SOL, msdb, model database are successful, only master database are failed with error code 83, 17

Note : Linux OS (FT media server) and windows 2008 (SAN Client)

Any can help me on this issue, to resolve?

Thanks

Comments 9 CommentsJump to latest comment

Mick Scott's picture

You dont say what version of NBU

have a look at  http://www.symantec.com/docs/TECH155301

it may be necessary to reduce the NUMBER_DATA_BUFFERS_FT

Yogesh9881's picture

Hi,

Need to isolate this issue ....

kindly configure test file level backup for the same client (atleast 10 GB) & let us know the status.

If this post has helped you, please vote or mark as solution.

Before break-up, make sure you have a good backup.....  ;-)

NBU_13's picture

Hi,

I run the test backup for file system, for 100GB, its running fine. once issue with sql database backup and also only 1 database (master) gettting fail with Error code 83, other 3 database (sol, msdb, model) are getting successful.

and also I opened case with symantec before 3 days, yesterday I get the call and I provide all information, but no responds after that.

Marianne's picture

PLEASE follow advice in your other post to open a Support call with Symantec? 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

NBU_13's picture

Hi,

Today, I created batch file for each sql database (master, msdb, model and sol), its running fine and completed successfully via SAN,

So, Finally, I create two batch file, one batch file for sol, and another batch file for (msdb, model and master) with 2 seperate policies, now all four sql database are running fine and getting completed successfully.

 

is this fine ? or need to do any changes ?

NBU_13's picture

Hi,

Anyone please guide, If I create batch file for all 4 database (master, msdb, model and sol), its getting fail with error code 83 with one database (master) via, but if I use 2 seperate batch file for database (sol) and database  (msdb, model and master), then its running fine and completing successfully.

but, my client request, they want single batch file with $ALL

can anyone help me on this issue.

Thanks.

Marianne's picture

Get your call with Symantec escalated.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

NBU_13's picture

Yes, i already opened call with symantec and also provided error logs,

They are working on it,

I will update.

NBU_13's picture

Hi,

Sql database backup failure issue with Error code with 83 through SAN has fixed.

The below hotfix patch installed on FT media server and SAN client.

Now, all 4 sql database are running fine as single policy and completing successfully.

eebinstaller.2748951.1.LinuxR_x86.exe <<-- apply this on Linux RH Media server eebinstaller.2748952.x86.exe <<-- apply this on Window Client

 

Thank you..

SOLUTION