Video Screencast Help

SQL part of Backup Job fails

Created: 27 Jun 2012 | 1 comment
BFM's picture

I have BE 2010 R3

I am using the SQL agent to backup a SQl Database file.  There are daily tables that The app each night archives then deletes the oldest one.

The creates the problem.

V-79-65323-911 -
An error occurred on a query to database i010040000100120120202.
V-79-65323-911 - Could not locate entry in sysdatabases for database 'i010040000100120120202'. No entry found with that name. Make sure that the name is entered correctly.
 

You see this is the 2/2/2012 table and it is not in the Sysdatabases file. 

Tje text version of the selection list is

\\IMSMCC1\G:\SQLData\MSSQL.1\MSSQL\Data\*.* \SUBDIR

The above database is not in the above folder thus the error.

How can I resolve this?

Thanks

 

Comments 1 CommentJump to latest comment

navintah's picture

Hi:

It sounds like the app somehow is deleting the database and not the table or both. If the database entry is not in the sysdatabases table in the master database and the files are not on disk, then the database and not just the table is somehow getting deleted.

Few questions which may help us in diagnosing the issue:

- How long you have been using this app to modify the tables in the database? Has it worked before with the Backup Exec SQL Agent?

- Are you selecting the database to back up or the files that make up the database?

- What happens when you run a SQL backup through the SQL utility?

Thanks

Navin