Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SQL Reporting Services - unmatched default SQL collation

Created: 22 Mar 2013 • Updated: 27 Mar 2013 | 1 comment
This issue has been solved. See solution.

Environment:

  • Enterprise Vault 10.0.2
  • Windows 2008 R2

I ran Enterprise Vault Deployment Scanner and got an error for “unmatched default SQL collation”.  The only databases that are “unmatched default SQL collation” are the Reporting databases:

  • EnterpriseVaultReport
  • EnterpriseVaultReportTempDB

 Untitled.jpg

Untitled2.jpg

 

SQL 2008 default collation is SQL_Latin1_General_CP1_CS1_AS

SQL 2008 Reporting Service default collation is Latin1_General_C1_AS_KS_WS

How can we change the default collation for Reporting Services?  Should this be something to be concern as it only the Reporting database?

From what I understand is that we will have an issue if we do any EV upgrade in the future.  After reading a lot of articles on the internet, most stated common EV databases should match to the master collation but nothing about Reporting database.

We tried several scripts that mentioned in the other article on how to change the collation, but it failed every time we tried it.

Can we create a new Reporting database and somehow to tell it to use the correct collation?

 

Operating Systems:

Comments 1 CommentJump to latest comment

JesusWept3's picture

as long as the Master/Model/TempDB databases match the collations of the Directory/VaultStore/Fingerprint databases, then you are absolutely A-OK, the reporting services is nothing to be concerned about at all.

If you did want to make it match though, i think your best bet would be to simply uninstall the reporting services, delete the reporting db's, and then reinstall and choose the proper collation if its not taking it from the model db, but its a bit aimless really

Regardless, this won't stop your upgrades from occuring and won't cause any issues for EV

SOLUTION