Video Screencast Help

SQL Restoration Failed

Created: 02 Sep 2013 • Updated: 05 Sep 2013 | 8 comments
This issue has been solved. See solution.

Hi All, 

 

We have SQL server on Windows 2008 (not R2) and SQLserver 2008 running, NetBackup is version 7.5.0.4. We did test restore after backup before successfully. Now when we tried to restore, we always encounterd a failure.

 

 

09/02/2013 16:05:19 - begin Restore
09/02/2013 16:05:20 - number of images required: 1
09/02/2013 16:05:20 - media needed: 401164
09/02/2013 16:07:41 - restoring from image ermapp01-bck_1377612219
09/02/2013 16:07:43 - Info bpbrm (pid=5540) ermapp01-bck is the host to restore to
09/02/2013 16:07:43 - Info bpbrm (pid=5540) telling media manager to start restore on client
09/02/2013 16:07:46 - Info bpbrm (pid=3176) ermapp01-bck is the host to restore to
09/02/2013 16:07:46 - Info bpbrm (pid=3176) listening for client connection
09/02/2013 16:07:48 - requesting resource 401164
09/02/2013 16:07:48 - awaiting resource 401164. Waiting for resources. 
          Reason: Media is in use, Media server: N/A, 
          Robot Type(Number): NONE(0), Media ID: 401164, Drive Name: N/A, 
          Volume Pool: N/A, Storage Unit: N/A, Drive Scan Host: N/A, 
          Disk Pool: N/A, Disk Volume: N/A 
09/02/2013 16:08:32 - Info bptm (pid=4792) Waiting for mount of media id 401164 (copy 1) on server ebs5-bck.
09/02/2013 16:08:32 - started process bptm (pid=4792)
09/02/2013 16:08:32 - mounting 401164
09/02/2013 16:08:32 - granted resource  401164
09/02/2013 16:08:32 - granted resource  ESL02_Drive9
09/02/2013 16:08:34 - Info bptm (pid=4792) INF - Waiting for mount of media id 401164 on server ebs5-bck for reading.
09/02/2013 16:09:30 - mounted 401164; mount time: 0:00:58
09/02/2013 16:09:30 - Info bptm (pid=4792) 401164
09/02/2013 16:09:31 - Info bptm (pid=4792) INF - Waiting for positioning of media id 401164 on server ebs5-bck for reading.
09/02/2013 16:09:31 - positioning 401164 to file 114
09/02/2013 16:09:41 - positioned 401164; position time: 0:00:10
09/02/2013 16:09:41 - begin reading
09/02/2013 16:09:54 - Info bpbrm (pid=5540) media manager for backup id ermapp01-bck_1377612219 exited with status 25: cannot connect on socket
09/02/2013 16:09:54 - Info bpbrm (pid=5540) terminating bpbrm child 3176 jobid=331224
09/02/2013 16:10:52 - Error bpbrm (pid=3176) listen for client protocol error - couldn't accept from data socket, An operation was attempted on something that is not a socket.  (10038)
09/02/2013 16:10:52 - Info bpbrm (pid=5540) child done, status 25
09/02/2013 16:10:53 - restored from image ermapp01-bck_1377612219; restore time: 0:03:12
 
 
Any idea what went wrong?
 
Thank you,
 
Iwan Tamimi
Operating Systems:

Comments 8 CommentsJump to latest comment

rookie11's picture

your clientname ermapp01-bck

please check clientserver to media server and master server connection working, check vice versa also.

please post detail logs as well. bpbrm logs will help

Iwan Tamimi's picture

Hi rookie, 

Thanks for the response, the bpbrm logs is on the client side right? I think it hasn't been created. I created then I tried again after that I post it again. 

Regards, 

Iwan 

AjinBabu's picture

HI,

It looks some socket error “couldn't accept from data socket”. Could you check the following?

1.     On your master server check move to Host Propertiesà clientsà select the your SQL server à

Right click and connect, make sure that it is able to connect.

2.       Is any job is getting started on NBU activity monitor while you start from client’s BAR GUI?

Regards

Ajin

Iwan Tamimi's picture

Ajin, 

1. Yes it is enabled (see attachement). 

2. No other backup running for this client. 

 

Regards, 

Iwan 

Screen Shot 2013-09-03 at 1.47.12 PM.png
Mark_Solutions's picture

Are you running this restore from the client itself using the NetBackup SQL GUI?

You cannot run SQL restores from the BAR Console

It does sound like a connection issue but that could be an ODBC issue is you are not running it from the right place

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

captain jack sparrow's picture

pls post dbclient log and mssql_backup_failure log from client you are performing restores.

If log dir doesnt existing create them and re-run restore job

Also post restore script (if used NBU SQL GUI instead of BAR)

 Cheers !!!

CJS

 

rookie11's picture

Iwan -- bpbrm logs are on media server. media server through which restore is running

Iwan Tamimi's picture

Hi All,

Thank your for all of your support. We resolve the problems.

Actually 2 things happened, see the solutions:

1. The brpd hung:

The restore seemed hung at 'media id needed'

It seemed that bprd process is hanging, check with bpps

# bpps -a | grep bprd

Kill the process bprd -dontfork -mpxmain with kill -9

I got the solution from:

http://www.symantec.com/connect/forums/unable-restore-data-nbu-75

http://www.symantec.com/business/support/index?page=content&id=TECH33379

2. This one is the SQL client part:

Restoration error: (cannot connect on socket)

09:02:50 (325439.002) INF - Waiting for positioning of media id 401164 on server ebs5-bck for reading.

09:03:36 (325439.002) INF - Beginning restore from server ebs5-bck to client ermapp01-bck.

09:04:05 (325439.002) Status of restore from copy 1 of image created Tue Aug 27 22:00:42 2013 = cannot connect on socket

 

Resolution: Within the Admin Console > Host Properties > Master > Client Attributes > Client > Browse and Restore Ability > Allow Both

Resolved the issue

(He got the solution also from the this forum too, but forgot which one)

 

Regards,

Iwan Tamimi

 

SOLUTION