Video Screencast Help

SSIM replication database error and max SSIM EPS

Created: 14 Dec 2012 | 16 comments


i have replication problem.I received database db2_password corruption error. how to resolve it? I did follow the instruction for the 2 SSIM replication pdf.


What is the max EPS for SSIM on-box collector and off-box collector. I found max message per hour for Kiwi syslog is 300K per hour.

Comments 16 CommentsJump to latest comment

bluepimple's picture

Question 3

When i installed sidewinder off-box collector, i was told to install SESA installation. i can't find the application. can anyone direct me to the download page?

olaf's picture

When you install a offbox collector you first have to install the SSIM agent which can be downloaded for different platforms from the Web-UI.

For example for SSIM 4.7

Login to Web-UI of SSIM appliance and go to Home->Downloads

olaf's picture

Where do you get the db2_password corruption error? I never heard of such an error message.

alvingarlic's picture

I had the same problem:

when i run

gsk7cmd.ssim -cert -extract -db /etc/symantec/ses/key.kdb -label SESA -target /tmp/master.crt -pw `/opt/Symantec/simserver/bin/ /etc/symantec/ses/key.sth`.                                                          Error id: GSKKM_ERR_DATABASE_PASSWORD_CORRUPTION
 DETAIL:  /etc/symantec/ses/key.kdb

gsk7cmd.ssim -cert -add -file /tmp/master.crt -db /etc/symantec/ses/key.kdb -label MasterCert -format ascii -trust enable -pw `/opt/Symantec/simserver/bin/ /etc/symantec/ses/key.sth` /* Error id: GSKKM_ERR_KEYDB_NOT_EXIST
 DETAIL: /etc/symantec/ses/key.db

gsk7cmd.ssim -cert -extract -db /etc/symantec/ses/key.kdb -label SESA -target /tmp/replica1.crt -pw `/opt/Symantec/simserver/bin/ /etc/symantec/ses/key.sth`                                                                 Error id: GSKKM_ERR_DATABASE_PASSWORD_CORRUPTION
        DETAILS: /etc/symantec/ses/key.kdb

olaf's picture

What happens when you rubn the following command:

/opt/Symantec/simserver/bin/ /etc/symantec/ses/key.sth

This should return the password for your key database.

Does it start with any special character like "-".

Also be aware about the ticks you use. They are forward ticks `, not the normal tick '.

You can also use the password which is returned from the command. For example when it returns ndg563kdhty:

gsk7cmd.ssim -cert -extract -db /etc/symantec/ses/key.kdb -label SESA -target /tmp/replica1.crt -pw ndg563kdhty

alvingarlic's picture

i installed SSIM agent but when i install sidewinder collector, It prompt me that SESA installation is missing.

I install juniper, snare off-box collector, i have no sure problem

i uninstalled SSIM agent and reinstalled SSIM agent, problem still persist.

olaf's picture

Are you trying to install the sidewinder collector on a 64-bit machine?

The problem is that the old 4.2 collectors were not designed to install on a 64-bit system.

alvingarlic's picture

yes, i am using sidewinder collector on a 64-bit machine.

What should i do? who should i approach for solution? Or if i can get a download site from you?

alvingarlic's picture


I encounter problem.

/opt/Symantec/simserver/bin/ /etc/symantec/ses/key.sth

gsk7cmd.ssim -cert -extract -db /etc/symantec/ses/key.kdb -label SESA -target /tmp/replica1.crt -pw ?ScSI5KuQfIsv


Please refer to the GSKCapiCmd User's Guide
details: /etc/symantec/ses/key.kdb

olaf's picture

I tried on a SSIM 4.7.4 appliance with a password starting with a ?, but I don't see this problem.

Can you put the password into double quotes, like is described here.

IMPORTANT: On Unix type operating systems it is recommended to always

encapsulate string values associated with all tags in double quotes (“”). You

will also need to escape, using a ‘\’ character, the following characters if they

appear in the string values: ‘!’, ‘\’, ‘”’, ‘`’. This will prevent some command

line shells from interpreting specific characters within these values. (e.g.

gsk7capicmd –keydb –create –db “/tmp/key.kdb” –pw “j\!jj”). Note however

when prompted by gsk7capicmd for a value (for example a password) quoting

the string and adding the escape characters should not be done. This is because

the shell is no longer influencing this input.

So in your case:

gsk7cmd.ssim -cert -extract -db /etc/symantec/ses/key.kdb -label SESA -target /tmp/replica1.crt -pw "?ScSI5KuQfIsv"


gsk7cmd.ssim -cert -extract -db /etc/symantec/ses/key.kdb -label SESA -target /tmp/replica1.crt -pw "`/opt/Symantec/simserver/bin/ /etc/symantec/ses/key.sth`"

alvingarlic's picture

I was told by my collegue sidewinder collector run successfully on 64bit OS and isn't SESA installation supposed to be with agent installation?

olaf's picture

The collector install.bat doesn't detect the path where the agent is installed.

This is a problem of 4.2 collectors.

4.3 collectors and later willl detect the path of the agent installation correctly.

alvingarlic's picture

I resolved the collector problem yesterday so agent can recognise the path. Tested working.

Now leaving only data replication.

alvingarlic's picture


maximum EPS per collector on box, off box is ~2200

Thus if i have snare offbox collector, sidewinder collector, juniper collector,

6600 events, can event agent take this bulk of EPS of there is no limit

alvingarlic's picture

Hi olaf

I have two SSIM and i need a simple HA solution but without avail.

Can you offer some guide(pdf file, link) and solution?

Also Happy Christmas

alvingarlic's picture


I am wondering if LDAP replication is part of the SSIM slave-msater replication?
I was told by my collegue it may not be the same