Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SSL and Software Delivery (CMS7)

Created: 03 Mar 2009 • Updated: 07 Aug 2012 | 4 comments
powellbc's picture
This issue has been solved. See solution.

I know this is a little early but here goes:Our Test CMS7 server has SSL enabled on the default website.  Because of this, I set Altiris Agent Settings - Targeted > Advanced to define the URL of the server as https://NSNAME/Altiris under the "Alternate URL for Accessing NS" setting.  The client agents are checking in fine but they are unable to download packages because it is trying to do it over HTTP, not HTTPS.  There are no sites defined, so no package servers.

I also tried running AeXAgentutil with the /server and /web switches on a client but still it won't download the package via HTTPS.  The URL just shows up as HTTP.

Does anyone know why this might be happening?

Comments 4 CommentsJump to latest comment

SK's picture

If you go to the websites properties (Default Web Site, or a custom one) > Directory Security > Server Communications > Edit, is the "Require secure channel (SSL)" option enabled?

If it isn't, then please enable it, and then restart IIS. 

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

powellbc's picture

It is enabled and I have restarted IIS multiple times.  The agent is pointing to HTTP and I can browse out to the package path using HTTPS, so it is not a Web server issue.

This issue is still affecting me on our new system.  Any ideas on how to rectify this?

jharings's picture

(configuration of IIS, redirecting the clients, getting and accepting a certificate, etc) the only thing that seems to apply is that the package codebases are not coming down over HTTPS (rather http). Is this correct?

If so, did you try restarting the NS Package Refresh scheduled task? See Altiris KB34101 for confirmation.

Jim Harings
HP Enterprise Services
1st Rule of Connect Club: Mark the post that helped you the most as a 'solution'. 2nd Rule of Connect Club:You must talk about Connect club.

SOLUTION
powellbc's picture

Thanks for pointing me in this direction, It has addressed the issue. I think I may have had the fix going already but was impatient as the changes are not immediate.  Thanks very much Jim.

Bryan