Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

SSR 2011-Error when trying to choose drives when creating Backup Policy

Created: 09 Feb 2013 • Updated: 11 Feb 2013 | 7 comments

Hello experts. First post, because I could not find this issue anywhere in the forums.

When creating a new Independent Recovery Point backup policy for a client PC, I click on "All drives on selected computers" next to drives:. I used to get a big list of drives from which to choose, but now I get "An unexpected error has occured in the application. For further details, see Altiris Log Viewer."

I launched the viewer and found the error in the logs. Here's the output:

 

I've rebooted the server just for safe measure, but same results. So, my only current option is to leave "All drives" selected when creating a new backup policy. Any help would be appreciated! Thanks.

Comments 7 CommentsJump to latest comment

TRaj's picture

Open a support ticket with System Recovery.

We are requesting you to mark the forums as Solution , so that is makes easier for the viewer to search and refer the posts with "Solutions"

Markus Koestler's picture

So do I get it right that you encounter this issue: http://www.symantec.com/business/support/index?pag...

 

If yes try this steps:

-Connect to your SSR MS Database

-run the following query:
SELECT [_id]
      ,[_ResourceGuid]
      ,[GeneratedFilename]
      ,[GenericVolumeID]
      ,[Label]
      ,[Machine]
      ,[MinSize]
      ,[Mounted]
      ,[MountPoint]
      ,[ObjectId]
      ,[OSServicePackVersion]
      ,[OSVersion]
      ,[PartitionOrientedType]
      ,[PartSize]
      ,[Size]
      ,[SizeMB]
      ,[State]
      ,[System]
      ,[TrackingJob]
      ,[Type]
      ,[Valid]

  FROM [Symantec_CMDB].[dbo].[Inv_BESR_Volume]

-Look for the row(s) where GenericVolumeID has value of NULL

-Edit that row in the Inv_BESR_Volume table and enter the correct value in GenericVolumeID field e.g. C:\oder D:\ ist

*** Please mark thread as solved if you consider this to have answered your question(s) ***

ElliotN's picture

Thanks for the replies. My original problem is solved. I followed the directions in the link Markus provided. I ran the report. Found a computer listed with no drive info. I deleted that computer from SSR 2011 Computer list under the Manage tab.

The computer showed up again due to the agent checking in, which is fine, but now it shows "Not Installed" under Home-->Manage Tasks-->Computers list. I did not uninstall anything from the client computer. Any way to get SSR-MS to recognize that it's installed on the client again?

 

Thanks

Markus Koestler's picture

Try first to restart the AexNSclient service twice, if this does not help simply reinstall the SSR-MS plugin.

*** Please mark thread as solved if you consider this to have answered your question(s) ***

ElliotN's picture

Thanks Markus. This worked to bring back the culprit client computer to be recognized as 'installed', but once it came back showing "Backed Up" instead of "Not Installed", it showed the same null value for the Volume, zero MB for Volume Size, Free Space=87435 MB, and -87435 MB for Used Space.

So, there must be a problem in the way the client computer is reporting itself to the MS. Any ideas?

BTW, the service I had to restart on the client PC was AeXAgentSrvHost. And then I had to open the agent, so the Settings, and click Send and Update for SSR MS to see it as installed.

Thanks again!!

Markus Koestler's picture

Well try to reinstall tha altiris agent ?!

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Markus Koestler's picture

Have you tried to reinstall alreday ?

*** Please mark thread as solved if you consider this to have answered your question(s) ***