Video Screencast Help

SSR 2011 not showing failed or missed backups.

Created: 01 May 2013 • Updated: 30 Jul 2013 | 31 comments
This issue has been solved. See solution.

Hi,

I'm using a SSR 2011 Management Solutions.

Here i've setup 2 policy's and 1 filter, meaning that a client receives 2 Backup Jobs.

Through the Management Agent the SSR 2011 on the client does receive its Jobs.

Each Jobs has a different destination.

When the first Job has been done succesfully but the second Job has failed.

It reports to the home screen that the system has been fully backed up.

The Jobs are running every week, but i found a Computer that had missed a job for half an year without reporting that it has missed a job.

How do i change this that every missed or failed job is reported.

 

With Kind regards and thanks in forward,

Dennis Velthuis

Operating Systems:

Comments 31 CommentsJump to latest comment

Chris Riley's picture

So it sounds like the 2 jobs are backing up the same volume(s) - can you confirm.

Denus's picture

Yes the same volumes,

one Job does C:\ and D:\ to E:\

the other job does C:\ and D:\ to 'network destination'.

 

it doesn't matter which job gives the error.

 

Example from a computer:

If the local job (to E:\) runs into a fail, and the offsite job (to network) finished normally.

The message to the clients home tab says that it has been succesfully backed up. Same message on the SSR 2011 Management Solutions

Chris Riley's picture

OK, I think this is expected behavior because the drive has been backed up recently.

Is there any reason why you have 2 jobs configured? I think a better way would be to have one job and then use the offsite copy feature to copy the recovery points to the network destination.

Denus's picture

The local job is incremental and runs every week.

The offsite job is independent and runs twice a month.

This due to network traffic

Chris Riley's picture

You could setup STMP notifications which would allow you to monitor the status of backups.

Can you confirm what was causing the backup failure?

Denus's picture

Doesn´t matter which error is generated.

To confirm your question: not enough disk space for the backup.

 

Example from one of the computers:

12% disk space left, 9,6GB free on 80GB disk/partition. But the backup is bigger than 10GB.

Causing an error that the Backup to E:\ has failed.

 

While the offsite doesn't have an error it will report to the home screen and to the Management Solutions that the computer is backed-up.

Denus's picture

FYI

The network is not connected to the internet.

 

We did used the offsite copy method (not 2 jobs, but 1 job with copy feature)

If the Backup succeded and the copy had failed, no error was created.

Chris Riley's picture

I'm not sure I follow you...

However, I will try and explain: if offsite copy fails, it will not affect the overall status of the machine (i.e. 'Backed Up, 'At Risk' etc).

Denus's picture

That's the reason we removed the offsite copy from the local job and made it a job of its own.

If the offsite fails, the 'SSR 2011 Management Solutions' will show the computer its status as 'Backed Up', thats incorrect because the offsite has failed.

Chris Riley's picture

I see where you are coming from and I kind of agree with you.

However, the current design of the product is that the overall status of a machine wont be affected by the offsite copy success/failure. The primary backup was successful - that is the key as far as the overall status is concerned.

Going back to your original issue....can you clarify the exact schedule you are using for each job. Once I know this, I will see if I can try and reproduce the issue here.

Denus's picture

These are 2 policy jobs from Group A (set-up in the "SSR 2011 Management Solutions").

For each day of the week we got a different job (Group A(Monday) to Group G(Sunday))

 

Policy Job 1:

Type: Recovery Point Set

Drives: C: D: 0-1

Schedule: Every Monday 4:00 (Start a new recovery point set (base): Monthly

Destination: e:\backup\

Advanced options:

  Activate Backup policy

  Limit the number of recovery point sets (bases) saved for this backup Maximum: 2

  Verify recovery point after creation.

Applied to: 

Group A

 

Policy Job 2:

 

Type: Independent recovery point

Drives: C: D: 0-1

Schedule: Every 3:00 on days 1,12 of every month (For example: Group G is 7, 18)

Destination: \\<Networklocation>\systemimages\

  Create subfolder for each computer

Advanced options:

  Activate Backup policy

  Limit the number of recovery point sets (bases) saved for this backup Maximum: 2

Applied to: 

Group A

 

If one of these jobs failed, the SSR 2011 Management Solutions won't receive an error.

 

The primary backup was successful - that is the key as far as the overall status is concerned.

But the job had failed, meaning that the overall backup is not succesfull. 

 

Edit: added 'Verify Recovery Point after creation' to Policy job 1.

This option was allready set, i forgot to mention it in this post.

Denus's picture

SSR2011melding.png

Today i encounterd the problem on a computer.

I discoverd it because "Backup(E:\)" has less then 10% free disc space.

I selected the 1st Backup job and the system is "Backed up" with the green check image.

I also tryed to select the 2nd Backup job but the "Backed up" message is still there.

I fixed the disk space error by deleting some old backups. On the Home screen everything is fine and the screen is green (Backed up).

I don't know why the backup job has failed. This task had nothing to do with E:\, and the system didn't went unstable when the backup job was running.

 

This time it did send a "attention needed" to SSR2011 Management solutions that a asssigned job hasn't run for a long time, or maybe missed it.

The basic inventory is send with an interval of 1 day. 

But i also have seen systems that have not reported the missed backup for longer than 1 day. i didn't checked if the basic inventory was send for a long time, but will check it when i encouter it.

kind regards!

Denus's picture

I discovered that we don't have SP2 installed yet.

I asked my colleagues why they did not installed it yet. They replied that the update must be done with an internet connection.

The server can't be connected to the internet. How do i install the SP2 without an internet connection?

So far i've not found a manual for that yet.

Denus's picture

FYI:

clients are running:

SSR2011 server edition 10.0.2.44074

 

server is running:

Symantec management Console version 7.1.6851

Altiris Notification Server version 7.1

Chris Riley's picture

SSR2011 server edition 10.0.2.44074

That is SP2. SP3 is the latest available and you can get it here:

http://www.symantec.com/docs/TECH195461

The server will need rebooting after installing this.

I'm not saying this will resolve your issue but it's good practice to update to the latest SP.

Denus's picture

I will install SP3 on some of our machines today.

 

As you confirmed that we have SP2 installed we still receive errors same like this:

http://www.symantec.com/business/support/index?pag...

 

Chris Riley's picture

As per that article, you need SP2 for the Management Solution.

When I mentioned SP3 earlier, I was referring to the client versions.

These are 2 different things.

Denus's picture

I know you reffered to the client, and did install SP3 succesfully on one of the computers (not rebooted yet).

 

Some more information from SIM:

Symatec Management Platfom 7.1 SP1 (v7.1.6851)

Symantec NS WebServices (v7.0.60)

Symantec System Recovery 2011 Installer SP2 (v10.0.2)

Symantec System Recovery 2011 LightsOut Restore SP2 (v10.0.2)

Symantec System Recovery 2011 Management Solution x64 SP2 (v10.0.2)

Denus's picture

I installed SP3 on a client, after i rebooted the computer i immedietly recieved an At Risk error (simular to: http://www.symantec.com/business/support/index?page=content&id=TECH155022 (also mentiond 2 posts ago)) on the Management Solution.

I resetted the agent with the Button in the agent itself, but the error still remained.

I tryed to send its basic inventory (with the agent on the local machine) but the timestamp won't update.

I stopped the 'Symantec System Recovery' service in services.msc.

also stopped the 'Symantec Management Agent' service.

I started the 'Symantec System Recovery' application and wait till it completes getting information.

I start the 'Symantec Management Agent' service again (icon in tray pops up again).

I click the reset agent button (Just to make sure).

I checked the error on Management Solutions and it still remains.

I clicked te Send button to send its basic inventory (this time the timestamp does update).

I checked the error on Management Solutions and it is gone.

Denus's picture

I received an error (attention needed) from another computer that a backup has not run for a long time (18 days ago).

I logged into that computer and the backups did run succesfully (4 days ago).

 

I conclude that with a minimum of 4 days length, the agent has repoted false information.

 

My actions:

I tryed to reset the agent with the button in the application.

I tryed to send the basic inventory.

I stopped and started the service: 'Symantec Management Agent'.

I sended the basic inventory.

the error was cleared on Management Solutions.

Denus's picture

Sometimes when i randomly check SSR2011 on a client. It runs through the first-time startup screens. Accepting the terms and asking to run live update etc.

This is not a SP3 client.

 

Edit: It has reported the backup that has been done 4 days ago.

But not the backup 2 days ago.

It did send it's inventory yesterday.

I had to stop/start both services again, else SSR2011 won't startup (holds on connecting).

since the services had been restarted, the timestamp of the basic inventory sending remains the same.The reporting to the Management solution was correct now. I don't know what updated it.

Denus's picture

Another Computer failed to report properly.

The computer was rebooted unexpectedly, Solution Manager threw an error (At risk) after the Computer was rebooted again. (Enum error: http://www.symantec.com/business/support/index?page=content&id=TECH155022)

I logon to the computer and noticed that the system tray icon of SSR2011 didn't had warning (simular to attention needed, at risk, backup up, running backup, etc.)

I tryed to double-click the icon to open SSR2011 but it won't start, right-click and a grey menu pops up without components to choose from.

I only stopped the VProSvc service and SSR2011 started up immediately (VProSvc was started automatically).

The last local backup was 17/04, should be 15/05. It missed 3 backups without warnings to Management Solutions.

I've searched for the changelog of SP3:

 

2823129: VProSvc goes unresponsive / locks when NIC cable to network share unplugged at 6%-7%.
 
Maybe this is the causing problem.
I thought the restart of VProSvc should solve the problem since there is local no warning visible.
 
But after a couple of hours it still gives the At Risk error.
 
The inventory was also send less then an hour ago (45 min).
Error still remains.
 
Clicked the reset Agent button. Error remains.
Clicked Send Inventory. Error remains
 
Restarted services: Symantec System Recovery & Symantec Management Agent. Error Remains.
 
Clicked the reset Agent button. Error remains.
Clicked Send Inventory. Management Solutions reported the computer was backed up.
 
That is incorrect because 1 job had missed 3 times.
 
 
Denus's picture

On the Computer where SP3 is installed:

VProSvc freezes while making an backup. (Offsite without validation)

So my guess that VProSvc should be fixed in SP3 is wrong.

Denus's picture

Is there any progress here?

Are there already some answers?

Chris Riley's picture

Sorry for the delay in getting back to you on this.

It seems that you have multiple issues here. To ensure I understand everything, can you please recap in bullet points the current issues you are facing?

Denus's picture
  • VProSvc freezes (also on SP3), resulting that the console won't work properly
  • Symantec Management Agent freezes (not reporting properly to server)
  • Symantec System Recovery Details, Events, <Unknown result name 'INFO_NUM_TEXT> (also on SP3)
Chris Riley's picture

Symantec System Recovery Details, Events, <Unknown result name 'INFO_NUM_TEXT> (also on SP3)

This should be fixed in SP2 for SSR-MS (http://www.symantec.com/docs/TECH155022). It seems you are already on SP2 so this will need a formal support case opened.

Symantec Management Agent freezes (not reporting properly to server)

You need to ensure the agent is up-to-date. From your earlier post ('Symatec Management Platfom 7.1 SP1 (v7.1.6851)'), you are not on the most recent version of SMP.

VProSvc freezes (also on SP3), resulting that the console won't work properly

Can you explain this one in more detail please? What happens exactly? How many client machines are affected? etc etc

Denus's picture

 

VProSvc freezes (also on SP3), resulting that the console won't work properly

Can you explain this one in more detail please? What happens exactly? How many client machines are affected? etc etc

Received on the server: "Backup Status: This computer is at risk."

1) I checked the machine and tryed to open the Console, through the tray icon.

2) Nothing happend so i tryed to stop the service: "Symantec System Recovery", but it failed.

3) I stopped the process: "VProSvc.exe" (Needed to "End Process" twice to acutally stop it).

4) Because I tryed to open the console many times, it started up many times.

To me it is a common problem that reoccurs many times, so i can't give you the exact number of machines affected, but it happens at least 3 times a week on different machines (we have 240 machines running SSR).

 

 

Chris Riley's picture

So it sounds like the service is going into a 'hang' state.

Again, this is not something that can be worked on via the forums - please open a support case for this.

Denus's picture

As too many offsite backups failed and vprosvc.exe becomes into a 'hang' state.

Local backups were fine though.

 

I do not continue on this issue anymore, because were installing SSR 2013 now.

We only use the local backup feature of it. (The one that doesn't fail).

Making an own script to do the offsite copy job (SSR doesn't retry a BackupJob).

 

SOLUTION