Video Screencast Help

SSR 2013 and Hyper-V Error

Created: 21 Mar 2013 • Updated: 27 May 2013 | 11 comments
CQ's picture
This issue has been solved. See solution.

Hi all,

We are a small shop running a server with Windows 2012 Standard with Hyper-V.  We have 4 hyper-V VMs running and we have SSR 2013 installed on the Windows 2012 host.  I have searched through these forums and have found that SSR 2013 is capable of backing up the Host with the VMs.  I have run backups on the Windows 2012  host several times and SSR always completes successfully and creates a recovery point.

I was looking in the event logs and find the following 2 errors for each VM that is on the host when SSR is run.

Error 1  "Requester reported unsuccessful backup for the virtual machine 'XXXXXXXX'. (Virtual machine ID 064918AE-59A8-4D4D-8D11-7A70D5CEC1AF)"     XXXXXX is the name of the virtual machine.

Event ID 10170        Source Hyper-V-VMMS 

Error 2  "The operation failed"

Event ID 16010        Source Hyper-V-VMMS

 

Given the errors above, is SSR 2013 performing proper backups with the VMs in a consistent state?   Can someone explain the significance of these errors?  I don't want to find out in the future that SSR was not properly backing up the host machine and its VMs. 

 

Thanks!!,

CQ

 

Operating Systems:

Comments 11 CommentsJump to latest comment

Chris Riley's picture

Have you looked in the Hyper-V specific event logs for a more detailed error/message? (Event Viewer - Applications and Services Logs - Microsoft - Hyper-V)

Unfortunately I don't have access to a Windows 2012 server running Hyper-V so I cannot test this myself.

You may want to consider contacting Microsoft about this issue. Or open a case with Symantec support.

CQ's picture

Unforunately those errors were from the Hyper-V logs. I was hoping someone on the forums had seen those errors before.

I will probably open a case with Symantec Support as I don't see much hope getting an answer from Microsoft. I am sure they will refer me back to Symantec and take my money.

Chris Riley's picture

You could try posting in the Microsoft forums to see if anyone other there has any ideas.

http://social.technet.microsoft.com/Forums/en-US/w...

matt42's picture

We are also in the same position (have the same errors).

My suspicion is that Symantec system recovery is not fully tested with WIndows Server 2012.

The reason I think this is that they STILL don't support backup exec on SQL 2012 or Windows Server 2012 until SP2 (which as of 5/22/2013 is still not released). 

Symantec is really dragging their feet on support for new products.

See here for more details: https://www-secure.symantec.com/connect/blogs/new-beta-program-backup-exec-2012-r2

 

You might want to start looking for a backup software that has a better track record of keeping up to date with various Microsoft product changes.

Chris Riley's picture

You are right in the sense that BE does not currently support Windows 2012 (unless you are enrolled in the Beta Program for SP2/Capri) but SSR does support it (http://www.symantec.com/docs/TECH201318).

I would encourage you to update to SP1 for SSR 2013. If this does not help, open a case with support so this can be investigated further.

manishkrsingh's picture

Please upgrade to SSR 2013 SP1. Also, do let us know if Integration Services are installed for each VM. In the properties dialog of the VM, from either Hyper-V Manager or SCVMM, look on the Integration Services tab and ensure that “Backup (volume snapshot)” is checked (see screenshot below).

1-Live-Hyper-V-Backup-Volume-Snapshots.png

manishkrsingh's picture

Please check the technote at  http://www.symantec.com/docs/HOWTO48572 for requirements to be met in this case.

 
matt42's picture

We have met all those requirements.  Only thing left to do now is to try SP1 which we will do over the next few days.  Apparently the thing forces a reboot of the server which we were not expecting.

CQ's picture

I updated SSR 2013 to SP1 on our server and the Hyper-V failure errors in the logs have disappeared.  I will continue to monitor the logs for a while but it looks like SP1 corrects the issue.

SOLUTION
TRaj's picture

Any updates ?

How is it working ?

We are requesting you to mark the forums as Solution , so that is makes easier for the viewer to search and refer the posts with "Solutions"

CQ's picture

The error has vanished.  When I open Hyper-V Manager and observe the status of the Virtual Machines during backup I see Backing Up followed by succeeded as SSR completes.  I used to see failed.  I believe my particular issued has been resolved.