Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SSR Deletes previous backup from drive - but should not be deleting.

Created: 06 May 2013 | 23 comments

SSR deletes the previous backup on the drive. I have the number of recovery points set to 3. In the log it states it is deleting the previous backup "in order to comply with the size limit of the recovery point to save".

Where is this setting. I have to increase it.

 

Thank you

Operating Systems:

Comments 23 CommentsJump to latest comment

Markus Koestler's picture

Its on the manage backup destination I think.

*** Please mark thread as solved if you consider this to have answered your question(s) ***

grantpsd's picture

On the options page of the backup job there is an Advanced button. This is where the size limit is set up.

If this solves your problem, please mark this post as the solution.

Joemt's picture

I've searched and cannot find an "options page or Advanced button" - I'm using the system recovery 2011 software.

grantpsd's picture

Go to the View menu at the top, Click on Advanced View, Then click on the Backup Jobs Tab, Double click the job. This will open the wizard. Click next until you see the Options page. The Advanced button is toward the lower left of the window.

If this solves your problem, please mark it as the solution to close this thread. You can alway add comments later.

If this solves your problem, please mark this post as the solution.

Joemt's picture

What I see there is a setting to break the recovery points (backup file size) into smaller files (MB size files).

I'm going to have to try to find where it tells it delete the previous backup.  I also know a few of these backups have reached a size that will not allow more than 2 (sometimes 1 ) backup to fit.

Thank you all for your help.....any other ideas let me know.

 

 

Chris Riley's picture

Go to the TOOLS tab of the console and then go to MANAGE BACKUP DESTINATION. Select the relevant drive and click on SETTINGS. From here you can set how much space you want to use for backups.

Hope that helps.

Joemt's picture

Setting are correct:

Set for:

3 backups on the drives.  (full backup everynight on a different drive M-F))

Backup size compressed is 586GB  Max size on external drive for backup storage is just over 1.8 TB.

Problem:

external drive has one backup on it...the second backup completes and it deletes the previous backup. It should have enough room for 3 backups.  If there are 3 backups on a drive  (once in a great while it works) ...then it doesn't backup at all. What is wrong with this software. These are very key features to be running so hit and miss.

Need some help - thank you

 

 

 

DStain's picture

Untick the box monitor disk size and then you can decide when the drive is full.

 

Deric

Joemt's picture

I have a question after figuring a few things out.

Situation: 5 drives, 5 individual backups for each day (M-F) each day gets a specific drive. Recovery set limit set to 3. Friday's backup sets a new recovery set on sunday.  T-F are independant backups.  NOTE: the drives have enough space to hold 3 backups. I've noticed the software deletes backups "after" completeing the backup, not before (I find that odd).

At one point the drives would hold 3 backups (removing the oldest) the limit seem to be per drive). Somehow this changed and now there can be only one backup and once that nights backup is done reaching 2 backups on that specific drive..the old backup is deleted leaving only the new backup on the drive.

It appears the limit of 3 recovery sets is now spanning the drives instead of being applied per drive.

QUESTION: What does the recovery set limit reference? Or by the backup histroy? OR? 

Goal:  to have each drive maintain 3 backups.....deleting the oldest each night.

Chris Riley's picture

I've noticed the software deletes backups "after" completeing the backup, not before (I find that odd).

It HAS to do it this way. Image this example:

You only specify to retain 1 set and the next full (new set) fails part-way through the backup. Result? You end up with nothing.

Can you please confirm the version (including service pack level) of SSR you are using.

Can you also provide a screenshot of the settings screen of one of these backup destinations so we can see what you have configured.

It appears the limit of 3 recovery sets is now spanning the drives instead of being applied per drive.

This is wrong. As you mentioned, you are using specific drives for each independent (full only) backup job. Whatever you specify should be for each drive (backup destination).

 

Dave_H's picture

Do you have 3 different schedules, one set for each drive?

Or do you just have one schedule set and your manually swapping the external drives each day?

Dave

 

 

Joemt's picture

To answer questions: Software info:(From about) Version= 10.0.3.45857 - SSR2011 SBS

I have attached 5 screenshots

Friday.jpg Manage Backup Destination.jpg Managed backup destination settings.jpg Monday.jpg Manage backups.jpg
Chris Riley's picture

Bit confused here, this (https://www-secure.symantec.com/connect/sites/defa...) suggests all jobs are using the same disk as the destination.

Can you clarify please?

Joemt's picture

Chris, I did not initially set this up. I believe there was an issue with the SRR2011 refusing to name the drives (sw bug?)  qnd I suspect this was the answer (yes a poor one)...5 individual drives all with the same name.

Ok lets dicuss an alternative solution.  Is the answer to rename the drives with unique names and set up 5 individual backups. If so, can each drive be set to a 3 set limit using full backups (customer wants full backups).

Thank you

 

Chris Riley's picture

Yes, give each drive a unique alias within SSR.

Assuming there is enough space, yes, you can set the limit to 3. You still need enough space for 4 though so you need to consider this (i.e. 4th recovery point has to be created before 1st gets auto removed).

Hope that helps.

Joemt's picture

I have given up trying to get this 5 drive rotations to work,  So if I understand you correctly:

I should assign unique names to tmy drives. How?  I have looked in options and the external drive list is empty.  Is ther another location for giving the drives a unque name?

DO I hae to format the drives clean on another Pc and then plug in and see if I can give them a unique name?

Thank you,

 

Chris Riley's picture

Can you confirm if this is the issue you are seeing?

http://www.symantec.com/docs/TECH138113

Joemt's picture

Seriously? Almost 3 years on something as important as this and it's still not fixed?  YES, that is exactly what is happening.   Please tell me there is a fix........

Chris Riley's picture

This does not appear to have been fixed yet (please don't shoot the messenger).

I have raised this internally again today so will let you know when I get some feedback on this.

Bigsky's picture

Sorry this took so long, no new info till this morning.

The backups do not have unique names to the drives. These drives did at one time. I have found the issue to be the interface of the external Drives.

These are large backups. We are using the eSata ext. HD interfacefor faster backups. WIth USB 2.0, yes I have the ability to name  the external backup drive.  WIth the eSata interface - No, I do not.

Is there another way to use the eSata drives and get around this naming issue?  Thank you for all your help. I'm curious if many people have reported this......Sorry Chris about my last comments. This has been a very trying problem and an impatience client.

 

 

 

 

Chris Riley's picture

I don't really have anything further to add following on from my previous comments. Sorry..

Our engineering team are aware of the issue and are looking to see what can be done about this issue. Until this issue is fixed, you may need to review your backup strategy.

Joemt's picture

Well, I asked because (maybe I missed it) I did not see any references to the interface being the issue (USB vs eSata). I did not realize it was a eSata interface issue.  Our backup strategy is not an issue. (Expensive) Software falling to operate as stated is certainly an issue. The "software bug" document you listed is from 2010. It's 2013. 

I was simply ensuring I had all the facts for everyone kind enough to help which I do appreciate. 

 

Chris Riley's picture

(Expensive) Software falling to operate as stated is certainly an issue. The "software bug" document you listed is from 2010. It's 2013.

Point taken and it seems we have somewhat dropped the ball on this. I originally reported this issue but our engineering team have not, for whatever reason, fixed it yet. As I said earlier, please don't shoot the messenger (essentially this is what I am in this situation). I have however already raised this intenally and will continue to pursue it so we get a fix for it. What I cannot tell you at this stage, is when a fix will be available.

I will keep you posted as and when I get news on this.

Hope this helps.