Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SSR Restore Anywhere cannot add storage driver megasr1.sys

Created: 20 Nov 2012 | 8 comments

I am restoring Windows 2008 R2 to dissimilar hardware. Having a terrible time getting Restore Anywhere to load the mass storage drivers. I know that I have the correct drivers from Intel's site. The server has Intel ESRT II (embedded server raid technology II). The SSR Recovery CD will load the 32 bit driver so the drive is selectable as a target. However, when the restore starts and prompts for the storage driver it just won't accept the driver

 

The message is

No matching driver could be found for device

pci\ven_8086dev_1d6csubsys_35838086.devicedes Embedded Server Raid Technology II

 

I have seen several articles that reference this very issue and indicate the SSR Recovery CD doesn't include this vendor driver description so it will not load. I have looked in the XML file on the Receovery CD and indeed don't see the full vendor description listed above.

 

What is the fix to get around this issue?

Comments 8 CommentsJump to latest comment

Markus Koestler's picture

Let me escalate this to support for you !

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Chris Riley's picture

The SSR Recovery CD will load the 32 bit driver so the drive is selectable as a target. However, when the restore starts and prompts for the storage driver it just won't accept the driver

The 32bit driver is needed prior to the restore (to see the drive). However, if you are prompted for a driver after the restore has already started, this driver needs to be for the OS you are restoring. So, you need the 2008 R2 (64bit) driver now...

Hope that helps.

itnuroc's picture

I am providing the correct driver version for the OS during the restore (Windows 2008 R2 64bit) - it will not accept the driver

Chris Riley's picture

OK, can you provide the following:

 

  1. Server hardware details (server you are restoring to)
  2. Download link for driver you are using during restore
itnuroc's picture

I am restoring a Windows Server 2008 R2 system...

 

1) Intel Server - server board S2600GL

2 CPUs - Intel Xeon E5-2620 2GHz

Onboard NIC - Intel I350 Quad Port Gigabit Ethernet Controller

SAS/SATA Capable Controller - Intel Embedded Server Raid Technology II (uses Intel ESRT2 drivers based on LSI MegaSR)

2 600GB SAS drives

32GB RAM

2) Download link for driver being used

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20963&lang=eng&OSVersion=Windows%20Server%202008%20*&DownloadType=

When boot from Recovery CD - I loaded the driver under the folder labeled 2k8-x86_v.15.00.0811.2012. This works fine - can see the drives to select as a target

During the restore when prompted to load the storage driver I point to the driver under folder named 2k8r2-x64_v.15.00.0811.2012 - I always get the message in my original post

I am able to do a fresh install of Windows Server 2008 R2 onto this new hardware and use this same driver without issue

 

Chris Riley's picture

What version of the SRD are you using? Version should be mentioned in the filename (10.0.x).

itnuroc's picture

Initially used 2011_10.0.1.41704

Yesterday, I downloaded the latest version and tried the restore again - 2011_10.0.3.45857

Having the same exact issue with both versions

Chris Riley's picture

OK, in that case I would recommend you open a support case so this can be investigated further.