Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SSR2013 no scheduled backup of UEFI partition

Created: 18 Feb 2013 | 32 comments

Trying to schedule a backup of system drive c on a regulary basis.

C contains win8 x64 uefi install. C is located on a SSD. On the same SSD there are also hidden partitions.

Partitionlayout: 300MB Win8 recovery partition, 100 MB Fat32 EFI Systempartition, C-Drive

In Diskmanager it is not possible to assign a drive letter to the recovery or EFI partition.

In SSR2013 i define a volume backup of drive C. In the next screen SSR2013 recommends to add also to this backup the other two partitions. (Regarding the physical partition layout the SSR2013 list of partitions are ordered by size? (1. Efi, 2. Recovery partition))

This seems to be correct.

I hit continue.

Now the next screen shows the recovery type: It is not possible to create a set! It is only possible to create an independent backup!

A Message tells me that i can't create a set because of a hidden partition which has no Driveletter assigned.

If i deselct the EFI-Partition and only the recovery partition and the C-partition is selected i can create a backup set - so the problem is the Efi-partition. I deselect the Efi-partition select the other parameters -do initial backup - no problem at all. The hidden recovery partition and drive c was backuped.

Now i changed the backup definition and added the Efi-Partition - which is accepted. Also the Drives are shown correct: Recovery (*:\);(*:\);System (C:\).

I now do again a backup - a new full backup is done - but without the Efi-Partition.

I tried then to define a backup from the Efi-Partition only. SSR2013 is asking me if i want do add this backup to an already definded backup - i select yes, selected the C-Drive backup - which is accepted. Doing a backup will not safe the Efi-Partition.

I defined now a new backup from the efi partition allone, not adding to the other backup. I can't create a backup-set on regulary basis - so i chose an independent backup. I started the backup manually - voila: Efi-Partition was saved.

Question: How do i do a backup of a full harddrive with all partitions on it on a regulary basis? (Like SSR2013 is recommending it) and other solutions are doing it?

Thanks
Thorsten

 

 

 

 

 

 

 

 

 

 

 

 

Comments 32 CommentsJump to latest comment

Chris Riley's picture

A possible workaround would be to use diskpart (http://support.microsoft.com/kb/300415) to assign a drive letter to the UEFI partition. If you do this (as a test), does it allow you to create a recovery point set backup of all partitions?

If yes, does it actually back them up?

Let us know...

erevo's picture

I have used diskpart to assign the drive letter w to the efi-volume.

I can see the drive letter as local drive W in windows explorer.

If i try to access the drive in windows explorer via double-click i geht a windows that i do not have access to the drive and that i should click on ok for having access - which i have done and is normal.

After clicking ok i geht the next window - access to drive w is denied. I have to use the security tab to get access to the drive - but, with a right click on the drive and selecting properties there is on security tab - i can see tabs like Tool, Hardware, Share, Symantec 2013 etc.... but no security.

In SSR2013 itself i still see not the drive w - only the hidden volume. If i look to the drives in SSR2013 (where i specify which drive should be reported - i don't see drive w.

If i ignore this and do a backup the efi-partition is not backuped.

If i restart the computer - drive w is gone.

So it seems, that it is not easy to access this partition.

On the other hand other products A.... are able to do backups of this partition.... hmmm

erevo's picture

Strange thing:

If i have a command prompt as admin i can access drive w - but not via Windows Explorer - also not if i disable UAC.

 

 

Chris Riley's picture

I think you need to open a support case for this.

If you do, can you let me know what the case number is please?

erevo's picture

I can't open a support case because the support site seems to not exist anymore:

https://my.symantec.com

Page not found

Chris Riley's picture

Looks like the portal is down at the moment.

You can open a case via phone though:

http://www.symantec.com/support/techsupp_contact_p...

erevo's picture

If have now logged the Problem: #03733794

Sidenode: It is very difficult to log a case if u have no customernumber etc. Beside of this the form is not showing Win8... strange

erevo's picture

DISKPART> list part

  Partition ###  Typ               Größe    Offset
  -------------  ----------------  -------  -------
  Partition 1    Wiederherstellun   300 MB  1024 KB
  Partition 2    System             100 MB   301 MB
  Partition 3    Reserviert         128 MB   401 MB
  Partition 4    Primär             118 GB   529 MB

There are may be two problems

Part 4 is the C-Drive

I can scedule a backup on regulary basis if i exclude Partition 2 (Efi, Fat32). However Partition 3 is not seen by SSR 2013 at all.

If i select only Part 2 i can only do an independent backup.

In Windows i also do not see Part 3 - But Part 1,2 and 4

In Acronis 2013 i can backup Part 1,2,4 without any problem however also here part 3 is not seen.

In Macrium Reflect all Partitions are seen and all Partitions can be backuped.

I guess, that partition 3 is empty and this is the reason while it is not shown?

If i list volumes with diskpart i can see all partitions but not part 3 - so i'm also not able to assign a driveletter.

From my understanding, if i do a backup on disklevel all partitions should be seen from SSR2013 also if one is empty - and all partitions should be included in a reulary backup.

erevo's picture

How can i test a restore with the Boot-CD without a serial?

erevo's picture

Nice! I invest my time trying to solve the bugs from SSR 2013, open as wished a case - and what happened?

I got an email: Case # 03733794 - Support Denial:  No Support Found because i have no contract and i should contact symantec sales.

May be i have clicked somewhere false - i don't know - symantecs webside is not really clear.

I think it would be a good idea if the support is looking into the forum for getting the bug informations.

Dave_H's picture

evero is correct here.  (BTW-You don't need a serial to restore an image from the rcovery disk, only to make one)

 

The partition in question is the "Microsoft Reserved Partition" used on EFI systems with GPT drives.

That partition is not visible in either disk management or SSR 2013

 

You can see in my screenshot it is not visible in disk management, only diskpart.

 

 

Here you can see that it is not visible to backup in SSR 2013.

I highlighted the 2 visible partitions for HD0, the other ones listed are HD1.

Curiously, If I restore the SRP (system reserved partition) or the image of the C drive, the SSR 2013 recovery disk will show the MRP partition when I click the "edit" button, but other than seeing it on that screen I have been unable to fiigure out a way to back it up.

I also been unable to restore these images onto a drive that has been cleaned.  I figured it was because of that missing partition.  I can restore either or both partitions that SSR lets me image without any problems and the system boots and works properly.

But if I use disk part to clean the drive and re-initilize it as GPT, I am unable to restore the images and get a working system.

But my issue is besides the point, I'm just trying to confirm what evero is reporting.

Dave

 

 

 

evo_revo's picture

I'm also encountering the same issue as erevo and Dave_H. I have an open support case for it now, but I was curious if either of you had found a solution yet. I will report back my findings.

Dave_H's picture

Since my post above I have spent considerable time with it but I was still unable to restore it onto a new drive or a drive that has been cleaned with diskpart.

I can restore either or both partitions onto the same drive and have it work fine but I could not figure out how to do it on a empty drive.

I also "think" the Microsoft reserved partition is empty but for some reason the inability of being able to replace, restore, or regenerate that partition is causing the problem. And the problem is more than a simple disk signature error encountered when moving the starting point of the windows partition.

I basically gave up because every failure would force me to start over and reinstall windows.

It's just a test system and I was just playing around with it, I actually have no need or desire for a EFI/GPT system setup like that.  I also figured it was me doing something wrong and if I kept checking the topics here I would be able to figure out how to do it.

Best of luck and please let me know if it's just me doing something wrong.

Dave

 

erevo's picture

I have solved the problem by uninstalling and installing an other product TI 2013 - which is working very well: Have done till now over 20 restores without any problem.

UEFI: On my Asus P8Z77-V Pro, with SSD as C-Drive and without the windows "Faststart-Option" i have reboot times from 15 Sec till Desktop - so i guess UEFI makes booting a lot faster.

I may be try Symantec in one or two years when the problems are solved. But i'm not really optimistic because the Support is really bad.

 

 

Dave_H's picture

That happens to be the same motherboard I been trying to do this on too.

 

evo_revo's picture

Support was not much help, and this definitely seems like a huge bug for a solution that supposedly supports UEFI recovery; however, I found a workaround for this. Upon restore of my backed up image to a new server, I get an inaccessible boot device error on boot to Windows. I was able to use the Windows 2008 R2 installation CD to "Repair my computer", loaded the RAID drivers for the server, and then selected that Windows installation to repair. Go to command prompt, go to cd recovery (X:\sources\recovery) and run the startrec.exe. That will go through and fix the boot files so that I was able to get to the desktop.

They need to fix this since as it stands, there is no way to restore a Windows EFI/GPT installation using SSR 2013.

erevo's picture

thanks for feadback evo_revo.

From Windows NT and Vista times i will never use the repair function from Windows because you must have luck that nothing is destroyed which you see later.

As far as i guess and i know, the uefi and the other partition are static - so the data will noch change.

Theoretical, if you do a seperate onetime, daily or weekly backup from the uefi-partion and sceduled backups from the other two partitions it should work.

First restore the uefi-partition, then in a second step the other both partitions.

May be you can try this? (If this is not working then there are also other problems) 

Dave_H's picture

Yes, thank you very much for sharing that.

I saw your post earlier and I installed windows 7 64 as uefi again to try what you did but it's getting pretty late.  I kept getting frustrated because when I got the error I had no other option than to wipe the disk and start over.  At least with your tip I can do the repair and try again.  I may also try the other product mentioned along with a windows system image and see if they work.

I'm really interested if you have the hidden Microsoft Reserved partition still.  If the repair you did replaced it or simply fixed the startup so your system can boot without it.  I still think that is what is causing the problem.

I'll try again tomarrow if I run out of time tonight.

Thanks,

Dave

 

evo_revo's picture

@erevo:

That is how I was attempting to restore the system. I would first try to restore the EFI partition, finish that, and then go back to restore the C: partition. The MRP is not an option to restore singularly--it gets restored with one of the other partitions. (I did not check when that gets restored though. I'm assuming that it's with the C: partition). After I do the restore of both, I can go back into SSR's command prompt and run a diskpart to see al three partitions. The restores I was trying to do was with all partitions taken from a a backup done at the same time. I haven't tried to restore the C: partition while using an older backup of the EFI partition, but I don't see why this wouldn't work using the System Repair workaround.

@Dave_H: 

After the restore, I can go back into diskpart before rebooting the server (and before doing a System Repair) and see all three partitions. SSR 2013 definitely backs up (and will restore) all partitions. I suspect the MRP is the issue too, but not because it doesn't restore it. When I do the restore prior to the System Repair, I noticed that the MRP partition was Partition 3 in diskpart. After the System Repair it was back to Partition 2 where it should be (the MRP/MSR partition MUST be the next partition after the EFI/ESP partition). Either that or I'm just totally grasping at straws and SSR is stripping out my RAID drivers, and when I do the System Repair and load the drivers, it puts them back into the install so it can boot.

Dave_H's picture

I can confirm your results.

I installed a uefi system just like in my screenshots above.

100MB EFI System Partition

128MB Microsoft Reserved Partition (Hidden from SSR and disk management)

119GB Windows 7/64bit

Installed SSR and imaged the 2 partitions It could see.

Booted to a PE disk and used diskpart to clean the disk and then convert to GPT.

Booted the 64bit SSR recovery disk in uefi mode and restored the partitions.  This time I used the option to "browse by filename" and only selected the system partition.  When I click "edit" I verified it was going to recover into the first "phantom" partition.  (Although the drive was empty, it was showing the 3 partitions that were there before, obviously it is getting this information from the partition I selected. Curiously it does indeed show the "Microsoft Reserved Partition" in the list of phantom partitions).

After I recovered that partition I went back and recovered the windows partition, again using the edit button to make sure the destination is correct,  (There is a bug when you restore by "date" that sometimes the partitions get restored in the wrong order, thats why I restored the partitions seperatly).

After I restored the windows partition I opened a command prompt from the recovery disk and ran diskpart, I could see the restored drive looked exactly as before the recovery.

Rebooted the system and it does not work.

Booted to the windows 7 installation disk and ran startup repair.  Then I was able to boot windows normally.  No startup repair log is present on the system :(

I also tried 2 other competitors products, both worked fine first time and booted normally.

Dave

PravinAmin's picture

Hi,

We need some information to investigate the issue in SRD mode

  1. After restoring the system and windows partitions,  do not reboot and open command prompt in SRD
  2. Mount the EFI voume using this command  “ mountvol  <drive letter> /s ”.
  3. To collect the bcd database , run “bcdedit  /store  <drive letter>:\EFI\Microsoft\Boot\BCD /enum all> x:\log.txt “ .
  4.  Please paste the contents of this log file or attach the log file for further analysis.

-Thanks,

Pravin

Dave_H's picture

This is after it's been fixed with a startup repair and windows boots normally.

(also taken from the SSR disc just like above).

AttachmentSize
fixed.txt 5.93 KB
PravinAmin's picture

Hi Dave,

Thanks for attaching the log files. We are investigating this issue and keep this thread updated on findings.

 

-Thanks,

Pravin

Dave_H's picture

 

It doesn't work with Windows 8 installed as EUFI either.

Here is the setup with a clean installation of Windows 8 Enterprise 64bit installed eufi.

120px_partitions_0.jpg

 

You can see that when you install Windows 8 as eufi you get 4 partitions:

Recovery

eufi system

Microsoft Reserved (hidden from disk management and SSR)

Windows

 

I assume the extra recovery partition is the contents of the recovery.wim file.

I installed SSR, and created images of all the visible partitions:

180px_onetimebackup.jpg

Before doing anything else I booted to the SSR disk and gathered the info in the "working.zip" file below, I got the BCD list, partinfo, and SMEDump. (I didn't like all the extra entires in the one above after the windows startup repair, this one is before doing anything.

Then I booted to a PE disk and deleted the partitions on the drive, then booted back to the SSR 64bit recovery disk in eufi mode and restored the 3 partitions being very carefull to restore them into the correct place (once again, on the "edit" screen, SSR showed the "phantom" partitions of where they were before, I just made sure each of the 3 partitions were set to the right targets and the "MSR" partition was not used).

Next I rebooted and gathered new copies of all the above and put it in "Broken.zip"

(This was my 3rd time through and I knew the system would have problems)

The system does not boot into windows 8 but since windows installed the recovery partition it goes directly into a startup repair with no options to stop it.  Basically it was similar to what I did with windows 7 using the startup repair disk.

After that, windows 8 will boot.

Another disturbing thing I found but I will add it on another post to make it less confusing.

Find attached 2 zip files, and note the boot entry pointing to the wrong partition on the "broken" bcd file.

Dave

 

Edit- guess I can't figure out how to make the images open in another screen. :(

I'll attach them below.

 

partitions.jpg onetimebackup.jpg
AttachmentSize
working.zip 22.38 KB
broken.zip 22.22 KB
Dave_H's picture

Oh well, I guess you don't need the images anyway :)

Second problem I found was that I can't restore just the EFI system partition.

If I restore just the SRP that contains the boot files, Windows 8 will not automatically go into a startup repair like it did before. It goes into a blue screen crash with the error "a required device is inaccessable".

I can choose the options to run the repair again and it fails each time and suggests I try doing the repair from the installation disk. (I didn't bother).

What I did find was at that point I can go back and restore both the recovery partition and the SRP (the first 2 phisical partitions) and the system will boot into the system recovery, get repaired, and be able to boot properly.

I find that odd that restoring one partition causes problems but restoring the first 2 partitions allows the system to repair itself.

Either way, I think you will agree there is a problem and that it should be able to recover without needing any repairs.

Dave

 

Chris Riley's picture

We do have the following known issue (http://www.symantec.com/docs/TECH203168) that is currently under investigation. It may or may not be relevant to some of you..

evo_revo's picture

@Chris Riley

This is my exact issue. It appears that the Windows installation CD fixes the BCD, the same as running these bcdedit commands. I'm sure there's not, but I must ask: is there any ETA on a fix for this?

Chris Riley's picture

I will try and find out....

Chris Riley's picture

OK, I've had confirmation that the issue will be fixed in SP1 for SSR 2013.

Current timeframe (i.e. still subject to change) for SP1 is around the end of May.

Dave_H's picture

Yes Chris, that is what is happening to me too.

You may want to add Windows 7 64bit and Windows 8 64bit to that KB.

Dave

oliverjia's picture

Is there any update on this?

I am very surprised that a reliable UEFI/GPT backup and restore still can not be achieved at this time. I mean, come on, UEFI/GPT has been out for a while now, all new windows 8 computers coming with this new, STANRDARD disk layout.  there are many other products, even some free ones, can image UEFI/GPT properly for a long time. Why Symantec still could not do it correctly? This is ridiculous.

I used to be a symantec fan, it's antivirus, its imaging soutions. But now, I am very disappointed. Whoever in charge of SSR development should be fired and a new leader needs to be in charge to get things going.