Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Status 2074 - Disk Volume Down

Created: 04 Feb 2014 • Updated: 24 Mar 2014 | 5 comments
Pritesh Pisal's picture
This issue has been solved. See solution.

**** Moved to new discussion from https://www-secure.symantec.com/connect/forums/nbu-status-2074-emm-status-disk-volume-down ****

I am facing the exactly the same issuewith EMC DD. I have follow the steps you follow. after some times issue still prssist.

I have search the entire catalog for the volume in my case @aaaai. but I havent found such volume. inside the Netbackup.

I have atttached the logs.

Discussion Filed Under:

Comments 5 CommentsJump to latest comment

Jim-90's picture

I get this every couple months.  The best way I found to fix this to disable the DD "file system" where the DD storage unit (NBU disk volume) lives. When disabled enable it.  It may take a couple mintues to go down and about the same when enabled.  Bouncing the DD "filesystem" is not instanious.  If there are NFS/CIFS shares exported separate from NBU they become offline for some minutes.   Often that's all I need to do. 

Marianne's picture

I have search the entire catalog for the volume in my case @aaaai. but I havent found such volume. inside the Netbackup.

NBU will only look for a volume if it existed at some point in the configuration.

Info nbdelete(pid=2248) deleting expired images. Media Server: ind-mhp1bck001 Media: @aaaai

So, at some point in time, this media server had a disk storage unit configured that was recorded as  @aaaai. 

Any idea what happened to this storage unit?

Have you tried nbdelete -allvolumes -force on the master server as per the post that you found earlier?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Pritesh Pisal's picture

Hi Marianne,

I agreed! we have created disk pool several times for the testing purpose and now we have deleted them after expiring images on them, else it wont allow to delete. but when I search according to logs i do not found any backup ID has @aaaai media ID.

No there is no such storage Unit exsist on the master server as we have deleted it.

I did tried nbdelete -allvolumes -force  but it resloves my issue at the moment and after few days I face the same issue.

I did try to play with that OST_aaaai.lock file renaming and Deleting the file but it gets created as soon as I triger the cleaup job

04:23:06.576 [8748.3736] <4> nbdelete:getFileLocks: Attempting volume lock on: D:\Program Files\Veritas\NetBackup\var\nbdelete\OST_aaaai.lock_Check1

04:23:06.576 [8748.3736] <4> nbdelete:getFileLocks: Acquired process 1 lock. Continuing.
04:23:06.576 [8748.3736] <4> nbdelete_lockOperation: Attempting to acquire lock on: D:\Program Files\Veritas\NetBackup\var\nbdelete\OST_aaaai.lock
04:23:06.576 [8748.3736] <4> nbdelete_lockOperation: obtained lock D:\Program Files\Veritas\NetBackup\var\nbdelete\OST_aaaai.lock
04:23:06.576 [8748.3736] <4> nbdelete: nbdelete_allocate_media: Requesting resources for: @aaaai
04:23:06.654 [8748.3736] <16> RequestInitialResources: MultiResReq.cpp:2474 resource request failed [2074]
04:23:06.654 [8748.3736] <4> nbdelete: nbdelete_allocate_media: jmcomm_RequestInitialResources returned: 2074
04:23:06.654 [8748.3736] <16> nbdelete: RemoveFragments: Cannot obtain resources for this job : error [2074]
04:23:06.670 [8748.3736] <4> nbdelete_unlockOperation: Released lock on: D:\Program Files\Veritas\NetBackup\var\nbdelete\OST_aaaai.lock
04:23:06.670 [8748.3736] <4> nbdelete:freeFileLocks: Released lock on: D:\Program Files\Veritas\NetBackup\var\nbdelete\OST_aaaai.lock_Check1
Yogesh.Jadhav's picture

After upgrading to NetBackup 7.5 we have faced this issue, even though the DD volume was up and running it throwed this error and thousands of jobs failed. What I did is increase the timeout where netbacup checks the status of the DataDomain.

Check the status of the DD disk devices when you get error for it

nbdevquery -listdp -stype DataDomain -U

Increase the timeout by adding the paratmeter under /usr/openv/netbackup/db/config directory.

Thanks & Regards

Yogesh Jadhav
Mark_Solutions's picture

I think the parameter referenced by Yogesh will be the DPS_PROXYDEFAULTRECVTMO file

If it doesnt exist create it (on all Master and Media Servers) and add a value of 800 to it.

However, if you are sure that @aaaai does not exist this may not help.

To double check run nbdevquery -listdv -stype PureDisk to see what ID all of your pools actually have

If @aaaai is definately not one of your pools then you can try running the following to see if that resolves your issue:

nbstlutil remove_exp -force

It is still persists then usually it is caused by you deleteing a disk pool and creating another one without re-starting NetBackup services on the Master between those operations (though it doesn't actually say anywhere that you need to!!)

If that is the case the entry is stuck in EMM and you need to raise a case with support who will write you a little sql script to remove it from EMM - there is no other way i know of to get rid of these issues.

This is all assuming that you are running NBU 7.5 - if you are running 7.1 you can just run:

nbstlutil remove_all -mediaid @aaaah –force

Hope this helps

#EDIT# ONLY DO THIS IF YOU ARE SURE THE POOL NO LONGER EXISTS - IF IT DOES IT WILL REMOVE EVERYTHING FROM YOUR LIVE DISK POOL !!!!

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION