Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Storage Foundation 5.1 and MSCS not working

Created: 17 Apr 2010 • Updated: 28 May 2010 | 4 comments
This issue has been solved. See solution.

Hi.  We want to use Storage Foundation 5.1 to manage our dual path disk.  We are clustering MS BizTalk 2006 so we need to use MSCS to Cluster BizTalk.  Problem is that MSCS cannot see the disk group created in SF.  We are using Windows 2003 Enterprise Server R2

We installed SF first and the disk groups appear fine.  Then we tried to configure MSCS and it could not see the disk.  During some investigation we discovered we needed the MSCS Option, so we added our "VRTS STORAGE FOUNDATION OPTION MICROSOFT CLUSTER 5.1 WIN FOR OS TIER ENTERPRISE EDITION STD LIC" license key and it indicated that the MSCS option is available.  However, when we go back to Add/Remove programs to select this option, it does not appear as a choice in the add/remove SF options.

How should we proceed?  Is there a seperate plug in we need to download or should it appear in the list of options in the SF installation screen?

Do we need to have MSCS configured before we install SF so it can detect it?

Any advice would be appreciated.

Warren

Comments 4 CommentsJump to latest comment

jlockley's picture

Hi Warren,

Nothing more is needed after installing SFW and adding the license key. 

I found this in the Admin guide for 5.1 (p516-7)
"Installing Microsoft Clustering support after SFW is already installed"

To summarise, starting on an inactive cluster node:
- go into Add or Remove Programs
- click on Veritas Storage Foundation 5.1 for Windows and then "change".
- select radio button for Add or Remove, click next
- select Cluster Option for MSCS
- the wizard should finish
- go to another cluster node, move group for any online groups to the updated node
- repeat

I think SFW should have warned you if you tried to install a MSCS option license into SFW HA (the Veritas Cluster version) but check when you are running the wizard that it doesn't say "Veritas Storage Foundation HA 5.1 for Windows" on the first dialog box when you select Add or Remove because that indicates the wrong installation files and MSCS option won't appear in this case. 

James.

SOLUTION
David Veber's picture

Hi Warren,

If SFW-HA is installed you will not see the option for MSCS/WFC. You must uninstall from this point and reinstall with just SFW(Not HA). HA will not show the MSCS option. The option shows under DMP, IF it says SFW-HA you will not see this option.

David Veber
Business Critical Engineer, Symantec Corporation
WarrenBrown's picture

Thank you everyone.  Once i installed SFW I see the MSCS option!

Warren

Daniel Schnack's picture

Hi Warren,

I see this issue has been resolved. Can you please take a moment to mark this as resolved to move this from the "Unresolved" list?

Thank you,

Daniel