Video Screencast Help

Subsequent Backup Exec 2010 R3 jobs remain queued

Created: 07 Dec 2012 • Updated: 03 Jan 2013 | 4 comments
This issue has been solved. See solution.

Hello all,

Been fighting the issue since Tuesday 12/4.  What happens is this: after a scheduled reboot of my backup server, a Win2003 box, running Backup Exec 2010 R3 SP2, into a Dell ML6000 library with 6 LTO-3 drives, it would not start jobs. All the jobs would remain in a 'queued' state. Restarting Backup Exec Services, which takes a LONG time by the way, had no effect.  Rebooting the server would of course restart the services, but this also had no effect.

First we thought it might be the catalogs, so we worked on those. Had our SQL guy pronounce them sound.

Tried pausing the server for several seconds as a suggestion by another poster, no effect.

Then I read more in the forums there and we decided it might be comms to the drives, so I tried a solution that someone here by the name of DEVT posted here is that process:


"Queued" state means backup exec is finding the Drives busy. You need to powercycle the network.

1  : Shutdown the Server and the Library and disconnect the Library.
2  : turn ON the Server (This step will remove all the entries in OS)
3  : Turn OFF the server and connect the Library
4  : Turn ON the Library and let it boot
5  : Turn ON the Server and check the Device Manager for the Drives and the Medioum Changer

Make Sure that you are using Symantec Drivers and the Medium Changer must be Unknown (Microsoft Drivers) Removable Storage Service - Stopped and Disabled as mensioned by JoaoMatos

Perform inventory and backups....


Logon after server start and check tape drive drivers, they are the same Symantec drivers in use before the reboot on 12/3.

However, I am still using the Dell ML6000 library (Media changer?) driver that was in use before the reboot on 12/3

What I can do now is start 6 jobs and they will run to completion.  But any jobs that are due to start after those jobs, or jobs that I change the schedule on and order them to 'run now' (they are waiting for a drive) stay in a queued state.  One time, two days ago, one subsequent job ran, but since then no other schedule jobs or 'run now' jobs have run.

I can import and export tapes without issue. I would appreciate any and all input, advice, that might help me get this fixed.

Regards all,


Comments 4 CommentsJump to latest comment

Kiran Bandi's picture

For BE to communicate in a proper way with robot, robot should be using Windows driver. Means it should be listed as Unknown Medium Chnager in device manager. Remove DELL driver, install windows driver and see if that helps...


mcclurer's picture


That will be a change I'll attempt after this weekend's run.

I really think communication with the robot is fine, it's communication with the tape drives isn't quite right.

As I said, the library will import and export tapes, and will run jobs AFTER I run DEVT's process.

But, about a year ago when the SNC (SMC?) board failed in the library, the library had been using the MS driver.  It was after the Dell tech who assisted me with installing and configuring the new SNC (SMC?) board the tech switched the driver to the Dell driver.

Thank you for the suggestion. Do you know where I can find the MS Windows driver for the library?



mcclurer's picture

Hello all, and thank you Kiran.

What finally SEEMED to fix the issue with my backup system was my manager installing Hotfix 195395.

I had faithfully tried EVERYTHING I could find that seemed to relate to my problem; DEVT's suggestions, Kiran's suggestions and even some I had found via my own research, nothing remedied the problem.

But after installing Hotfix 195395 and changing the drivers back to the Symantec drivers for the tape drives themselves and the Dell Library driver for the library, everything has been running as usual for the last 4 weeks, so much so that I'm deeming the backup system fit for DR testing to follow shortly.

I do appreciate everyone who took the time to read this issue and of course those to had time to give me some input.

Thank you very much.


Rob McClure
IT Analyst III
Cameron International