Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Support for Mac OS X 10.9 Mavericks

Created: 02 Dec 2013 • Updated: 12 Oct 2014 | 1 comment
This issue has been solved. See solution.

According to Backup Exec 2012 Software Compatibility List, created November 20, 2013 (http://kbdownload.symantec.com/resources/sites/BUS...) The last supported version for Mac OS X is 10.7. However Mac OS X 10.8 came out in July of 2012 and Mac OS X 10.9 came out in October 2013.

We are currently trying to install Backup Exec 2012 14.0 SP2 in Mac OS X 10.9 Mavericks.  We extracted the LinuxUnixMac files as per instructions at http://www.symantec.com/business/support/index?page=content&id=HOWTO73771. However, the following errors are returned.

--Begin Error

sudo /rams/installrams

Can't locate Switch.pm in @INC (@INC contains: ../ /rams .. /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin /Library/Perl/5.16/darwin-thread-multi-2level /Library/Perl/5.16 /Network/Library/Perl/5.16/darwin-thread-multi-2level /Network/Library/Perl/5.16 /Library/Perl/Updates/5.16.2 /System/Library/Perl/5.16/darwin-thread-multi-2level /System/Library/Perl/5.16 /System/Library/Perl/Extras/5.16/darwin-thread-multi-2level /System/Library/Perl/Extras/5.16 .) at ..//VxIF/Utils.pm line 26.

BEGIN failed--compilation aborted at ..//VxIF/Utils.pm line 26.

Compilation failed in require at ..//VxIF/Interface/Utils/Config.pm line 22.

BEGIN failed--compilation aborted at ..//VxIF/Interface/Utils/Config.pm line 22.

Compilation failed in require at ..//VxIF/Interface/Generic/ConfigInfo.pm line 28.

BEGIN failed--compilation aborted at ..//VxIF/Interface/Generic/ConfigInfo.pm line 28.

Compilation failed in require at ..//VxIF/Interface/Generic/InstallerInfo.pm line 24.

BEGIN failed--compilation aborted at ..//VxIF/Interface/Generic/InstallerInfo.pm line 24.

Compilation failed in require at ..//VxIF/Interface/Generic/ClassFactory.pm line 22.

BEGIN failed--compilation aborted at ..//VxIF/Interface/Generic/ClassFactory.pm line 22.

Compilation failed in require at ..//VxIF/Interface/Classic/ClassFactory.pm line 4.

BEGIN failed--compilation aborted at ..//VxIF/Interface/Classic/ClassFactory.pm line 4.

Compilation failed in require at ../installrams.pl line 16.

BEGIN failed--compilation aborted at ../installrams.pl line 16.

--End Error

What I ended up doing, was looking at the shell script that was running. Running /rams/installrams would call /rams/RALUXx86/installrams.  This in turn would run /ram/installrams.pl.  The line in /rams/RALUXx86/installrams needs to be changed from:

perl -I.. -I$PATH -I$VXIF_HOME ../installrams.pl $*

to:

perl -I.. -I$PATH -I$VXIF_HOME -I../perl/Darwin/bin -I../perl/Darwin/lib/5.8.7 ../installrams.pl $*

This was able to get the installer running but now with a different error:

--Begin Error

Enter the system names separated by spaces on which to install RAMS: (b119h-033393.domain.edu)

Use of uninitialized value within %utf8::PropertyAlias in lc at ../perl/Darwin/lib/5.8.7/utf8_heavy.pl line 123, <STDIN> line 1.

1: Can't find Unicode property definition "XPerlSpace" at ..//VxIF/Utils.pm line 380, <STDIN> line 1.

-End Error

Any Help with this would be appreciated.

I know that this is not supported by Symantic, but when will Mac OS X 10.9 be supported?

Operating Systems:

Comments 1 CommentJump to latest comment

pkh's picture

Unfortunately, Symantec does not put out a support roadmap.

SOLUTION