Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Switch File contents for Multicasting

Created: 21 Feb 2013 | 5 comments

I am trying to automate Ghosting via Multi-Casting - specifically Uni-casting since in most cases I'm only doing one machine at a time.  Multi-casting doesn't work the way it used to since we upgraded our Core Router.   As such I need to specify the fullowing parameters via the Ghost or Ghost32 User Interface:

Mode: Unicast

Multi-cast session name: AV6300Save

Multicast Server Address 192.168.194.66  (changed to protect the innocent ...)

My Switch File (savec.swi) contains the following lines:

============

-clone,src=2,dst=@MCAV6300Save
-span
-ia
-auto
-JA=AV6300Save
-JADDR=192.168.194.66
-JM=U

============

My ghost Command line is:

Ghost32.exe -script=savec.swi

**** When I run the command above to envoke ghost with the switch file, Ghost32 runs and displays the initial screen and says at the bottom (on the Status line): "Attempting to contact Session <AV6300Save>..."  but never contacts the session  :-(

If I kill the program and run it again CMD>ghost32.exe  without any parameters and specify the needed parameters via the Program UI, it joins the session immediately an starts to upload to the server.

 What am I doing wrong??

This is one area that is not documented very well, the use of a script file.

*** Is the Clone command line really needed if everything is specified by the GhostCast Server session - something that is not touched on in the Docs.

Rob
 

Operating Systems:

Comments 5 CommentsJump to latest comment

EdT's picture

Just a thought, but have you tried specifying the full path to your script file?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MSOE AvGuy's picture

Actually I am, I missed typing that in when I entered all the details.

When I call the script via the ghost -script parameter, it is reading the script file to know what Multicast session to join, it just won't join. :-(

Thx

Rob

EdT's picture

For multicast to work you need IGMP snooping enabled on your switches.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

MSOE AvGuy's picture

Yes, I do realize we need to have IGMP snooping enabled, but that is not the problem.

When I run the session from ghost and manually enter the parameters for the client to find the Ghostcast server everything works.

When I try to do the same via the a script file it does not work...

Thanks

Rob

EdT's picture

A common reason for scripts to fail when a manual entry works, is that the current working directory is not correct. Try changing directory to the same location you use when entering the string from the command line. Another reason is one of timing. Put a pause statement in your script, wait a few seconds, then hit enter to continue the script. It may be an issue where the script is running before the network connection is established.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.