Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SWV 6.1 SP4 (6.2) - Altiris NS7 integrated install?

Created: 30 Jul 2010 • Updated: 14 Oct 2010 | 10 comments
This issue has been solved. See solution.

Is anyone having issues with this?  I grabbed the integrated installer for 6.1 SP4 and for some reason it is not showing up as a software package in Altiris.

Do I have to manually add it for this release?

Thanks,

Chris

Comments 10 CommentsJump to latest comment

chris.vanderlinden's picture

Update:

Fresh install of NS7, and i grabbed the "SWV_6_1_SP4_6.2.1562_Integrated_Install" from the download section.

When I installed it on my NS, it gave me 6.1.5126 instead of the correct version.

Is the Integrated install not updated?  I have downloaded the non-integrated install and set that up in my software library, and it installs just fine as well, but I am still perplexed as to why the integrated install gave me an older version!

jharings's picture

I haven't personally used this, and your questions aren't getting alot of traction here, my apologies.

Jim Harings
HP Enterprise Services
1st Rule of Connect Club: Mark the post that helped you the most as a 'solution'. 2nd Rule of Connect Club:You must talk about Connect club.

Jordan's picture

The guy who would know the answer to this is on vacation for the rest of the week, I'll try to find out anything if I can but you may have to remind me next week if I haven't gotten back to you.

If a forum post solves your problem please flag is as the solution

Jordan's picture

So there shouldn't be any issues with SWV SP4 and NS7.  Did you use the solution installer for SWV or the agent installer?

If a forum post solves your problem please flag is as the solution

Jordan's picture

I don't know what SIM is.

If a forum post solves your problem please flag is as the solution

shogo's picture

Symantec Installation Manager, the tool to install solutions in NS7.

Pascal KOTTE's picture

Hi Chris,

Yes, you are right, when installing CMS 7, latest version, you got the "previous version" of SWV 6.1 instead of 6.2 !

But you are lucky, not such a long time before, you were getting only the very old 2.1 version one... It was such, I was thinking only old version was included into CMS suite, and must pay to get the SWV update... And it is not the case !! (1 year wrong before change). I will update my post (no body never correct me crying !!)

https://www-secure.symantec.com/connect/blogs/how-get-svs-or-swv-where-download-svs-21-and-swv-61

enlightened

Well, regarding your SWV 6.1 package would like to update 6.2. What I suggest, is to download the latest 6.2, and import MSI file into your own new "Software component" into CMS7.

You can copy/paste the additional command line option from the 6.1 original one, it is the same. (Take care the ALTIRIS_NS=1 option, see my post).

Why creating your own component instead of updating the existing one ? Just to avoid your updated component to be outdated next "update" your CMS7 installation !!! I take the bet, next update CMS7 will still deliver the SWV 6.1...no

As Symantec does not provide any "plug-in" management for the SWV. you will not find any integrated deployment or upgrade tasks (policies) for SWV angry

Be also careful to add a "detection rule" to check in the uninstall registry the correct version. Symantec got the "bad" usual to keep same "windows install MSI GUID" for all build same version of SVS or SWV. So your detection rule will not distinguish a build form another, and will never update... devil

Also, if you see the x64 version of SWV (final version) available... Please send me a message. I am a little bit tired to come back and see, still not there... after months an months, and months... and months... But honestly, I prefer waiting for a final, stable, instead a final plenty if bugs! But when plan a full migration of Windows XP to 7, using as most as possible VSA packages, if Symantec takes more 1 year after an OS is out to provide the compatible agent or plug-in. We will have some difficulties to sell it !

Please let me know if this answering your question, and mark it as a solution if it is ;-)

~Pascal @ Kotte.net~ Do you speak French? Et utilisez Altiris: venez nous rejoindre sur le GUASF

SOLUTION
chris.vanderlinden's picture

Yep, it is exactly what i did.

I just took the 2.1 install line and modified it to work with the newest release.  This way the install pushes with the NS=1 and the key=xxxxxxx.

The only problem I have noticed that is probably tied into the integrated install, is that my .XPF "installs" don't get their IMPORT / ACTIVATE / DEACTIVATE / DELETE install lines automatically created via NS.  So when you import: Line_of_business_App123.xpf into the software library, you need to create all the install lines yourself!!!

Extremely annoying when you have 10+ to import!

But no big deal :), better than not having the newest SWV :)

Cheers!