Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SWV 6.1 SP6 MP1 and NS6

Created: 02 Nov 2010 • Updated: 12 Nov 2010 | 35 comments

I've downloaded and installed the latest version of of SWV (6.1 SP6 MP1) into my development environment.  The version we are running now (SP4) came with a dedicated "Integrated Install" package which gave us integration with our NS6 platform (collections, packages, tasks, policies, etc).  This made it easy to deploy and manage the agent through NS without having to create manually all of the these things.  I have noticed that in the new downloads, there is no integrated install package.

However, during install I did find the "Altiris Notification Server Support" option checkbox.

The documentation only has this to say:

"Altiris Notification Server Support

This option installs support for managing Workspace Virtualization on
endpoints in a Notification Server environment."
 
After completing the install, none of the NS components were installed into the NS (this is what the "integrated install" package did with sp4).
 
Unfortunately, I have not been able to glean any more information from the documentation or even our assigned engineer.
 
Does anyone have any idea if SP6 supports the "integrated installation" with NS6?  Or will I have to create all of the tasks, packages, collections and policies for managing SWV 6.1 SP3 by hand?  Also, as an aside, does anyone know what that "Altiris Notification Server Support" check box actually does?
 
Thanks!
 

Comments 35 CommentsJump to latest comment

SilentCastle's picture

Update: I have discovered that the checkbox "Altiris Notification Server Support" only registers the SWV agent in the local agent to make it appear as any other solution agent, like SWD or Inventory.  I still haven't been able to figure out the full NS6 integration piece.

SK's picture

You will need to modify the collections and policies to reflect the new version as well as replace the executable for the package.

I do not believe that there will be any further development for the NS integration component, sorry.

SVS Solution 2.1 provided a report pack, but SWV Solution does not, so I intend to modify the 2.1 version to work with SWV when I have some free time.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SilentCastle's picture

Hi SK,

Not only will all of that need to be modified, but all of the built-in tasks for task server as well as the agent deployment package need to be modified as well- because the executable name and command line strings have all changed.

It's unfortunate they decided to discontinue NS integration support.

Best,

Michael Wade

Jordan's picture

My understanding is the same as SK's, that SP4 was the last version to support the SWV solution (NS support).

I know we have something else in the pipeline to replace it but I don't know what it will support (NS, DS, CMS) or what it will have feature wise.

As I tell everyone on the forum, since this is essentially a SWV feature, you need to let Sales, support and\or PM (via the ideas section) know that this is important to you.  We base a lot of what development does based off of what customers tell us they want.

If a forum post solves your problem please flag is as the solution

Jordan's picture

So here's what you can do, we've got an article coming soon to cover this in more detail, but you'll have to install the solution from SWV SP4 and then upgrade SWV as we won't be providing an updated for the SWV solution anymore.

With NS7 we're now using SMS to do what the solution use to do which is better for everyone because you can managed everything in one place.

If a forum post solves your problem please flag is as the solution

SK's picture

All, I have made great progress with this project, and expect to have it finished by the end of the month, so stay tuned.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Jordan's picture

Awesome.

If a forum post solves your problem please flag is as the solution

SilentCastle's picture

SK,

Thank you so much.  I'll be watching this space eagerly.

You'll post something here when you're done?

SK's picture

Yes I will.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

shogo's picture

I would like to get access to the SWV 6.1 SP4 media to install the integration component for NS 6, i can only find the 6.1 SP6 version, anyone now where i can get the older SP4 ?

SK's picture

Here it is - SWV_6_1_SP4_6.2.1562_Integrated_Install.zip

AttachmentSize
SWV_6_1_SP4_6.2.1562_Integrated_Install.zip 31.61 MB

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SK's picture

I just have to check report drill downs as well as task server tasks installed by sp4, and then we should be good to go.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Jordan's picture

Here's my article on this: https://www-secure.symantec.com/connect/articles/getting-swv-and-ns-work-together

If a forum post solves your problem please flag is as the solution

SK's picture

You article provides a good over view to customers as to what needs to be done.

Once my add-on pack is finished, I will create an article explaining how to implement it.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

shogo's picture

I have now run the SWV_6_1_SP4_6.2.1562_Integrated_Install.zip on the NS 6 server and also changed the HKEY_LOCAL_MACHINE\Software\Altiris\Altiris Agent\Plugin Objects\Agents\Software Virtualization Agent “Agent Name” value from “Symantec Workspace Virtualization Agent” to “Software Virtualization Agent”.

We are installing the SWS_6_1_SP6_6.3.1.45 64-bit client with the following syntax in a DS job: PRODUCT_KEY=xxxxx-xxxxx-xxxxx-xxxxx REBOOT=ReallySuppress ADDLOCAL=Altiris_NS

The problem is that the Altiris agent do not recognice the SWV agent and therefore no integrated SVS-job will run on the client.

How can i get the NS6 Altiris Agent to recognice that it has the SVS capability installed?

SK's picture

Hell all,

My add-on pack is nearly finished.  I just have to create some programs for 6.3 and then test what I have created.

My add-on pack maybe a bit over the top, however, it will provide flexibility to all customers.

SK.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Pano's picture

SK,

Can wait to see what you created!  The canned reports need a bit of TLC.

Thanks,
Pano

SK's picture

The reports didn't need much attention, however, I have created a new report that may be useful.

SK.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SK's picture

I just need to test it... :-)

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

shogo's picture

Whats the point to install the Workspace agent in NS6 enviroment when the NS6 does not recognice a client with the Workspace agent to have SVS capabilities?

SK's picture

As long as the agent is installed with the NS option set, then the nsa will find it in its registry, thus including it into its basic inventory nse file.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

shogo's picture

And have you tried to deploy a "native" SVS task to a Workspace client?

I have tried that and i did not got it to work, it says that the client is missing SVS functionality???

And it will not be listed in "Installed agents" at the client.

SK's picture

I have found that if I manually install SWV, then the NS option is created, however, I upgraded from SP4 using the command line and found that even though the NS option was included, the upgrade actually removed the relevant registry key that allows the NSA to see the agent as a plugin.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SK's picture

Review this link for full details of the plugin dilemma:

https://www-secure.symantec.com/connect/forums/using-swv-63-command-line-upgrade-sp4-removes-nsa-registry-plugin-data

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SK's picture

OK, I have tested evrything for 32bit and it all works.

Unfortunately, I am having some problems with 64bit, as the R13 NSA doesnt detect 64bit plugins.

I may have to create a wow64 registry key in order to workaround it.

SK.

I had no choice but to create a registry key.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SK's picture

Hello all,

I have found that the method used to specify the NSA install directory in command line syntaxes, $Altiris_Agent_Cache_Path$, doesnt work on 64bit systems.

Once I have resolved this, I will have a fully tested add-on pack.  :-)

SK.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SK's picture

Hello all,

I have now got my add-on pack working for 64bit systems, and just need to fully test it, modify a collection and then document the entire pack.

I expect to have this completed by the end of January at the latest.

SK.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

boozzard's picture

Hi SK,

Any news on the add-on pack?

Cheers

Boozzard

SK's picture

Hello Boozard,

Documentation is underway and I hope to have it completed by the end of the month.

I am doing this in my spare time, which is why its taking this long.

SK.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

SK's picture

Hello all,

I have published my extension to SWV Solution 6.1 SP4 here:

https://www-secure.symantec.com/connect/articles/extending-life-symantec-workspace-virtualization-solution

Enjoy. SK.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Pano's picture

I might be trying to quickly, but link has been restricted by the author.

Thanks,
Pano

Edit:  Forgot to thank you!  Appreciate your effort.

SK's picture

You're welcome.

Its probably still waiting for approval.

SK.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Jordan's picture

ya I just got notified on it being in the approval que.  Might not be till Monday till it goes up, just depends on how many of us can get to approving it today.

If a forum post solves your problem please flag is as the solution

ohzone - CherylPeterson's picture

SK's article is now live - for anyone who is interested in the solution

https://www-secure.symantec.com/connect/articles/e...

Cheryl

Endpoint Management,
Endpoint Virtualization
Managing Mobility
Community Manager
www.twitter.com/EMnV_symc
Need Altiris help? IRC chat #Altiris