Video Screencast Help

SWV 6.1 SP8 MP1 ( causing silverlight issues

Created: 26 Apr 2013 | 3 comments
philipmiskelly's picture


SWV 6.1 is causing issues with Silverlight on Windows 7 SP1 x64 with IE8. Neither IE8 nor Silverlight are virtualised. For example when I try to access the Altiris console from a Windows 7 PC I get the following runtime error.

"Unhandle Error in Silverlight Application Code: 1001 Category RuntimeError Message 1001 An error has occurred MethodName:

Default.aspx                             Line: 57

Code:0                                     Char: 13

When I uninstall SWV and reboot Silverlight works as expected. The 1001 error occurs on multiple Silverlight websites.

Thanks in advance for any help.


Operating Systems:

Comments 3 CommentsJump to latest comment

EdT's picture

Have you tried with IE9 or IE10 - I think it would be useful to check whether this issue is specific to one version of IE on Win7, or affects any.

Also, do you use the default IE8 install or is it customised in any way, eg via Group Policy. If you are using Group Policy, are you able to advise what policies are being applied?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

philipmiskelly's picture

I've upgraded SWV to SP8 MP2 on a few tests computers which appears to have resolved the Silverlight issue (still carrying out a few more tests).

Interested to find out the cause so will test SP8 MP1 on the different versions of IE as you suggested and see what IE GPOs are applying to IE8.

I'll post an update if I find out anymore.

Thanks EdT for the suggestions.

AngelD's picture

Prior to SP8 MP2 there was a bug that would create a symbolic link (reg_link) in the registry when the layer contained App Paths entries which would leak the symlink (reg entry) to the RO sub-layer.

I would assume that that could have been your "cause"