Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SWV 6.5 on Win 7 -

Created: 29 Aug 2010 • Updated: 03 Oct 2010 | 8 comments
This issue has been solved. See solution.

I installed SWV 6.1 sp4 on Win 7 with the admin account for that machine. I then created a new layer and attempted to install Windows Live Essentials but get an error message:

Couldn't install programs

Please log on to Windows as an administrator and then try again.

I have installed Foxit PDF reader on another layer and that installed fine and runs correctly.

I have checked my permissions and I am logged in as an administrator. Any tips?

Thanks!

Comments 8 CommentsJump to latest comment

FrankB's picture

altiris_svsnewbie,

Have a look on the requirement of Windows Live Essentials, it seems the installer is missing certain requirements.
Also have a look in your temp directory, most of the times such errors are logged in a tempfile.

F

______________________________________________
Frank Bastiaens
Senior Technical Consultant
http://www.aimedsolutions.nl

Jordan's picture

The error was a permissions one so are you a limited user?

If a forum post solves your problem please flag is as the solution

altiris_svsnewbie's picture

Jordan, no I am not a limited user. I am the admin account on that computer. 

altiris_svsnewbie's picture

FrankB, I checked the installation requirements which are consistent with the error that i need to be logged into the computer as an admin. I am not sure if SWV somehow appears as a "limited" account to the Windows Live Essentials installer.

erikw's picture

On a windows 7 machine you are never administrator.
Try rightclick and then run as administrator.
That will give you the sufficient permissions to install what you need.

Be aware that UAC limits all acounts, even administrators

Regards Erik www.DinamiQs.com Dinamiqs is the home of VirtualStorm (www.virtualstorm.org)

*************************************************************
If your issue has been solved, Please mark it as solved
***********

SOLUTION
altiris_svsnewbie's picture

Erikw, your suggestion of right-clicking and selecting the "run as an administrator" works if I do that without using SWV. However, I can't figure out how to do the same thing while creating a layer in SWV. I tried a "global capture" but that still gave me the permission error. Running the install file directly did not give me the option to "run as administrator".

erikw's picture

In your case the solution is pretty easy.
Go to the executable, and rightclick on it. Select properties and set the option to always run as administrator.
Then start swv, and capture the software.
It will now start as administrator without you having to select it again.
Usually if you start explorer or cmd as administrator the child proces will also be admin.
Except in swv.
Starting it as administrator will not help you.
I think thats a bug, but that is my humble opinion.
Try the solution as i mentioned it.

Cheers

Regards Erik www.DinamiQs.com Dinamiqs is the home of VirtualStorm (www.virtualstorm.org)

*************************************************************
If your issue has been solved, Please mark it as solved
***********

altiris_svsnewbie's picture

Erikw, when you say go to the "executable", I am guessing you mean the windows live essentials software install in my case (not SVW). Anyway, I set both SVW and the Windows Live Essentials setup exe as "run as administrator". I still get the same error.

When I run the Windows Live installer without SVW it works fine with the same user (me) logged in