Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

SWV Office 2010 with Japanese MUI: Help file won't work

Created: 21 Sep 2010 • Updated: 15 Apr 2011 | 32 comments
This issue has been solved. See solution.

We've been working with Office 2010 virtualized for Windows 7 for awhile (yes we are aware of the licensing bug with KMS), and are in the process of creating the Japanese MUI for it, but have noticed that if you set the help in anything other than English, it goes through a config on the first run and asks for the MST.  Even if you provide the files it asks for, it says invalid location.  Here's what we did.  The build we are using is 6.1 SP4

1. Created the Office 2010 layer on a clean vmware instance - works no problem

2. On a VMWare, install Office 2010 to the base exactly the same method that the 2010 installed in step 1.  Then capture a new layer installing the Japanese MUI for 2010 via cmd method.  Before you exit the cmd.exe session, go to c:\program files\microsoft office\office14\ and run setlang.exe.  Set the top portion to Japanese, and the 2 bottom panes to Japanese as default.  Save (and exit).

3. Export the MUI layer as a VSA.  (the XPF there's a bug in SP4 where XPF's don't import properly - the dev team is already aware of this)

4. You will have to then go copy and export the keys from the captured machine and add them to the Office 2010 layer so that the MUI layer can be seen:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\LanguageResources]
"UISnapshot"=hex(7):31,00,30,00,34,00,31,00,3b,00,31,00,30,00,33,00,33,00,00,\
  00
"PreviousInstallLanguage"=dword:00000411
"WordChangeInstallLanguage"="No"
"WordMailChangeInstallLanguage"="No"
"XLChangeInstallLanguage"="No"
"AccessChangeInstallLanguage"="No"
"OutlookChangeInstallLanguage"="No"
"SharePointDesignerChangeInstallLanguage"="No"
"PublisherChangeInstallLanguage"="No"
"ProjectChangeInstallLanguage"="No"
"InfoPathChangeInstallLanguage"="No"
"OneNoteChangeInstallLanguage"="No"
"WebDesignerChangeInstallLanguage"="No"
"LangTuneUp"="OfficeCompleted"
"FollowSystemUI"="Off"
"PreviousUI"=dword:00000409
"HelpExplicit"="On"
"MTTF"=dword:0000005a
"MTTA"=dword:0000005a
"ShowDates"="ON"
"HelpExplicit"="On"
"HelpLanguage"=dword:00000411
"HelpFallback"=hex(7):31,00,30,00,34,00,31,00,3b,00,30,00,3b,00,31,00,30,00,33,\
  00,33,00,00,00
"UIFallback"=hex(7):31,00,30,00,34,00,31,00,3b,00,30,00,3b,00,31,00,30,00,33,\
  00,33,00,00,00
"PPTChangeInstallLanguage"="On"
"InstallLanguage"=dword:00000411
"UILanguage"=dword:00000411

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\LanguageResources\EnabledLanguages]
"1041"="On"
"1033"="On"

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Toolbars\Settings]
"CLView"=hex:01,01,00,00,00,00,00,00,12,00,01,00,00,00,02,01,ff,ff,8f,05,00,00,\
  01,00,18,00,00,00,10,00,00,02,00,02,fe,00,00,00,00,f4,01,00,00,7d,01,aa,00,\
  71,03,9c,02,02,01,ff,ff,22,07,00,00,08,01,00,00,00,00,11,00,00,03,01,03,fe,\
  00,00,00,00,00,00,00,00,c3,01,56,01,c3,01,56,01,02,01,ff,ff,29,08,00,00,05,\
  01,18,00,00,00,10,00,00,01,00,01,fe,00,00,00,00,00,00,aa,00,e6,01,79,01,da,\
  03,23,02,02,01,ff,ff,2f,08,00,00,41,01,18,00,00,00,10,00,00,00,00,00,fe,00,\
  00,00,00,fa,00,00,00,09,02,aa,00,03,03,9c,02,02,01,ff,ff,9a,06,00,00,41,01,\
  18,00,00,00,10,00,00,02,00,02,fe,00,00,00,00,fa,00,00,00,2c,02,aa,00,26,03,\
  9c,02,02,01,ff,ff,bd,06,00,00,41,01,18,00,00,00,10,00,00,02,00,02,fe,00,00,\
  00,00,fa,00,00,00,28,01,a7,00,22,02,99,02,02,01,ff,ff,65,07,00,00,41,01,18,\
  00,00,00,10,00,00,02,00,02,fe,00,00,00,00,fa,00,00,00,4b,01,aa,00,45,02,9c,\
  02,02,01,ff,ff,27,08,00,00,41,01,18,00,00,00,10,00,00,02,00,02,fe,00,00,00,\
  00,fa,00,00,00,6e,01,aa,00,68,02,9c,02,02,01,ff,ff,fc,06,00,00,01,01,18,00,\
  00,00,10,00,00,02,00,02,fe,00,00,00,00,fa,00,00,00,91,01,aa,00,8b,02,9c,02,\
  02,01,ff,ff,f1,05,00,00,41,01,18,00,00,00,10,00,00,02,00,02,fe,00,00,00,00,\
  09,01,00,00,b4,01,aa,00,bd,02,9c,02,02,01,ff,ff,9a,08,00,00,41,01,18,00,00,\
  00,10,00,00,02,00,02,fe,00,00,00,00,fa,00,00,00,fa,01,aa,00,f4,02,9c,02,02,\
  01,ff,ff,46,07,00,00,41,01,18,00,00,00,10,00,00,02,00,02,fe,00,00,00,00,00,\
  00,00,00,1d,02,9c,01,1d,02,9c,01,02,01,ff,ff,f0,06,00,00,41,01,18,00,00,00,\
  10,00,00,02,00,02,fe,00,00,00,00,00,00,00,00,40,02,bf,01,40,02,bf,01,02,01,\
  ff,ff,a7,08,00,00,41,01,18,00,00,00,10,00,00,02,00,02,fe,00,00,00,00,fa,00,\
  00,00,3c,01,a7,00,36,02,99,02,02,01,ff,ff,1c,07,00,00,01,01,18,00,00,00,10,\
  00,00,02,00,02,fe,00,00,00,00,fa,00,00,00,5f,01,aa,00,59,02,9c,02,02,01,ff,\
  ff,f1,06,00,00,41,01,18,00,00,00,10,00,00,02,00,02,fe,00,00,00,00,f4,01,00,\
  00,82,01,aa,00,76,03,9c,02,02,01,ff,ff,d5,06,00,00,41,01,18,00,00,00,10,00,\
  00,02,00,02,fe,00,00,00,00,f4,01,00,00,a5,01,aa,00,99,03,9c,02,02,01,ff,ff,\
  88,09,00,00,41,01,18,00,00,00,10,00,00,02,00,02,fe,00,00,00,00,c8,00,00,00,\
  c8,01,aa,00,90,02,9c,02

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\HelpViewer]
"CLViewMTTF"=dword:0000000d
"CLViewMTTA"=dword:0000000d

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\PowerPoint]
"MTTF"=dword:000000bb
"MTTA"=dword:000000bb

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\HelpViewer\Applications\POWERPNT\AdditionalCollections\

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\HelpViewer\Applications\POWERPNT\AdditionalCollections\0]

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\HelpViewer\Applications\POWERPNT\AdditionalCollections\1041]

[HKEY_CURRENT_USER\Software\Microsoft\Shared]
"OfficeUILanguage"=dword:00000411

[HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Office]
"PTOptionsDlgSizePos"=hex:48,03,00,00,26,02,00,00,5c,00,00,00,6d,00,00,00,00,\
  00,00,00

[HKEY_CURRENT_USER\Software\Microsoft\IMEMIP\0x0411]
"Input"="Plain,Dotted,AppText,AppWindow,AppText"
"TargetConverted"="Plain,Single,White,DkBlue,DkBlue"
"Converted"="Plain,Dotted,AppText,AppWindow,AppText"
"TargetNotConverted"="Plain,Single,DkBlue,AppWindow,AppText"
"InputError"="Plain,Thick,AppText,AppWindow,Red"
"FixedConverted"="Plain,AppText,AppWindow,AppText"

[HKEY_CURRENT_USER\Software\Microsoft\IMEJP\10.0\MSIME\AutoCharWidth]
"LearnData"="A2,040,050,060,070,080,090,160,170,"

[HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\PowerPoint\options]
"LastUILang"=dword:00000411

[HKEY_CURRENT_USER\Software\Microsoft\Shared]
"OfficeUILanguage"=dword:00000411

[HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\proofing tools\Grammar\MSGrammar\2.0\1041]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00004109110000000000000000F01FEC\Usage]
"ProductFiles"=dword:3d2f0009

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00004109E60090400000000000F01FEC\Usage]
"ProductNonBootFilesIntl_1033"=dword:3d2f0002

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00004109F10011400000000000F01FEC\Usage]
"SpellingAndGrammarFiles_1041"=dword:3d1e0001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00004109F10090400000000000F01FEC\Usage]
"SpellingAndGrammarFiles_1033"=dword:3d2f0004

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00004109F100A0C00000000000F01FEC\Usage]
"SpellingAndGrammarFiles_3082"=dword:3d2f0004

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\00004109F100C0400000000000F01FEC\Usage]
"SpellingAndGrammarFiles_1036"=dword:3d2f0004

5. On the target machine import and activate Office layer first, then the MUI.  Now if you open Powerpoint, the UI and MUI will be fully in Japanese.  Press F1 though, then it goes through some config and then asks for some manifest mst file located in the japanese folder on the Japanese MUI ISO.  Even if you provide that, it will still say invalid location.  Weird thing is if you exit out it reverts to english no problem.  Also if you go to setlang.exe and set it back to English, the help works fine, no problem.

Any ideas how to get this working for Japanese in the Help file?

The other thing I tried was to make patch layer. I cloned the Office 2010 layer (the one in step 1, not the one in step 2), add to layer the Japanese MUI (set languages to Japanese), then set a new restore point.  Then I create a patch using the Office 2010 as the first layer and the New one with Japanese MUI added as the new one and created the VPA file.  However, when I go to use the VPA and apply it to the Office layer, it says it could not access a file in the VPA and quits.

Comments 32 CommentsJump to latest comment

Jordan's picture

This looks like the help issue you have with any version of office.  Try adding %temp% and %cache% to the layer's exclude entries and see if that works for you.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

On the machine we import the layer to we already have it as a global exclude.  Or do you mean we should exclude this before capturing?

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

On the client machine, capture ignores excludes.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

ah then that's not the issue.  What we are noticing is that the layer isn't capturing the MSOcache and is clearly missing the cache files that are needed for the MUI help menu to display in japanese as it goes through a configuration screen when you run help for the first time asking for the XML manifest and other files.

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

From the sounds of it Office is using some other process or service to install the MUI and because of that it's something we don't track during capture.

An example of this behavior is print drivers are installed by the printer service which isn't a process that's launched by the installer so we can't track it.

If a forum post solves your problem please flag is as the solution

Nirmal R's picture

Hi Jordan, in that case, can global capture possibly solve this?

EddieNYC's picture

it looks like it's using the "office source engine" service which isn't being picked up by SWV (which explains why the MSOcache is void of these files).  Reminds me of how in early swv builds, SWV didn't pick up all the new office services and you had to enable some registry key among other workarounds...  Ideas?  Global capture isn't going to work either.

"Rather fail with honor than succeed by fraud." - Sophecles

EddieNYC's picture

Just to explain further, if you edit the config.xml file in the OMUI.ja-jp folder to force the cache of the msocache (it will fail saying there's no qualifying product as it's missing the office source engine service):

More documentation here: http://technet.microsoft.com/en-us/library/cc17923...

To deploy the local installation source separately

  1. On the network installation point, open the Config.xml file in a text editor, such as Notepad. For information about the Config.xml file, see Config.xml file in Office 2010.

    By default, Config.xml is located in the core product folder for the Office product that you are installing. For example, if you install Microsoft Office Professional Plus 2010, open the Config.xml file in the ProPlus.WW folder.

  2. Find the LIS element (<LIS>); remove the comment marks in the line by deleting the opening <!-- and closing --> tags.

  3. Set the <CACHEACTION> attribute to "CacheOnly".

    The line in Config.xml should look as shown in the following example.

     
    <LIS CACHEACTION="CacheOnly" />
  4. Save the Config.xml file.

  5. Run Setup.exe on users' computers; on the Setup command line, specify the path of the modified Config.xml file.

    You must use a fully qualified path. For example: setup.exe /config <path here>\Config.xml

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

Thanks for that info.  I'll look into some this week and let you know if I can find a way to get it to work.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

Thanks Jordan, much appreciated.

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

I'm having trouble even following the steps to try and reproduce this issue.

I've got a Win7 machine with the Japanese language pack installed and the display language set to Japanese.

I then take an office 2010 layer and run setlang.exe.  I can set Japanese as a input language but not a display language so I downloaded the office 2010 Japanese language pack and the language pack won't install.

I figure trying to capture the Japanese version of office 2010 won't show this issue.

Also, as a final note, SWV does not currently support office 2010 so this issue may already be fixed internally.  when I first saw this post I thought it was for office 2007 which is why I didn't mention this earlier.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

Ah let me clarify, you need to download the entire Japanese Multilingual (MUI) for Office 2010.

Using the CMD.exe window method, capture the following:

setup.exe

(in setup.exe, after accepting the EULA, choose the 2nd option to customize the install, and select to install all from hard disk)

Once setup completes and you're back to the cmd prompt, type go to:

c:\program files\microsoft office\office14\setlang.exe

Set Japanese as the default language for all 3 windows.  exit

Exit cmd.exe window (captured)

Export as VSA (xpf will fail to import as its a known bug).

Import on a target machine with Office 2010 layered, and now you'll get the MUI's in Japanese.  Press F1 it will try to go through a config and fail since it's asking for files for some reason.

Even if you point it to the cd source, it will copy the files and ask a reboot, but after the reboot it still fails to open Help.

"Rather fail with honor than succeed by fraud." - Sophecles

EddieNYC's picture

Ah we also tried the beta build of SP6 which officially supports Office 2010 and still have this issue.  Looks like it may have something to do with the office source engine service...

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

try adding an auto run from layer entry for the office source engine service (you'll need the full path to the exe) which you'd do before placing your layer into capture mode.

If a forum post solves your problem please flag is as the solution

Jordan's picture

So I'm not seeing this issue with the latest internal build of Sp6.

here's my steps:

1) with a precaptured Office 2010 layer I ran a command prompt from the layer and installed the Japanese language pack for office 2010

2) I then ran Setlang.exe and set everything to Japanese as you described above.

3) I then deactivated the layer and created a new reset point keeping user settings

4) activated the layer and everything worked

5) exported the layer and transfered to a different machine and I had the Japanese UI.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

What we did was capture office 2010 in a separate layer and the MUI in another layer since we have multiple MUI's to deploy globally.  This is why we put office 2010 in a VM ware instance as a base install exactly the way that it's captured in the layer so that we can capture the MUI separately.

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

hummm....Ok. I don't think that will work because a layer will always see itself first so it will see the default UI and settings before ever seeing the Japanese settings in the second layer.

If you place all the proper settings into the original layer to tell it  to look for the Japanese stuff then it would work--but I don't know how office would behave if the Japanese MUI wasn't on the system.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

Well the MUI's work perfectly in this fashion (actually no longer need to inject the reg keys anymore) in that the GUI is in the language, proofing tools work, etc., except that the help goes through a config/repair when you press F1.  I've been able to reproduce this using the French, Japanese, Chinese (Simplified), Chinese (Traditional) MUI packs (all on separate layers).  It's really strange.  All work except for the help in the localized language.  If you set it to English, the help works.  However we can't leave it in English all the time, in the case with France, we must have all French by law.

"Rather fail with honor than succeed by fraud." - Sophecles

EddieNYC's picture

oh also office is installed as English with all components installed.  It works perfectly independently.  You activate any of the MUI layers and the MUI takes over the GUI no problem.  Disable the MUI layer, office is back in English no problems.

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

I'm pretty sure there's some conflicting registry key that Office is seeing that's causing this repair so it's seeing part of the second layer with the Japanese stuff and then part of it's own layer with conflicting stuff causing a repair.

Event viewer will tell you what is being repaired, usually only gives you a GUID, and then you can use ORCA to track down the actual feature.  This might help narrow down the offending registry key because you can watch for that area in Procmon.

If you find the offending key then you can create a delete entry for said key in your second layer--so when it's active the key disappears from the system.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

Actually that's a very big tip...  Thanks Jordan.  Let me take a stab at it.

"Rather fail with honor than succeed by fraud." - Sophecles

EddieNYC's picture

I went through the log, but there are only 2 errors.  One is harmless I guess...

  - Provider
   [ Name]  Microsoft-Windows-CAPI2
   [ Guid]  {5bbca4a8-b209-48dc-a8c7-b23d3e5216fb}
   [ EventSourceName]  Microsoft-Windows-CAPI2
 
  - EventID 513
   [ Qualifiers]  0
   Version 0
   Level 2
   Task 0
   Opcode 0
   Keywords 0x8080000000000000
 
  - TimeCreated
   [ SystemTime]  2010-10-07T19:54:12.866561300Z
    EventRecordID 2803
    Correlation
   - Execution
   [ ProcessID]  1400
   [ ThreadID]  5924
    Channel Application
    Computer <edited out>

   Security

- EventData
   Details: AddWin32ServiceFiles: Unable to back up image of service uvnc_service since QueryServiceConfig API failed System Error: The system cannot find the file specified.  
 

----------------------------------------------

The second error is more interesting.  It's asking for the source files.  Question is, shouldn't this already be captured by the layer?

- System
  - Provider
   [ Name]  MsiInstaller
  - EventID 11706
   [ Qualifiers]  0
   Level 2
   Task 0
   Keywords 0x80000000000000
 
  - TimeCreated
   [ SystemTime]  2010-10-07T19:57:21.000000000Z
   EventRecordID 2818
   Channel Application
   Computer <edited out>
 
  - Security
   [ UserID]  S-1-5-21-602162358-1897051121-1417001333-125196

- EventData
   Produit : Microsoft Office Shared MUI (French) 2010 -- Erreur 1706. Le programme d'installation ne peut pas trouver les fichiers requis. Vérifiez votre connexion au réseau ou votre lecteur de CD-ROM. Pour obtenir des solutions possibles supplémentaires à ce problème, reportez-vous à C:\Users\EDDIE(this is my user profile here)~1\AppData\Local\Temp\Setup00001100\SETUP.CHM.
   (NULL)
   (NULL)
   (NULL)
   (NULL)
   (NULL)
 7B39303134303030302D303036452D303430432D303030302D3030303030303046463143457D

--------------------------------------------------------------------------------
Binary data:
In Words
0000: 3130397B 30303034 30302D30 302D4536
0008: 2D433034 30303030 3030302D 30303030
0010: 43314646 7D45   

In Bytes
0000: 7B 39 30 31 34 30 30 30   {9014000
0008: 30 2D 30 30 36 45 2D 30   0-006E-0
0010: 34 30 43 2D 30 30 30 30   40C-0000
0018: 2D 30 30 30 30 30 30 30   -0000000
0020: 46 46 31 43 45 7D             FF1CE}

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

well remember that this repair is probably being triggered because the MUI stuff is in a different layer then your Office 2010 install so there's a visibility issue. I figured you'd see this as the repair item in event viewer but hoped that it would be something a little less broad in scope because it will be harder to track down.

You're best bet now is to do a procmon during launch and see if you can find what's causing the repair.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

I tried building the MUI layer on the 6.1 SP6 MP1 RC build and still have the same repair build.  What's interesting is that I was able to inject the MSO cache and the OSE registry entries for the guids added by the MUI and the repair finishes, but the help still appears in English.  If you close Powerpoint and open help again, it goes through the repair config again too.  So the situation has gotten a little better (no longer asks to reboot everytime), but it's still stuck in the same situation.

"Rather fail with honor than succeed by fraud." - Sophecles

EddieNYC's picture

Hmm combining the office 2010 and mui in a single layer seems to work though (however we can't do this otherwise we will have so many 2.5 GB different layers to manage distribute for each MUI.

"Rather fail with honor than succeed by fraud." - Sophecles

EddieNYC's picture

Ok we got the new SP3 RC build which supports Office 2010.

If you put the Office 2010 and MUI in one layer it works fine.

If you put Office 2010 and the MUI on different layers it works fine except for help (don't need to inject registry keys anymore as long as you reset the main Office 2010 layer everytime you want to swap an MUI).  As soon as you go to help, it runs through a config, looks for the MSOcache for the MUI files (which I injected into the MUI layer with the respective keys in the OSE hive).  But the office help still doesn't appear in the local language and running help again after you close it runs through the config process again.

Any ideas?

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

We've got a bug up for this internally and it's now and issue that development will be looking at and is out of my hands.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

Supposedly it's slated to be fixed in the Skylark release.  Do you know what else will be fixed in the Skylark build?

"Rather fail with honor than succeed by fraud." - Sophecles

Jordan's picture

I cannot comment on that release at this time, it's still a long way off and things could change.

If a forum post solves your problem please flag is as the solution

EddieNYC's picture

For those looking to do this, I've posted a better solution here:

https://www-secure.symantec.com/connect/articles/w...

"Rather fail with honor than succeed by fraud." - Sophecles

ohzone - CherylPeterson's picture

This article will be available as soon as it have been reviewed and approved.

Thanks!
Cheryl

Endpoint Management,
Endpoint Virtualization
Managing Mobility
Community Manager
www.twitter.com/EMnV_symc
Need Altiris help? IRC chat #Altiris