Video Screencast Help

Sylink Replacer not working with SEP 12

Created: 16 Jun 2011 • Updated: 19 Aug 2011 | 11 comments
B.Louie's picture
This issue has been solved. See solution.

I'm having problems getting Sylink replacer to work using SEP 12.  I believe I have the latest version of Sylink Replacer 1.3?  Not sure where you look to see what version it is.  The creation dates on the PDF and .exe files are 2008.  Anyway, it runs just fine from a Windows 2003 standard edition server logged in as domain admin, but it's not replacing the Sylink file eventhough it creates the temp directory on the client.  Bottomline, the sylink file is not updating on the client.  I'm getting "not copied" errors in the logs.  Please help since I have quite a few clients I need to convert from unmanaged to managed.  I'm also open to alternative methods of updating these clients to point to the management server.  Thanks.

Comments 11 CommentsJump to latest comment

Idimple's picture

Hello,
If possible call to Syamntec Tech support and get the new copy of sylink Replace utiltity.

Also check out the below documents,

How to convert an unmanaged client to a managed client

http://www.symantec.com/business/support/index?page=content&id=HOWTO16324&actp=search&viewlocale=en_US&searchid=1308279403905

Using the "SylinkReplacer" Utility

http://www.symantec.com/business/support/index?page=content&id=TECH105211&actp=search&viewlocale=en_US&searchid=1308279439036

Your satisfaction is very important to us.If you find above information helpful or it has resolved your issue...please mark it accordingly :)
Rafeeq's picture

It will not work on SEP 12, I think the folders are changed !! 

orignial sylink replacer will look for Symantec endpoint protection folder...

You have the same folder in SEP 12, if not it wil not work...

yang_zhang's picture

On SEP 12.1, there will be a SyLinkDrop.exe for SEP 12.1 specially.

If a forum post solves your problem, please flag it as a solution. If you like an article, blog post or download vote it up.
B.Louie's picture

Do you know when a SEP 12 supported version of SyLinkDrop.exe or Sylink Replacer will be available?  If not, what is the best/quickest way to convert workstations from unmanaged to managed.

Rafeeq's picture

sylink is found under Binn directory now

you need manually stop the service

start run

smc -stop

replace the file

and restart the service

start run

smc -start

Paul Murgatroyd's picture

Sylinkdrop is installed as part of SEP12, its in the bin folder too.

You can use that to replace sylink on the clients.

Paul Murgatroyd
Principal Product Manager, Symantec Endpoint Protection
Endpoint twitter feed: http://twitter.com/symc_endpoint

Chetan Savade's picture

Hi,

Sylink.xml location has changed in SEP 12.1

Click on Start 

Click Run 
Type smc -stop in the run field 
Copy the sylink.xml file and paste under "C:\Documents and Settings\All Users\Application Data\Symantec\Symantec Endpoint Protection\12.1.xx.xx\Data\Config" it will prompt do you want to replace the file click on Yes. 
Start the smc service 
Click Start 
Click Run  
In the run field type the following command
smc -start 
 
If you want to replace it through utility then as Paul mentioned you can do it with the help of Sylinkdrop utility
 
You can find it under tools folder with original setup files.

Chetan Savade
Sr Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

SOLUTION
Paul Murgatroyd's picture

You don't need to do any of those steps, SylinkDrop is INSTALLED on the client by default.  In fact, by default, those steps won't work, because tamper protection will prevent you from touching the sylink file.

Just run Sylinkdrop from here: C:\Program Files\Symantec\Symantec Endpoint Protection\<Version>\Bin and you can replace the sylink file.

Paul Murgatroyd
Principal Product Manager, Symantec Endpoint Protection
Endpoint twitter feed: http://twitter.com/symc_endpoint

MaRRuT@CC's picture

normally you're right paul but for some customers its needed because of sylink.xml change scripts. With them they are changing/moving users to different groups after a while because of infrastructure changes and so on.

Paul Murgatroyd's picture

but SylinkDrop is scriptable, it always has been.

You don't need to stop services or disable tamper protection for it to work.

Paul Murgatroyd
Principal Product Manager, Symantec Endpoint Protection
Endpoint twitter feed: http://twitter.com/symc_endpoint

bcwood16703's picture

Sylinkdrop v1.2 for SEP V12.1 will not work as installed.   I was able to find the data\config file as located in the registry.   The problem especially with Windows 7 clients is that Tamper Protection will not let you install the new sylink file in the appropraite directory.   I get a number of errors:  Cannot stop the smc service, cannot backup the sylink.xml file, etc.   The bottom line is that file protections of the new hidden directories esp Windows 7 and WinServer 2008 will not let Sylinkdrop.exe V1.2 update the file.  

 

I had to script install updates using Sylinkdrop for 2000 workstations between now and the Oct 31.   I need good information on when sylinkdrop will be fixed or a useable tested howto ASAP.

 

 

Brian