Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Symantec 12.1 unable to install. InstallShield Wizard Completed - The wizard was interrupted before Symantec AntiVirus Corporate Edition could be completely installed. (Win XP)

Created: 19 Feb 2013 | 11 comments

Good morning.

I'm having a very difficult problem. My Symantec 12.1 is not installing on this particular computer. few hours ago, I have successfully installed in on 2 other computer. All of them are running on Win XP SP3. The previous 2 had no problem, and this problem has only occurred on this particular computer.

I have searched around, and tried different solutions such as deleting the Symantec folder on different locations, turning off firewall, installing Windows Cleanup tool, and even resorted to reformating the computer again, but came back to the same problem.

Attached is my log file.

And below are the lines that appear after "return value 3" as most of you technical staffs usually look at.

MSI (s) (1C:44) [10:48:50:093]: User policy value 'DisableRollback' is 0
MSI (s) (1C:44) [10:48:50:093]: Machine policy value 'DisableRollback' is 0
MSI (s) (1C:44) [10:48:51:859]: Executing op: Header(Signature=1397708873,Version=301,Timestamp=1112823286,LangId=1033,Platform=0,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=1)
MSI (s) (1C:44) [10:48:51:859]: Executing op: DialogInfo(Type=0,Argument=1033)
MSI (s) (1C:44) [10:48:51:859]: Executing op: DialogInfo(Type=1,Argument=Symantec Endpoint Protection)
MSI (s) (1C:44) [10:48:51:859]: Executing op: RollbackInfo(,RollbackAction=Rollback,RollbackDescription=Rolling back action:,RollbackTemplate=[1],CleanupAction=RollbackCleanup,CleanupDescription=Removing backup files,CleanupTemplate=File: [1])
Action 10:48:51: Rollback. Rolling back action:
Rollback: Executing install script via service
MSI (s) (1C:44) [10:48:51:859]: Executing op: ActionStart(Name=ShowServiceProgress,Description=Executing install script via service,Template=[1])
MSI (s) (1C:44) [10:48:51:859]: Executing op: ProductInfo(ProductKey={A3AEEA68-AC93-4F6F-8D2D-78BBF7E422B8},ProductName=Symantec Endpoint Protection,PackageName=Sep.msi,Language=1033,Version=201392799,Assignment=1,ObsoleteArg=0,,,PackageCode={9383C7E7-E87A-4236-94BC-A8E761408534},,,InstanceType=0,LUASetting=0,RemoteURTInstalls=0)
Rollback: Executing rollback script via service
MSI (s) (1C:44) [10:48:51:859]: Executing op: ActionStart(Name=ShowServiceProgress_RB,Description=Executing rollback script via service,Template=[1])
MSI (s) (1C:44) [10:48:51:875]: Executing op: CustomActionRollback(Action=ShowServiceProgress_RB,ActionType=3329,Source=BinaryData,Target=ShowServiceProgress_RB,CustomActionData={A4C6A6D3-7221-458F-A52B-BA6011F550EF};SOFTWARE\Symantec\Symantec Endpoint Protection;Executing rollback script via service;)
MSI (s) (1C:38) [10:48:51:921]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSIDE.tmp, Entrypoint: ShowServiceProgress_RB
ScriptGen: ShowServiceProgress_RB() MSIRUNMODE_ROLLBACK
ScriptGen: ShowServiceProgress_RB() calling WaitForSingleObject(scriptStarted) ...
ScriptGen: ShowServiceProgress_RB() WaitForSingleObject(scriptStarted) returned WAIT_OBJECT_0
Action 10:48:53: ShowServiceProgress_RB. Executing rollback script via service
ScriptGen: ShowServiceProgress_RB() script execution failed.
ScriptGen: ShowServiceProgress_RB() reset script failure event.

I'll appreciate any kind of help because this is driving me nuts for the past 2 days.

Discussion Filed Under:

Comments 11 CommentsJump to latest comment

.Brian's picture

Have you tried Cleanwipe?

Can you also post 15-20 lines above return value 3? This is usually where the error message lies. Or if you could just post the full log that may be even better.

Are you running the install locally or pushing from the SEPM? Can you try installing locally?

If pushing from SEPM, ensure you followed this KB article:

Steps to prepare computers to install Symantec Endpoint Protection 12.1 client

Article:TECH163112  |  Created: 2011-06-23  |  Updated: 2012-01-17  |  Article URL http://www.symantec.com/docs/TECH163112

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

rhexis's picture

apologies, my attachment was in the wrong format. I have changed it and attached it now. I can't find the edit button so I had to double post.

AttachmentSize
SEP_INST.doc 3.63 MB
.Brian's picture

I would contact support and request Cleanwipe. They will send you the download information. Run that and try to install SEP again.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

rhexis's picture

Thank you for the amazingly quick reply. I have attached my log file. Pasting the entire thing would take up a lot of space. Sorry about the confusion, as I thought it was 15-20 lines below return value 3.

Anyway, no, I did not try Clean Wipe. But I did re-format my entire computer again, so I'm sure that would be counted as a clean wipe. laugh

I am installing my 12.1 locally. I have tried using the push down as well but that did not work.

EDIT: Sorry. I just found the EDIT button under Actions.

.Brian's picture

Try creating a new package from the SEPM and running again.

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

Ashish-Sharma's picture

hi,

It's means you can create NEW sep package and try again.

return value 3

You also look for the MSI Errors:

http://msdn.microsoft.com/en-us/library/windows/desktop/aa368542(v=vs.85).aspx

and Product version, source of Install package and Errors if any

Thanks In Advance

Ashish Sharma

Rafeeq's picture

From the Log

------

ShowServiceProgress() script execution failed.

ScriptGen: ShowServiceProgress() reset script failure event.

ScriptGen: ShowServiceProgress() is returning an error (so close to the 

---------------

Solution:

Create an install package or create a custom setting under the “Client Install Settings” options to not use “Add the program to the Start Menu”, leave this unchecked.

If the install is successful, manually create the shortcut on the desktop that points SymCorpUI.exe.

http://www.symantec.com/business/support/index?page=content&id=TECH170259
 
----
Creating custom client installation packages in the Symantec Endpoint Protection Manager console version 12.1
http://www.symantec.com/business/support/index?page=content&id=TECH165801
 
follow these two steps and please update us
rhexis's picture

Hi guys. Thank you for the really amazing quick replies and help.

I managed to contact my Symantec support to send me the Clean Wipe tool and have ran it. My Symantec has installed successfully. It did seem that the adding program to start menu was a problem because everytime it ran, the start menu's symantec folder was empty.

I think I should mention that this computer came with a built in McAfee, though I did remove it before installing. Also, my Liveupdate didn't run prior to applying Clean Wipe, as something was probably blocking it.

I did not manage to try the above solution regarding creating a new package, but I will be sure to look into that should another problem similar to this occur. Clean Wipe does seem to be a powerful tool, and I'm sure it's because of some built in software that caused this problem to occur as I had reformatted my computer twice, but still encountered this problem. Clean Wipe erased some stuffs and allowed me to successfully install SEP 12.1.

Thanks again for your help guys.

Rafeeq's picture

I did post two links above,

1 had the solution for start menu items not getting added and the second link was to create new package.

:)