Video Screencast Help

Symantec CMC Smc Memory Usage

Created: 07 Aug 2012 | 12 comments

Hey all,

 

I have a symantec client that I just installed that is being crushed by the cmc smc service.  I am running 12.1RU1  I have reinstalled the client twice, but that has been no help.  I have attached two screen shots of task manager showing symantec crushing the computer.  I have about 400 computers with symantec on it and I know that this isn't happening on most of the machines (as I am using the same package on the computer I am currently typing this on which is working just fine).  I am going to write a powershell script shortly to check all the computer in the domain to see if any are having this same problem, but I think it is just this one computer.  Anyone have any ideas why this would be happening?  Thanks and let me know if you need any other info.

Comments 12 CommentsJump to latest comment

W007's picture

To resolve this issue,

Check this fourms

https://www-secure.symantec.com/connect/forums/smcexe-process-uses-more-ram

To resolve this issue, increase the value of the IRPStackSize registry entry. To do this, follow these steps:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

    If the IRPStackSize entry is not present in this subkey, follow these steps:

    1. Click Edit, point to New, and then click DWORD Value.
    2. Type IRPStackSize, and then press ENTER.

      NoteType IRPStackSizeexactly as it appears. The value name is case sensitive.

  3. Click IRPStackSize, click Edit, and then click Modify.
  4. In the Data Value box, type a larger value, and then click OK.

    Note Values may range from 0x1 to 0xC. These values are equivalent to 1 to 12 in decimal notation.

If the problem persists after you complete the previous procedure, increase the value of IRPStackSize more.

 

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Dushan Gomez's picture

what is that use for ?

IRP Stack Size ?

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP

 

Dushan Gomez's picture

thanks for the info poly :-)

Dushan Gomez
IT Manager
VCP 4 and 5 | MCITP Exchange Server | MCTS SharePoint Server | MCP Windows XP

 

poly15's picture

Thank for the info.  Gave it a shot and no help.  Restarted the computer and restarted the server service after changing the IRPStackSize to several different values.  See attached screen shot.

symanteccmc3.JPG
W007's picture

hi,

Check this fourms will be help.

https://www-secure.symantec.com/connect/forums/smcexe-process-uses-more-ram

HKLM\System\CurrentControlSet\Services\Tcpip\Parameters
- DWORD MaxUserPort, with value 50000 (decimal)

- DWORD TcpTimedWaitDelay, with value 30 (decimal)

 

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

poly15's picture

It is my understanding that these settings do not apply to me as I am not setting this machine up as a GUP.  This is a simple client so there is no reason it should need more user ports or a longer or shorter TCP delay. 

Mithun Sanghavi's picture

Hello,

I would request you to Run a Cleanwipe version 12.1, which would uninstall the SEP client properly.

Once done, make sure all the SEP folder are deleted from the machine and then reinstall the SEP client 12.1 RU1 MP1 on the machine.

Check this Article  - 

How to get the CleanWipe tool (Endpoint Removal)

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

Cameron_W's picture

I would first try installing the latest 12.1 RU1 MP1 and see if issue persists. If it does I would recommend using procdump to collect a dump of the smc process. Below is a link to procdump and how I would configure it.

http://technet.microsoft.com/en-us/sysinternals/dd...

C:\>procdump -ma -m 1200 smc.exe smc.dmp

Another option would be to configure your machine for a full memory dump then manually crash the machine with a utility such as notmyfault while the issue is occuring. Below is a link on how to configure a full memory dump.

http://www.symantec.com/docs/TECH104660

Once you have this information call into tech support and open a new case.

If I was able to help resolve your issue please mark my post as solution.

Linas's picture

I have the same issue I was checking out my pc and noticed hi memory usage

So I looked in task manager and found SMC.exe is using 2,369,216K Ram for hours

I rebooted and the same still using 2.3 gig of ram?

I have version 12.1.1101.401 I think its RU1 MP1?

This is just a test pc nothing much on it has very little use

New install only a couple months old

I checked 2 other work station’s one is using 4K the other 12K ram?

poly15's picture

Linas,

 

To be completely honest it just started working for me randomly when I got back to the office one monday after opening a ticket on thusday or friday.  I highly recommend getting the cleanwipe tool from symantec.  To get this just open a ticket with symantec saying you need the cleanwipe tool and they will give you a place to download it from an FTP server.  Then run the cleanwipe tool and then reinstall symantec.  Also, My problem was with RU1 not MP1.  The version you stated is MP1. 

Linas's picture

I am not really worried about this PC but the other 350 clients on my network users are always complaining about slow PC’S This is one more thing to worry about

If the SMC.exe is using the entire ram in these systems I can’t go and clean wipe all the systems

I was hopeing support had some fix or a setting change I hate these try this fix

I guess whenever someone complains of a slow computer this is one more thing to check

I have the cleanwipe util Thanks for the suggestion I will put out a couple more fires before I have time to try this fix