Video Screencast Help

Symantec Embedded Database service will not start

Created: 10 Mar 2014 • Updated: 11 Mar 2014 | 18 comments
This issue has been solved. See solution.

Hello everyone,

I have this problem for about couple days. SEMP will not start, because database cannot start. In Services it shows Starting... and it unable to start. I disabled this service and tried to run Repair from Add/Remove programs. Repair finished successfully, but the database will not start.

Please help to resolve this issue.

I attached log file from db folder. If you need any other logs, please let me know.

 

Thank you

Operating Systems:

Comments 18 CommentsJump to latest comment

.Brian's picture

You can turn on some advanced debugging an post the logs here if you wish:

How to debug the Symantec Endpoint Protection Manager

Do you have plenty of space on C:?

Has anything changed recently, upgrades, patches, etc?

What OS is the SEPM running on?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

awhealthcare's picture

Please see all collected logs attached.

No upgrades. Running on Windows 7 Pro. About 250Gb free space.

AttachmentSize
SEPM_Logs__DIMAPC__2014_03_10__10_45_02__CentralStandardTime.zip 9.7 MB
.Brian's picture

Also, I forgot to ask, but what's the exact SEPM version?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

.Brian's picture

Can you check your windows event viewer to see if the error message in this article is the same:

http://www.symantec.com/docs/TECH194813

 

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

awhealthcare's picture

Yep, same error:

The Java Virtual Machine has exited with a code of -1, the service is being stopped.

But when I try to start it manualy, it will not start the service.

.Brian's picture

Try increasing the memory usage of the JVM to the values in the article I posted.

You can follow this article starting with Step 1 on how to do so:

http://www.symantec.com/docs/TECH105179

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

awhealthcare's picture

In Step 1, after changing the parameters, trying to start SEPM and got this error:

The Symantec Endpoint Protection Manager service on Local Computer

started and then stopped. Some services stop automatically if they are

not in use by other services or programs.
Rafeeq's picture

do you see the embedded data base service listed in services.msc?

awhealthcare's picture

Yes, the service is there, but like I said, the services status is Starting.. and it never chenge to Started.

See attached image

 

 

Capture.JPG
Rafeeq's picture

Right click on the service, and select properites, select Disabled, click apply, click ok

Open task manager , kill Dbserv9.exe ( something simillar to this)

Go back to services.msc  change the start up type to automatic. click apply, click ok ( do not start it yet)

Run the management server configuration wizard

awhealthcare's picture

Got error: embedded database is not started.

See attached image

Capture.JPG
Rafeeq's picture

Please try this

Go to "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\db\" and renamesem5.log to sem5.log.old

Click Start, click on Run and Type "CMD" then click OK

In the Command Prompt type: "CD C:\Program Files\Symantec\Symantec Endpoint Protection Manager\ASA\win32\" and press Enter this will change directories to the folder containing dbsrv9.exe.

To force the recreation of sem5.log. Type: "dbsrv9 -f "C:\Program Files\Symantec\Symantec Endpoint Protection Manager\db\sem5.db" and press Enter

Click Start, click on Run and Type "services.msc" then click OK and start the Symantec Embedded Database Service

Start the Symantec Endpoint Protection Manager service.

awhealthcare's picture

It didn't work.

Support gave me this link:

http://www.symantec.com/business/support/index?pag...

 

But this will Uninstall/reinstall SEPM.

I don't know... maybe this is the case.

Rafeeq's picture

Not a problem..

since you have less number of clients, 

uninstall sepm, 

reinstall sepm

use this document to get all your previous sep client to new sepm

http://www.symantec.com/business/support/index?pag...

awhealthcare's picture

OK, the problem is solved by Symantec tech support.

Here is the very brief transcript:

spoke to customer
He said that he cannot start DB service
Took remote
DB was starting
Tried to disable it & killed dbsrv12 proc., No go
Ran repiar, no go
Tried to run upgrade.bat, No go
Deleted the conf.
Ran repair and created a new DB 
(mistake. repair didn't work. we started the installation file, and in the process it saw that we have DB, program asked to overwrite. after creating new DB the service could start again)
Was able to start the DB process
clients started to check in back 
followed TECH1xxxxx 
Added the packages..
issue fixed
Closing the case

But there more. You have to navigate between Installation window, TaskManager and Services windows, and timly kill the process and stop and start service.

Could I do this repair again by myself? I'm not sure. You have to know when and what to kill or stop, or change it to Manual.

Yes, it was reinstallation. We couldn't fix it. So, one important thing is to have your serial number for licenses.

I hope it will help to someone.

SOLUTION
.Brian's picture

It does. Thanks!

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.