Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Symantec Encryption Management server clustering issue

Created: 27 Feb 2014 | 3 comments

Dear Team,

 

we are facing issue when joining our encryption management servers in a cluster. Inspite of meeting all the environmental requirements, the cluster page displays that Join could not be complete and the error message says that the remote server has the same id as the local server. Is there any way to change this ID? Also there is a continuous error mesage saying that reverse lookup failed for the clustering IP where as we have both the lookups in place in the DNS server.

We are stuck with this, need help in this issue..

 

Thanks 

Operating Systems:

Comments 3 CommentsJump to latest comment

Marianne's picture

Please check contents of /etc/llthosts and /etc/llttab on both nodes.

llthosts on both nodes need to look the same, e.g:

0 node1
1 node2

llttab needs to be different:

node1:
set-node node1
set-cluster <number>
link ...
link ...

On node2:
set-node node2
set-cluster <number>
link ...
link ...
 

Please show us the DNS error message and tell us where exactly the error is seen.

Also show us service group config in main.cf.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

lalitphirke's picture

Hi Marianne,

Thanks for the reply..

I checked out both the VMs, there is no file as /etc/llthosts and /etc/llttab on both nodes. i didnt find it under /etc is there any other location i should look these files for?

The error message is "Reverse lookup failed to find matching membership for 192.168.x.x:444"

I tried telnetting port 444 from both the VMs to each other, its workig fine..

Also,  where could i find main.cf file?

 

Thanks

Marianne's picture

...  there is no file as /etc/llthosts and /etc/llttab on both nodes....

This is indeed VCS on Linux as per the OS that you selected in you opening post, right? Then basic cluster config was not done or you have configured two one-node clusters.

The files are created during initial installation and configuration to create a cluster with a name, a cluster id and to setup the private network (heartbeats).

How long ago was this cluster installed?

Can you remember the steps that were taken to install and configure?

Can you show us output of the following commands on both nodes?
gabconfig -a
hastatus -sum

You may want to go through the VCS installation Guide and compare it with the steps that you have followed.

All manuals can be found here : https://sort.symantec.com/documents 
Select your OS and Linux version for links to manuals.

main.cf is in /etc/VRTSvcs/conf/config

About the error - we need to understand where exactly this error is seen and what the source of the error is.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links