Video Screencast Help

Symantec Endpoint Protection Manage can't start.

Created: 20 Sep 2013 | 16 comments

Hello,

after upgrade my SEPM (10.1.2->10.1.3) semsrv can't start.

Windows Events is clear

scm-server-0.log

2013-09-20 20:49:42.119 THREAD 1 SEVERE: ================== Server Environment ===================

2013-09-20 20:49:42.291 THREAD 1 SEVERE: os.name = Windows Server 2008 R2
2013-09-20 20:49:42.291 THREAD 1 SEVERE: os.version = 6.1
2013-09-20 20:49:42.291 THREAD 1 SEVERE: os.arch = x64
2013-09-20 20:49:42.291 THREAD 1 SEVERE: java.version = 1.7.0_21
2013-09-20 20:49:42.291 THREAD 1 SEVERE: java.vendor = Oracle Corporation
2013-09-20 20:49:42.291 THREAD 1 SEVERE: java.vm.name = Java HotSpot(TM) Client VM
2013-09-20 20:49:42.291 THREAD 1 SEVERE: java.vm.version = 23.21-b01
2013-09-20 20:49:42.291 THREAD 1 SEVERE: java.home = C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\jre
2013-09-20 20:49:42.291 THREAD 1 SEVERE: catalina.home = C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat
2013-09-20 20:49:42.306 THREAD 1 SEVERE: java.user = null
2013-09-20 20:49:42.306 THREAD 1 SEVERE: user.language = ru
2013-09-20 20:49:42.306 THREAD 1 SEVERE: user.country = RU
2013-09-20 20:49:42.306 THREAD 1 SEVERE: scm.server.version = 12.1.3001.165
 
 
 
ajaxswing.log
....
2013/09/20 20:06:05:830 : StartupServlet : [com.creamtec.ajaxswing.core.JVMFactory] Failed to unbind JVMFactory (Exception java.rmi.NotBoundException, creamtec/ajaxswing/JVMFactory)
java.rmi.NotBoundException: creamtec/ajaxswing/JVMFactory
at sun.rmi.registry.RegistryImpl.unbind(RegistryImpl.java:140)
at com.creamtec.ajaxswing.core.JVMFactory.shutdown(JVMFactory.java:290)
at com.creamtec.ajaxswing.core.ClientAgentFactory.shutdown(ClientAgentFactory.java:215)
at com.creamtec.ajaxswing.ServletHelper.shutdown(ServletHelper.java:191)
at com.creamtec.ajaxswing.AjaxSwingRouter.destroy(AjaxSwingRouter.java:92)
at org.apache.catalina.core.StandardWrapper.unload(StandardWrapper.java:1394)
at org.apache.catalina.core.StandardWrapper.stop(StandardWrapper.java:1739)
at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4865)
at org.apache.catalina.core.ContainerBase.stop(ContainerBase.java:1106)
at org.apache.catalina.core.ContainerBase.stop(ContainerBase.java:1106)
at org.apache.catalina.core.StandardEngine.stop(StandardEngine.java:468)
at org.apache.catalina.core.StandardService.stop(StandardService.java:604)
at org.apache.catalina.core.StandardServer.stop(StandardServer.java:788)
at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:408)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:338)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:416)
 
 
 
Operating Systems:

Comments 16 CommentsJump to latest comment

x0pd88's picture
I am grateful for any answer, but you have seen the attached file, and my logs? Maybe you are not the solution I was offered?
 
My problem is probably that SEPM does not find java machine. There is a parameter error for which he is looking for the location of Java
 
Nevertheless, I made ​​the decision that you have offered me and it did not help.
nwranich's picture

This may be a silly questions, but did you reboot after the upgrade?

Seyad's picture

Please give us the content of the setEnv.bat file, so we can check it.

Location: %Program Files%\Symantec\Symantec Endpoint Protection Manager\tomcat\webapps\ajaxswing\WEB-INF\ajaxswing\bin\setEnv.bat

x0pd88's picture
I corrected values ​​in this file it is run without error.
 
Now it looks like this
 
set CATALINA_HOME=C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\tomcat
set JAVA_HOME=C:\Program Files\Java\jre7
set AJAXSWING_HOME=%CATALINA_HOME%\webapps\ajaxswing\WEB-INF\ajaxswing
set JAVA_OPTS=-Djavax.xml.transform.TransformerFactory=com.sun.org.apache.xalan.internal.xsltc.trax.TransformerFactoryImpl
set KEEP_CURRENT_DIR=true
 
The service did not start. In the system events error "Java Virtual Machine is not found"
 
Maybe the problem is that I have SEPM x86 and x64 version of java?
 
i'm sorry 4 my machine translate(
 
p.s. Also in system events "In the LoadLibrary error occurred for the following reason: The specified module could not be found" - this error wrote in russian. I'm attached "semsrv" parameters from registry.
AttachmentSize
setEnv.bat_.txt 3.07 KB
semsrv-param.reg_.txt 5.11 KB
Beppe's picture

Hello,

if you suspect some settings got broken, try to repain the SEPM installation from the control panel and it will fix what should be fixed.

Regards,

Giuseppe

x0pd88's picture

Hello,

i'm reinstall SEPM 12.1.3 after removing 12.1 

x0pd88's picture

I uninstalled SEPM and Java as you advised. After the reboot, install SEPM and again the same problem with java

Rafeeq's picture

I still see the heap size as 128 in the logs, try increasing it, 

and also do  you have any  other java version installed (for other programs)

is this a fresh install or trying an upgrade? or restoring from backed up db?

this might help you to fix the issue.

http://www.symantec.com/business/support/index?page=content&id=TECH109393

x0pd88's picture

Thank you for you answer

On this server only Acronis Backup and Recovery and SEPM. Acronis do not use java.

Initially tried to upgrade, then a fresh install. I removed the remains of Java and tried to install again but the service did not start.

I also tried it in a virtual machine to install SEPM + backup key + database backup and he has started!
 
I do not understand why he does not want to do it on a live server ((( I'll try to uninstall again and use the utilities to clean registry. If not I will send a formal request for technical support. But I do not know if this is possible in Russia
x0pd88's picture

"The URL you've tried isn't returning content"

server in the domain, virtual is not.

for a fresh install using the default parameters

Rafeeq's picture

its opening for me, please enable the advanced logging lets see if thats gives some clues 

SameerU's picture

Hi

Can you please run repair and Mangement Wizard

Regards