Video Screencast Help

Symantec Ghost to other location

Created: 21 Jan 2014 • Updated: 30 Jan 2014 | 11 comments
This issue has been solved. See solution.


I'm currently working on setting up Symantec Ghost to be used to push images to workstations at not only my office but also branch offices as well. I've pushed many images to my office without issue and really like the results I receive by doing this. However, I recently tried pushing an image to a station at a branch location and everything seems to have pushed correctly except for the Configuration portion of the push.

Whenever I create a new task to push an image, on the Configuration tab, I always select "Default - Use previous machine configuration" which is what I want to use. I have ZERO problems using this as the Configuration as long as the PC I'm pushing to is located on the same LAN as myself. Whenever I try using this option on a station that's at a branch location, the task fails at the configuration stage and I'm left with a PC that is not communicating on the network (we use static IP Addressing so the Configuration part really needs to work). Any suggestions for pushing images to branch offices?

I was thinking that for branch offices I could just create a configuration file with the previous machine information in hopes that it would work but also wanted thoughts from others who may have run into this situation before.

Thank you in advance for your help

Operating Systems:

Comments 11 CommentsJump to latest comment

EdT's picture

Can you please describe your network environment in a lot more detail. What server platforms? Do you use Active Directory?  Are branch offices on separate subnets? How are they linked to your main office?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ETrosclair's picture

I have the Symantec Ghost Console installed on a Windows 7 Professional box.

Yes we do use Active Directory.

Our branch offices are all on the same subnet; they just use different IP Addressing from my office.

Branches are linked to my office by P2P fibre connections. Each office has a modem from our ISP and a router that has been configured to get out to the Internet through my office.

EdT's picture

What version of Symantec Ghost are you using?  Is it ?

Are you booting to DOS or WinPE in the virtual partition?  Do you have a static IP address reserved for your virtual O/S ?  Do you use the same subnet mask throughout your network?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ETrosclair's picture

Yes I am using version

I am booting to PC-DOS in the virtual partition.

What do you mean reserve a static IP Address for the Virtual O/S? If you mean that I should ensure that the IP Address I'm using is for this station only then yes I do ensure that it is the only station using this address.

Finally, yes we do use the same subnet mask throughout the network.

EdT's picture

What I was asking is whether you are reserving a static IP address for the PCDOS boot image?

Since you are using PCDOS, can I assume you fully understand its limitations in respect of the inability to support SATA hard disks (unless you have compatibility mode available, and selected, in the bios), and also large hard disks ? DOS uses CHS addressing, technically limited to 132 Gb, whereas newer technologies such as SATA use LBA and go beyond the 32 bit sector addressing limit of DOS. 

Realistically, you should use WinPE for modern hardware.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

ETrosclair's picture

Yes I understand its limitations and only began using PC-DOS because I did not have a whole lot of success using WinPE when I first started using Ghost. Since changing to PC-DOS, the situation I describe above is the only problem I've run into. I am, however, tempted to retry WinPE again as I am too thinking that this may be the entire problem when it comes to the configuration aspect of restoring an image at a branch location.

Other than trying WinPE, could there potentially be another problem that would cause the Configuration phase to fail?

Dpak D's picture

Are you using configuration to join clients to domain or you just wish to keep the existing settings?
Does the configuration part fail under the task ?If so what is the error?Or it fails to retain the previous machine configuration with the task reporting successful?

ETrosclair's picture

When restoring an image, I almost always wish to keep the existing settings that are specified on the station I'm restoring to.

Yes, the last time I tried restoring an image to a branch office, the configuration part failed under the task. The exact error was as follows...

Step - To target operating system - Client timed out

The step prior to "To target operating system" was the configuration. My thinking is that if the configuration was successful, the client wouldn't have timed out because it would have still been on the network. I have not had a chance to go out to the branch office just yet to see what this machine is showing but I'm fairly confident that if I were to look at the TCP/IP settings, it would be set to DHCP even though the previous configuration used a static IP Address.

Whenever I use a task at my office, 100% of the time the task completes successfully with the end result of the station retaining its previous machine configuration.

Dpak D's picture

I have seen this with Windows 7 machines ,where the default configuration does not retain the Static IP address.As a workaround you could try custom configuration to check the difference.
Since the task failed under "To target operating system", the possibilities are,
1. No client software under the image
2. Client did not boot to OS
2. Client was trying to use DHCP and did not connect back to network.

Also,you could create an image with DHCP enabled on the client,to check if it makes any difference.

ETrosclair's picture

Thanks for the feedback guys.

I'll take this advice and try these in my environment and post the results

ETrosclair's picture


Upon further investigation of the restored image, I noticed that the Configuration was in fact getting to the computers I was pushing to. What was happening, however, is the static IP Address that I used when I created the image was still there along with the IP Address I specified in the Configuration step. Researching this, I came across the TechNote below. I will be contacting Symantec support for this patch that will hopefully resolve my issue.