Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Symantec Installation Manager - Database Configuration - "Could not connect to server or Login Failed"

Created: 11 Nov 2012 | 11 comments
Iftikhar Iqbal's picture

Hi,

Environment:

3 VM Mahines

  1. LABDC - Domain Controllet
  2. LABSQL - SQL Server 2008 Datacenter Edition
  3. LABALTIRIS - Client Management Suite 7.1 SP2

I am currently on LABALTIRIS, at the Symantec Instllation Manager (SIM) interface and stuck at the Database Configuration page. My Settings are as below:

SQL Server Name: LABSQL

Windows Credintials

After I click next i received this error: "Could not connect to server LABSQL or Login Failed"

I have even tried using an SQL Server Login and am receiving the same error.

The SQL is confgured to allow remote connections and enabled on named pipes and TCP/IP

And I am using the Domain Admin account to configure and install each component.

Comments 11 CommentsJump to latest comment

andykn101's picture

Datacenter edition of SQL Server is not supported, only Express (for lab environments), Standard or Enterprise. See the Platform Support Matrix:

http://www.symantec.com/docs/HOWTO9965

Also I think the "SQL Browser" Service needs to be running on the SQL server or you need to specify the SQL port manually:

LABSQL:1433

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Robert Steinle's picture

Hi,

Please check that:

1. firewall is disabled on SQL or port 1433 is added as exception.

2. SQL server name is correctly resolved from NS (alternatively try to specify IP address instead)

3. you can connect to SQL server through SQL Server Management Studio

Regards,

Robert Steinle

Symantec Corporation

 

For Forum threads, please click "Mark as Solution" if answered.

Iftikhar Iqbal's picture

Andy:

The document link says the following:

"The Notification Server installation is tested with Microsoft SQL Express, Standard, and Enterprise versions x86 and 64-bit."

It just says tested, not specifically talking about the support. If you see the pages before it, it specifically mentions that Windows Server Core is not supported (specifically)

Second, SQL Broswer service is already running. I have disabled the firewall since the start of the installations on both LABSQL and LABALTIRIS.

 

Robert:

  1. FW is disabled
  2. SQL server name is being correctly resolved. Have tried specifying the IP address too, same result.
  3. Yes I can
Robert Steinle's picture

1. Did you try to connect from LABALTIRIS machine using SQL Server Management Studio?

2. If you're using non-default instance, don't forget to specify it as well (e.g. LABSQL\'Instance_Name').

Regards,

Robert Steinle

Symantec Corporation

 

For Forum threads, please click "Mark as Solution" if answered.

Iftikhar Iqbal's picture

Andy:

Furthermore I would be using IT Analytics, for which I would require SQL Server Enterprise or Datacenter.  I can try out the Enterprise Edition provided that the Datacenter is 100% not supported for Altiris/SMP.

If there are no other ideas then I guess I would require to go to Enterprise. But I need solid information, as it doesnt make sense to shift.

Iftikhar Iqbal's picture

Hey Robert,

I tried what you said and i couldnt connect to LABSQL from the Management Studio in LABALTIRIS.

 First, I connected to the default instance by typing the server name, LABSQL. I received the following error:

 

TITLE: Connect to Server
------------------------------
 
Cannot connect to LABSQL.
 
------------------------------
ADDITIONAL INFORMATION:
 
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 1265)
 
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=1265&LinkId=20476

 

Second, I tried to connect to the instance LABSQL\ALTIRISCMS. I did this by browsing under SQL Server Name name --> Network Servers --> Database Engine --> LABSQL\ALTIRISCMS. I received the following error:

 

TITLE: Connect to Server
------------------------------
 
Cannot connect to LABSQL.
 
------------------------------
ADDITIONAL INFORMATION:
 
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 1265)
 
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=1265&LinkId=20476
 
Further suggestions please.
 
Iftikhar Iqbal's picture

Hey Robert,

 

No I cannot. I have two instances, the default and ALTIRISCMS. I am not able to connect thorough the SQL Management Studio in LABALTIRIS. 

I have checked and the SQL server in LABSQL. Remote connections are allowed, TCP/IP and Named Pipes is enabled and the firewall in both LABALTIRIS and LABSQL is off.

 

Robert Steinle's picture

Hi,

Looks like named pipes are disabled, double check your settings. Also, did you restart DB services (or SQL machine) after pipes were enabled?

Please check this article for troubleshooting steps - http://blogs.msdn.com/b/sql_protocols/archive/2008/04/30/steps-to-troubleshoot-connectivity-issues.aspx

Regards,

Robert Steinle

Symantec Corporation

 

For Forum threads, please click "Mark as Solution" if answered.

Iftikhar Iqbal's picture

 Hey Robert, 

 

Named pipes are enabled. Services were restarted and machine too.

 

On the mentioned link. I have attached a text file on the commands I ran. Please have a look and let me know.

 

Thaks

SQL_Service.png protocols.png
AttachmentSize
sql.txt 5.18 KB
Robert Steinle's picture

Hi,

 

I'm assuming that you have enabled named pipes for both SQL instances.

 

1-Network Issue

Looks like you have problems with domain name resolving.

C:\Users\administrator>ping -a labsql

Pinging labsql.LAB.com [208.87.35.103] with 32 bytes of data:
Reply from 208.87.35.103: bytes=32 time=329ms TTL=128
Reply from 208.87.35.103: bytes=32 time=313ms TTL=128
Reply from 208.87.35.103: bytes=32 time=303ms TTL=128
Reply from 208.87.35.103: bytes=32 time=311ms TTL=128

C:\Users\administrator>ping -a 10.0.0.15

Pinging LABSQL [10.0.0.15] with 32 bytes of data:
Reply from 10.0.0.15: bytes=32 time<1ms TTL=128
Reply from 10.0.0.15: bytes=32 time=1ms TTL=128
Reply from 10.0.0.15: bytes=32 time<1ms TTL=128
Reply from 10.0.0.15: bytes=32 time<1ms TTL=128

C:\Users\administrator>nslookup 10.0.0.15
Server:  UnKnown
Address:  10.0.0.2

*** UnKnown can't find 10.0.0.15: Non-existent domain

 

3-Firewall Issue

Make sure that you don't have any filters/switches/firewalls somewhere between NS and SQL machines; otherwise they should be configured to allow SQL connection.

 

4-Client Driver Issue

C:\Users\administrator>telnet labsql 1433
Connecting To labsql...Could not open connection to the host, on port 1433: Connect failed

Let's assume that you have telnet installed and enabled on both machines. Looks like "labsql" name is mapped to incorrect IP address, or port/telnet connection is blocked somewehere between "LABALTIRIS" and "LABSQL".

Also, don't specify "MSSQLSERVER" if you have default instance, because it will look for non-default instance named "MSSQLSERVER".

 

You may try same steps, but with IP address of SQL server and "sa" user.

Regards,

Robert Steinle

Symantec Corporation

 

For Forum threads, please click "Mark as Solution" if answered.

Iftikhar Iqbal's picture

Hi Robert,

For the time i have given host entries on all VMs. Seems to be working now. I know this is not the right way but i need to get the demo up and running. Will check on it soon and update the forum. Thanks.