Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

symantec installation manager - reboot loop

Created: 21 Jan 2013 • Updated: 22 Jan 2013 | 5 comments
This issue has been solved. See solution.

Hi I did the latest update for SIM (Update 7.5.92) when completed it said it required a reboot as something else was requiring a reboot. I then realised there was a windows update waiting for reboot.

I have now rebooted the server 5 times but each time I open the SIM I get message "Another installation is requiring a reboot to complete changes to the system. You must reboot your computer before you can use Symantec Installation Manager. then Launch Symantec Installation Manager again."

Any ideas on how to get out of this loop?

Comments 5 CommentsJump to latest comment

kh@syscomworld.com's picture

Hi,

That indicates that some previous installation program left a value in the
registry. Use regedit to look at this key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
\PendingFileRenameOperations

Clear out any value in the key and then try again.

Also check if there is any MSI installations that do not complete. Look in to task manager to se if there is more than one MSIEXEC running. I had a simular issue at a Customer, at that customer it was Sophos tried to update some component. I had to remove sophos before i could continue.

Ryan Tetzlaff's picture

I have the same error.  I have cleared out the PendingFIleRenameOperations registry key, but this has not resolved the issue.  I also looked in task manager, but no msiexec processes are running.  Does the Symanted Installation Manager write a more detailed log file?  Where is it?

Ryan Tetzlaff's picture

Ah ha!  I figured it out.  This MS article suggests renaming the PendingFIleRenameOperations rather than just clearing the contents.  http://support.microsoft.com/kb/830608  That worked like a charm for me.

cathossie's picture

I've worked it out with the help of all of the above suggestions, I renamed the PendingFIleRenameOperations and checked the run and runonce (nothing other than VMtools), no msiexec running.

Rebooted server and had the same issue and the PendingFIleRenameOperations had returned. So I checked the .dll that was listed in this key and found it related to a lexmark printer!!! I disabled the "print spooler" as it isn't required on the server anyway, rebooted and can open SIM.

Thanks, Cat

SOLUTION
BigDaddyPS's picture

I had this exact error so I followed along the steps on the thread and didn't have that registry entry.  I did reboot the server 2 times yesterday with the same error and came in this orning to the same error and gave it another reboot....poof gone!  I didn't do anything but reboot.  I now have a cant reach solutionsam website error.  Webgateways!