Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Symantec Liveupdate Administrators failing at 99%

Created: 28 Sep 2013 • Updated: 03 Oct 2013 | 23 comments
This issue has been solved. See solution.

As of 9:43PM EST (09,27.13), all of our company Liveupdate servers are failing to download from http://liveupdate.symantecliveupdate.com

These are regional servers located all over the globe...

Were trying to download updates for:

- Symantec Endpoint Protection v11.0

- Symantec Endpoint Protection v12.1

- Symantec Endpoint Protection v12.1 RU2

 

We have gone as far as to reinstall one of our Liveupdate servers and again it failed at 99%.

Is anybody else experiencing this same issue?

Operating Systems:

Comments 23 CommentsJump to latest comment

Hector.Diaz's picture

Were a Global company each region has its own connection out to the internet.  If it was one region I would expect it to be firewall related but North America, South America, various other Latin American sites plus those from Europe, etc are all experiencing the same issue.

 

 

AttachmentSize
luadebuginfo.zip 14.6 MB
Hector.Diaz's picture

Thank you we tried the increased timeouts and that did not help.

What did work was removing the legacy definition downloads and only downloading RU2.

However, we need the 12.1 and v11 definitions.  Putting those back in causes the downloads to fail at 99%.

SebastianZ's picture

Try splitting the different definitions version download into separate schedules - for each 11.x, 12.1 and RU2 versions.

Hector.Diaz's picture

I have broken up the downloads the content that is failing is v12.1, RU2 and v11.x are downloading fine on their own seperate schedules.

L_Pohjala's picture

Hi,

We have two LUA servers installed and both of them are facing the same problem atm. Downloads are failed at 99%. Is there any solution to this?

Our proxy gives http 404 error, file not found.

Ambesh_444's picture

Hello.

Please check this.

https://www-secure.symantec.com/connect/forums/lua-distribution-fails-every-time

https://www-secure.symantec.com/connect/forums/lua-22113-fails-download-updates

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

L_Pohjala's picture

First link is helping on distribution problem? That is not the case. That last link helps with old version and is out with solution. How this should help in this case when 12.x definitions download fails.

HTTP error points to direction that there is some file missing from download source.

We have the same problem with two different customers, two different kind of environments exept LUA program.

SebastianZ's picture

Stay tuned - seems to be some general issues affecting the LUA.

Mick2009's picture

Good news- Symantec has been researching this issue, and now have a workaround to share.

Please note that this failure to download will affect only customers who are using LUA 2.x to download IPS definitions, and that the error only affects IPS definitions.  The LUA 2.x server is downloading and processing AntiVirus, SONAR, etc contents correctly.

Details can be found in the following article:

LiveUpdate Administrator 2.x Download tasks fail at 98% or 99%, "Failed to commit and move updates" - "a different object with the same identifier value was already associated with the session"
Article URL http://www.symantec.com/docs/TECH211068  
 

I will update this thread when a permanent resolution to this is available. Many thanks!

With thanks and best regards,

Mick

Mithun Sanghavi's picture

Hello,

Agreed with above comments. Thumbs up !!!! 

This developing issue is currently under investigation by Symantec. 

A workaround is to temporarily remove (uncheck) the SEP 12.1 and/or SEP 12.1 RU2 IPS definitions component from the scheduled LUA 2.x download task. This will allow the download task to complete and then the updates to commit.

Reference:

LiveUpdate Administrator 2.x Download tasks fail at 98% or 99%, "Failed to commit and move updates" - "a different object with the same identifier value was already associated with the session"

http://www.symantec.com/docs/TECH211068

Log a case with the Symantec Technical Support

How to create a new case in MySupport

http://www.symantec.com/docs/TECH58873

and keep the following data ready - 

1. luadebuginfo.zip
2. sdbz from each LUA server
3. The exported LUA Event Logs (export as CSV from the Event Log section in LUA)
4. The exported config file (export as zip from the 'Configure' section in LUA)

Details on how to gather those can be found in:

Gathering logs and troubleshooting data from LiveUpdate Administrator 2.x

http://www.symantec.com/docs/TECH92654

Hope that helps!!

Mithun Sanghavi
Senior Consultant
MIM | MCSA | MCTS | STS | SSE | SSE+ | ITIL v3

Don't forget to mark your thread as 'SOLVED' with the answer that best helped you.

pete_4u2002's picture

its been worked on,once the issue is resolved the KB will be updated. You can subscribe to this article.

Mick2009's picture

"Thumbs up" to the above advice.  A resolution for this issue is expected shortly.

With thanks and best regards,

Mick

nwranich's picture

I can confirm that turning off the IPS downloads allows the rest of the updates to download and distribute successfully.

Mick2009's picture

Good news- the issue has been resolved.  LiveUpdate Administrator 2.x has been confirmed to correctly download, process and distribute the content updates currently available from Internet source servers.

lua21_fixed.png

 

If IPS definition have been unchecked as a workaround, please re-enable their download and distribution now.  IPS are a crucial and effective defense against many of today's threats.

With thanks and best regards,

Mick

SOLUTION
Hector.Diaz's picture

Thank you, confirmed on my end as well IPS definitions downloaded and distributed without issues.

 

Mick2009's picture

Cheers for the update, Hector!  Good to hear it is all workign again.  &: )

If time allows, please do mark this thread as "solved" so that it will be included in search indexes and assist future admins in teh same situation.  (It is still displaying "needs solution" at the moment and will nto be indexed.)

With thanks and best regards,

Mick

SnowGhost's picture

Does this solution also apply to the FTP Fail over server?

Because of proxy server & firewall limitations I cannot alter, the FTP server is the only one I can access.

 

I've had only 2 sucecssful updates since the solution was announced, and none in the past week.

Mick2009's picture

Hi SnowGhost,

 

FTP and HTTP should both be working fine.

Have you tuned/configured your timeout values?

Also, how large are the jobs you ar etrying to download?  try to break it up into smaller jobs.  Those are more likely to succeed than downloading an enormous array of files all at once.

Many thanks!

Mick

With thanks and best regards,

Mick

SnowGhost's picture

I've previously adjusted the timeout values.  I also schedule the updates to happen out of hours.  Which for me is basically a zero network throughput time.

 

I've also split the download tasks up into

SEP 12.1

SEP 12.1 RU2

SEP 12.1 RU4

 

With no other products being downloaded.  The tasks are seperated by an hour.

 

Now my download tasks are typically failing at 0%, so I suspect it's a different problem.  What is annoying is the FTP server 'test connection' works fine.  I'll have to start a process and monitor it with wireshark and see what happens.

 

Mick2009's picture

Hi SnowGhost,

You may wish to open a new thread for your issue if the trouble continues.

Make sure you have the correct credentials specified in LUA 2.x if you are using the FTP source servers.  (User Name: cust-r2 Password: Alpc2p3O)

All the best,

Mick

With thanks and best regards,

Mick