Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

symantec management agent for linux

Created: 05 Feb 2013 • Updated: 19 Feb 2013 | 5 comments
This issue has been solved. See solution.

hi, i need help with installation agent for red hat 5.8.

cannot run ssh for root. i try to installed it manually using user (not root) and then su -root, success to install agent.

but this client not show in symantec management platform.

there's any other ways to install agent in red hat without root privilege and can running normally, like performance monitor, deployment solution, software management etc.

Comments 5 CommentsJump to latest comment

Andrew Bosch's picture

The base altiris agent needs to run with admin priviledges to install. If you are manually installing, just use 'sudo' and then the name of the package. During install, it will 'su' as needed and then will run as root during normal operation. Any plug-ins that are downloaded later, are installed using the default agent context (root). Currently there is no supported way to run the agent as non-root.

------------------------------------
Sr. Principal SQA Engineer
Symantec

mclemson's picture

If you've installed successfully (as Andrew described), but the agent still doesn't appear in the console, ensure that it's not a network or firewall issue.  Typically the agent communicates on port 80 to the Notification Server.

Mike Clemson, Senior Systems Engineer, ASC
Intuitive Technology Group -- Symantec Platinum Partner
intuitivetech.com

Andrew Bosch's picture

Good point Mike.  Make sure you can ping both the hostname of the NS and the FQDN.  If not, you'll have to add an entry to the hosts file.

------------------------------------
Sr. Principal SQA Engineer
Symantec

mawirr's picture

I've tried to install it manually but it does not appear on the console. I do a push install, by checking login first using unprivileged user but stuck in the starting bootstrap.

Andrei Fedulin's picture

Hi,

Did you check connection/firewall settings ( as mclemson/Andrew suggested?)?

After you manually installed it - was it running? you can check it using aex-helper check command(you can see more http://www.symantec.com/business/support/index?page=content&id=TECH29115)

Can you try to send basic inventory to NS from client( use aex-sendbasicinv command)?

Push install using non-privileged user still requires unrestricted root user . It is impossible to install agent on linux where root user is restricted by sudo.

Thanks,

Andrei

SOLUTION