Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Symantec Management Client Service will not start

Created: 01 Mar 2013 • Updated: 01 Mar 2013 | 8 comments
This issue has been solved. See solution.

I have had a couple of PCs on our network where as a result of performing a unmanaged PC search via SEPM 11 we find that AV is not visible/reporting into the server and we check the services and SMC is not started.  When you attempt to start it fails with: The Symantec Management Client service on Local Computer started and then stopped.  Some services stop automatically if they have no work to do, for example the performance logs and alerts service.

I have tried a repair via add and remove programs, made the SMC service manual instead of auto.  After this completed got the service started but after a refresh it stopped again and now back to the original issue.

I have tried replacing the smc.exe with a working one from another PC also replaced the cltdef.dat file in c:/program files/symantec/symantec endpoint protection.

Previously we have had to uninstall and reinstall to resolve, but I don't want to do that with this one as it runs an App that breaks easily in combination with Symantec AV.  So a in place repair is my preferred option.  Any suggestions?

We are running Window XP and version 11.7000 of SEP.

Operating Systems:

Comments 8 CommentsJump to latest comment

Ambesh_444's picture

Hi,

Try to repair sep and check..

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

Boeky's picture

As advised in my first post I have already tried a repair from Add and Remove programs and this has not resolved the problem.

Rafeeq's picture

Seems to be bug to me which was fixed in RU1 Check this document

Do you see the same logs in your client as well?

 

SMC service will not start. Error 0x80070102

 

http://www.symantec.com/business/support/index?pag...

Boeky's picture

I have just enabled debugging as had tried replacing cltdef.dat file as in the link in the above post which didn't resolve.  Please see logs when I tried to start the SMC service:

03/01 12:36:01 [340:1544] Enterprise version, Build 49!!!
03/01 12:36:01 [340:3072] SetUserProfileDir: User Profile Location: C:\Documents and Settings\LocalService
03/01 12:36:01 [340:3072] DamperControlSleepMS = 100
03/01 12:36:01 [340:3072] IsAlone() = 004DFDB0
03/01 12:36:01 [340:3072] Service ThreadID 7C8097D0
03/01 12:36:01 [340:3072] No Plugin is loaded yet
03/01 12:36:01 [340:3072] Loading C:\Program Files\Symantec\Symantec Endpoint Protection\Cltdef.dat
03/01 12:36:02 [340:3072] Loading C:\Program Files\Symantec\Symantec Endpoint Protection\Serdef.dat
03/01 12:36:02 [340:3072] ImportFromStream :  loadXML failed
03/01 12:36:02 [340:3072] ImportFromStream :  loadXML failed
03/01 12:36:02 [340:3072] Fail to import profile from C:\Program Files\Symantec\Symantec Endpoint Protection\Serdef.dat.bak
03/01 12:36:02 [340:3072] ProfileMan: cannot load server profile C:\Program Files\Symantec\Symantec Endpoint Protection\Serdef.dat
03/01 12:36:02 [340:3072] Service Start Initialize() Failed!
03/01 12:36:02 [340:3072] Service is shutting down
03/01 12:36:02 [340:3072] Saving SMC State
03/01 12:36:02 [340:3072] Skip saving state because Engine is not running
03/01 12:36:02 [340:3072] Stopping SyLink...
03/01 12:36:02 [340:3072] delete SMC State...
03/01 12:36:02 [340:3072] chmod on file C:\Program Files\Symantec\Symantec Endpoint Protection\SerState.dat to read/write.
03/01 12:36:02 [340:3072] delete netport...
03/01 12:36:02 [340:3072] delete IDSSignatureLib...
03/01 12:36:02 [340:3072] Disable damper...
03/01 12:36:02 [340:1544] System configuration has been saved.
 

Rafeeq's picture

one clarification in the above document That file name is Serdef.dat , but you mentioned it as cltdef.dat.did you replace this one?

 

its been resovled after copying two files

https://www-secure.symantec.com/connect/forums/smc...

SOLUTION
Boeky's picture

I think replacing the serdef.dat file has resolved the issue!  I was then able to start the service and Live Update sprung into life as well as the shield in the taskbar.

Thanks to all!