Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Symantec Workspace Virtualization (SWV) and Windows 7 with IE6

Created: 19 Mar 2014 | 7 comments

Altiris' Symantec Workspace Virtualization (SWV) agent and Windows 7 with IE6

I am working on virtualizing IE6 for our Windows 7 clients using the downloadable LDF files from Symantec.  The process successfully creates the .xpf file and virtual session.  I have imported and activated the product successfully, but once I attempt to run virtual IE6, and as soon as I click anywhere in the browser, I am receiving the error "iedw.exe - Application Error"  "The Application was unable to start correctly (0xc0000142).  Click OK to close the application."

I have run virtual IE6 in Windows XP successfully but it is Windows 7 where I really need to run it and cannot.  Any help or direction would be appreciated.

Thanks in advance!

Operating Systems:

Comments 7 CommentsJump to latest comment

EdT's picture

Can you confirm what version of SWV you are running?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

EdT's picture

Have you checked whether IE6 is actually supported on Win 7 ?   Virtualisation does not get around fundamental lack of support for a particular application version.

For the same reason, you could not virtualise a 16 bit app as Win 7 has no support for 16 bit apps.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

jms97's picture

Virtual IE6 is running now in our environment.  I could not create it with the LDF file.  I found one that was created for our Proof of Concept that worked.  Unfortunately, I don't have a resolution or root cause.

pegase_fr's picture

Hi,

I have exactly the same issue.

I have installed on Windows XP SP3 (+ latest patchs):

  • - SWV 7.5.522
  • - Swvldf_setup-1.1.18.0

I have copied under %userprofile%\local settings\temp\downloads the following patchs/package:

I have downloaded ie6-win7-1.0.113.0.zip. First issue, this version does not work, because it tries to download WindowsXP-KB2950467-x86-ENU.exe file that does not exist ! (see the KB note, this patch uses the package  WindowsXP-KB2936068-x86-ENU.exe). So I've downloaded ie6-win7-1.0.111.0.zip instead, and I have created the ie6 layer successfully.

I have exported the layer to XPF file, and imported the file on Win7 x64 workstation. It's supported (see http://www.symantec.com/connect/downloads/internet-explorer-6-windows-7-layer-definition-file).

When I launch the package, I receive the error "iedw.exe - Application Error" "The Application was unable to start correctly (0xc0000142). Click OK to close the application."

How can I inverstigate this issue ?

Regards,

balachandar_manimala's picture

Hello,

IE6,7 Layers created with 7.5 version of SWV for Windows 7 have this problem.

We have identified the root cause and are working to fix it. Please stay tuned for updates.

Regards,

Bala

jms97's picture

That is fantastic to know!  Please keep me posted.

 

Thanks!