Video Screencast Help

Synthetic full backup never completes.

Created: 02 Apr 2014 • Updated: 24 Apr 2014 | 9 comments
This issue has been solved. See solution.

I have taken a successful Full and incremental backup.

When I am running a synthetic backup it never completes. I cancelled the job.

Now when I check the backup images from BAR gui it shows me a Synthetic backup also.

How can I verify that image is not corrupted. Or why the Synthetic backup runs for a while and never completes.

Netbackup version is 7.1.0.3

Opersting System is 2003

Operating Systems:

Comments 9 CommentsJump to latest comment

Tech_S's picture

Full backup has taken 20 hours to compete and Incremental has taken just 1 hout to complete.

Synthetic backup was running from 20 hours, So I cancelled the job.

Now when I check the backup images from BAR gui it shows me a Synthetic backup also.

Adding above details just to clearify the problem.

Thanks.

ravin_a's picture

Hi Tech_S,

 

Synthetic full is combination of last full and subsequent incrementals. So it may take the same duration mostly to complete. Please wait for sometime and let us know.

SymTerry's picture

Hello,

Are you running a synthetic full or synthetic cumulative incremental backup? What storage is NetBackup reading from? Also how long did the last full synthetic back take to complete, or have you not ever had one complete?

To create a full synthetic backup, NetBackup would need to get all images since that last full, and create a new image. This will take some time, as the data will need to be gathered.  

You mentioned you canceled the job. What is the detailed status of that job?

Nicolai's picture

Are the backup images on disk or tape ?

Synthetic backup work well on disk and really bad on tape.

May i suggest you look into  Accelerator backups instead of synthetics.

This blog is a good place to start:

https://www-secure.symantec.com/connect/blogs/freq...

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

thesanman's picture

Whilst I agree Accelerator might be a way forward in the long term, in this case @Tech_S is running v7.1.0.3; Accelerator only appeared in 7.5 thus of no use to resolve this issue.  Accelerator also requires a more advanced storage type rather than plain old tape or disk.

I use Synthetic backups from tape; yes sometimes it can take 12-18 hours to re-synthesise a new full from a multi-terabyte backup but it gets there eventually and more importantly isn't loading up the client with meaningless IO and network use.  The work is all done by the Master and Media server in the Netbackup environment.  I only regenerate a new full once a month.  The rest of the time the differentials go to disk and then tape.

NBU v7.5.0.6 Master and Media servers on RHEL 5/6 & Win2008; SAN based LTO3, 4 and 6 tape libraries
Linux, Solaris, Windows and OpenVMS clients.
PureDisk, SLP, VMware, HyperV, Oracle, Netezza, SQL/Server,

Tech_S's picture

Backup is on disk.
Two times i tried synthetic backup and it got hung.
When i canceled second time now it shows me in bar gui that synthetic image .
Now again i tried synthetic full backup and it says nothing to synthesize.
Can we consider synthatic image which we can see in the bar gui as valid because i have canceled the backup because it was hung, it did not complete with status 0.

watsons's picture

Can you run bpverify against that synthetic backup image to see if it's valid.

Cases like this (where image exists but the synthetic backup job did not complete), I would look into bpsynth and bpdbm to find out if that job actually completes or not. Note that backupID is created first before the actual backup takes place, so having a backupID does not mean it's valid.

SOLUTION
Tech_S's picture

Hi Watsons,

 

Thanks, You have got a valid point.

I should try bpverify on that backupid.