Video Screencast Help

SysPrep with Ghost and PXE booting

Created: 31 Jan 2013 | 12 comments

Hi,

I have PXE booting working fine and I can take an image without issue until I add sysprep to the task. I am trying to sysprep Windows 7.

The source machine will PXE boot, connect to the console and then reboot back to Windows. At that point it is no longer connected to the console, but the create image task still runs.

Can someone point me in the right direct?

 

Best wishes
 
Michael
 
Discussion Filed Under:

Comments 12 CommentsJump to latest comment

EdT's picture

What exact version of Ghost are you running?  To work with Win 7 you need to have 11.5.1.2266

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

bazcurtis178's picture

Hi,

We are running 11.5.1.2266.

 

Best wishes
 
Michael
 
bazcurtis178's picture

Hi,

I have made some progress. I installed the Ghost client on the machine and this time it stayed connected to Ghost, but it failed - to Virtual Partition.

 

Best wishes
 
Michael
 
EdT's picture

Failing to Virtual Partition is normally caused by a lack of correct NIC drivers in WinPE. Make sure you use Vista 32 bit drivers as WinPE uses the Vista kernel.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

bazcurtis178's picture

Hi,

I have read that, but I am using the same Virtual Partioin that I use to PXE Boot when I don't sysprep. I have attached a screenshot of the Client Config page.

You will see I made a copy of the Windows PE and called it my own version.

Best wishes

 

 
Michael
 
Properties.png
Maneesh's picture

Fisrt off all,Sysprep is part of OS and needs to run under OS .Only then Sysprep would remove machine specific information and would either reboot to shuts down the client.So,Syspep task should not be used with PXE.Sysprep task should only be used with Console client installed .

Secondly, if you had added the drivers under WINPE and have using the same WINPE template for Console, storage drivers might be missing for WINPE.You ,ight have added NIC drivers while creating PXE package but not the storage.Pls send us the missing driver info.

 

bazcurtis178's picture

Hi Maneesh,

Thanks for the feedback. This is what I have done so far. The laptop is a HP Elitebook 2570p running Windows 7. I have added the network and storage driver to the PXE image. This new PXE image is named TSG-PE. The PXE will boot fine, I can take an image with no problem if in my task I don't tick, use SysPrep. I am assuming from this that the storage driver is working otherwise it wouldn't see the hard disk.

The Ghost client is installed on the laptop and I can see it stays connected in the console, which before it didn't as I hadn't installed it.

I then use the same task and tick SysPrep with the settings you see above and I then get this virtual partition error.

I would like to use SysPrep in the action so people don't forget to sysprep machines, but it may just be easier to sysprep locally and then take the image.

Appreciate the help.

 

 

Best wishes
 
Michael
 
Maneesh's picture

Hi Michael,
What is the exact error which you get under 'To Virtual Partition' Step.

bazcurtis178's picture

Hi Maneesh,

It is 

Could not read boot code file to format filesystem: "C:\Program Files (x86)\Symantac\Ghost\incoming\dos\bootsect.dat"

 

Best wishes
 
Michael
 
Maneesh's picture

I find that you are using WINPE for imaging with Console and in this error its a DOS file which is listed.On the client machine navigate to C:\Program Files (x86)\Symantac\Ghost\incoming and delete the contents of the folder and run the task again.

Make sure that the client does not have EFI enabled.
Does image creation and restoration complete successfully with PXE ?

bazcurtis178's picture

Hi Maneesh,

That folder is emtpy already. Sorry if I am being a bit thick, but isn't EFI the bios. How will it boot if I turn off EFI?

 

Cheers
 
Michael
 
EdT's picture

EFI stands for Extended Firmware Interface with the emphasis on Extended. An EFI bios should still be able to boot when you turn off the EFI feature.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.