Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Sysprep never finishes on Win 8.1 client

Created: 08 Nov 2013 • Updated: 02 Dec 2013 | 5 comments
This issue has been solved. See solution.

Hi,

I have just tried to capture my first Win8.1 image using Altiris 7.5 and Sysprep isn't completing. All i have done is use the "Prepare for image capture" task on our notification server. The client gets the tast and I can see Sysprep running in task manager. Usually, on a Win7 machine, this takes less than a minute but on this Win8.1 machine, it has so far taken just under 2 hours and doesn't really seem to be doing anything, though the task hasn't failed. Has anyone else come across this? Any suggestions?

Thanks in advance...

Operating Systems:

Comments 5 CommentsJump to latest comment

wiggum83's picture

Ok, so I've noticed something else. These log files don't exist:

generalize

%WINDIR%\System32\Sysprep\Panther

specialize

%WINDIR%\Panther\

Unattended Windows setup actions

%WINDIR%\Panther\Unattendgc

But in %WINDIR%\System32\Sysprep\Panther there is a file called setupact which states:

"Sysprep will not run on an upgraded OS. You can only run Sysprep on a custom (clean) install version of Windows".

So this machine had a factory build on it which I have upgraded to 8.1 and removed all the rubbish from. I think this answers my own question in that I'll need to install from a disc but if anyone can confirm one way or another, that'd be handy.

Thanks again.

MPowers's picture

Just FYI, when I tried to make a Windows 8.1 image a few weeks ago, I had the same issue with sysprep never finishing. This was on a clean install from ISO.

The issue ended up being with some Metro Apps after doing Windows Updates. Sysprep couldn't generalize the apps and would fail and hang. I couldn't fix it even after doing remove-appxpackages on nearly everything. I ended up reinstalling and not doing any WIndows updates before I took the image and I was able to take it fine at that point. Just something to look at if you end still having the issue.

SOLUTION
Klim_Belchev's picture

I don't think Windows 8.1 is supported in Altiris 7.5 at this point in time - Windows 8 is.

A bit ironic, isn't it... They just released 7.5 that supports the latest OS and Microsoft released 8.1 / 2012R2...

Maybe soon there will be an update for 7.5 to enable support for Windows 8.1 and Server 2012 R2?!

etk1131's picture

It's working on Windows 8.1 in my environment.  Are you running a sysprep first prior to running the Prepare for Image Capture?  That's how I always capture my images.

So, I installed Windows 8.1, customized it in audit mode, then ran a sysprep /generalize /oobe /reboot with an /unattend that had some of my custom settings (like copyprofile=true).  Then, when it rebooted, I went back into audit mode and ran my Prepare for Image Capture task.

It ran in a very short time, then rebooted as expected. 

SOLUTION
wiggum83's picture

Hi all, thanks for your help. I'm going to close this off for the time being. I have it working on 8 by installing no updates for the tile apps and running sysprep prior to the "Prepare for Image Capture" job. I haven't yet tested 8.1 as I now have another issue that I've just created a new thread for!

Thanks for all your help.