Video Screencast Help

System Recovery The connection to the recovery agent was lost

Created: 27 Sep 2012 | 9 comments

I have a critical server that I backup with Symantec System Recovery. This server cannot be backed up with BackupExec2010 due to the file system of the server. its has 1000's of small files that are 1k or less. It takes Backupexec hours to backup just a few GB on this server. It also takes just as long if I attempt to copy a mass amount of these files.

System Recovery works at the block level. This allows for backups to run more efficiently on this server.

I am able to Successfuly restore the OS, but unable to restore a data volume. This is 1 TB in size. Attempted a Restore from a USB Drive and attempted from a another local disk on the server. This restore is not over a network connection.

I created a new backup of the server and tried again with the same error. I tried both a compressed and non compressed restore set. I also tried with and without the origional disk signiture.

The job gets to 99% complete before displaying the error: the connection to the recovery agent was lost.

I click OK and I receive error: The Remote Procedure Call Failed

Trying to see if anyone else has seen this issue with System Recovery.

 

Thank you,

Glen

Comments 9 CommentsJump to latest comment

Chris Riley's picture

Can you confirm the service pack level of SSR that you are using?

It sounds like the restore of the data volume is being done within Windows - can you confirm?

Have you tried doing the restore via the recovery disk (SRD)?

gml542's picture

Version 10.0.0.39952

I tried both from Windows as well as the recovery environment. Both seem to get to 99% then fail.

 

 

Chris Riley's picture

First thing I would suggest is open the recovery point (double click) into the recovery point browser and do a verify to confirm the image is valid.

Assuming that is valid, update to SP3 (10.0.3) via LiveUpdate or here:

http://www.symantec.com/docs/TECH195461

This will require a reboot. Then try restore again.

gml542's picture

I tried that, I can browse the recovery point. I can mount it and recover files from it. I would just copy and past to recover the data, but because of the 1,000s of small files it takes to long. After 24 hrs I would only able to recover 100GB. System Recovery works at the block level. This type of copy is much faster for this situation. So I need system recovery to perform successfuly

 

Chris Riley's picture

It's not clear in your response....are you saying you are seeing the same issue with SP3?

If yes, please check in the event logs as it sounds like there is a crash in the SSR service.

You mention that the volume you are restoring is 1TB in size. Can you confirm how much of this is used space?

gml542's picture

We are seeing this issue with SP3. The size of my drive is 1.5 TB. We are baking up 1TB of data. Not seeing anything in our logs. I have a case open with Symantec. So far they have not found anything in the logs that would indicate what is causing our problem.

Chris Riley's picture

OK, you have a case open so hopefully this will progress towards a solution.

By the way, what is the case ID?

gml542's picture

Update; Technician is providing me with a hot fix. I will let you know the results as soon as I get a chance to test and apply it.