Video Screencast Help

System State backup fails with "0xe0000352 - The specified volume does not exist. Recreate the volume, and then try the job again."

Created: 19 Mar 2013 | 18 comments

The error occurs after the Systembackup :

System State backup fails with "0xe0000352 - The specified volume does not exist. Recreate the volume, and then try the job again."

the same error you can see in the windows event viewer.

vssadmin list writers shows the ASW Writer on error

Verfassername "ASR Writer"

status: [7] Fehler

Letzter Fehler: timeout

after restart the VSS service all writer ok till i make a new system backup.

I have installed all updates for Backup Exec 2012 R2 and windows updates too without success.

i have attached a debug log from the system backup with the following settings in the capture tool : Job Engine, Raws, Agent Browser.

Thnx for your help.

 

 

 

 

 

Operating Systems:

Comments 18 CommentsJump to latest comment

CraigV's picture

Hi,

 

If the VSS writers aren't stable and running, then they're in error and you restarting the server (which is correct!) reset them to a working state again.

If this happens again, check to see if there is a VSS Rollup Patch (if using Windows Server 2003) to download and install, or do a search on the Microsoft site to fix VSS on Windows Server 2008/R2. There will be a link to fix the problem which should also sort this out.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Mange_24S's picture

In the logfile you can see the following.

 

BEREMOTE: [03.19.13 13:24:05] [11364]     2013-03-19T13:23:37.666 [fsys\shadow]        - Status E_FS_VOLUME_NOT_FOUND (0xE0000352) for object 'System Files'.  Faild to resolve volume path name for 'v:\vddb\' in SHADOW::SetSelectedForBackup
BEREMOTE: [03.19.13 13:24:05] [11364]     2013-03-19T13:23:37.666 [fsys\shadow]        - Status E_FS_VOLUME_NOT_FOUND (0xE0000352) returned setting selected for backup for object System Files in SHADOW::AddToSnapshotSet

For me this indicates that an application on your windows server have registered a path related to the ASR writer. When you backup system state, Windows tells the writers to do their thing at the registered paths. If path is not found or corrupt in some way it will fail. Had this error on a server that had an application registering a number of paths on the D: relating to a part of System State. When uninstalled the paths disappered but the paths was not unregistered from System State.

v:\vddb looks like some sort of recovery disk or something?

Do you have a v-drive present? If so make sure the vddb folder is present, if not create an empty one and try again....

Madness's picture

V:\vddb is a network drive thats pointed to a directory on the server and its present.

In the backup job i don´t see this drive to select.

 

Mange_24S's picture

Ok, that mapped network drive will not be present for the remote agent when doing the backup since its mapped in another session and/or lack permissions. Thats why you cant select the drive for backup in BE when browsing. 

Hard for me to tell what the v-drive is used for, but I would try to get the V-drive local to the server and try a new backup. For example use a USB-stick as V: on the server, just get it local, so you can try again.

 

Madness's picture

the v:\vddb is a mapped drive that´s pointed to the folder c:\dracar\public\deni01\vo\vddb

i can´t change ist because a program needs this to work correctly.

can i tell backup exec somewhere to ignore this drive ?

 

VJware's picture

Is any application installed in "vddb" ? And/or is this directory encrypted ?

EDIT**

Didn't see your comment. Try adding a global exclusion or better still, consider reinstalling the program on a local drive & not network.

Mange_24S's picture

Is v: a mapped drive or a mounted drive? You said earlier it is a mapped drive pointing to C: but later you say it is a normal directory (local?)

 

Mounted drive - then it comes down to permissions or symbolic links or other issue.

Mapped drive - is not supported to backup mounted drive that way. A mapped drive should never be registered by an application to be included in System State.

 

The application seems to have registered that path to the ASR-writer so its hard to just exclude it.

 

Madness's picture

yes its a mapped drive to the directory i mentioned above.

but how i can exlude it from the ASR Writer, in the program i don´t see this drive anywhere...

 

VJware's picture

Not sure, if this will work, but try adding a global exclusion.

Click on the yellow BE button (on extreme tyop left corner) - Configuration & Settings - Job Defaults - Exclude Selections.

Add the directory here &rerun the backup.

 

EDIT***

Try this HF - http://support.microsoft.com/kb/980794

Madness's picture

Ok the global exclusion don´t work, the backup comes with the same error.

I try now the microsoft solution...

Madness's picture

This Microsoft Hotfix isnt´t for my server - i can´t install it.

but i found a solution that works for me :

as Administrator :

in eine Bat Datei kopieren

net stop "System Event Notification Service"

net stop "Background Intelligent Transfer Service"

net stop "COM+ Event System"

net stop "Microsoft Software Shadow Copy Provider "

net stop "Volume Shadow Copy"

cd /d %windir%\system32

net stop vss

net stop swprv

regsvr32 /s ATL.DLL

regsvr32 /s comsvcs.DLL

regsvr32 /s credui.DLL

regsvr32 /s CRYPTNET.DLL

regsvr32 /s CRYPTUI.DLL

regsvr32 /s dhcpqec.DLL

regsvr32 /s dssenh.DLL

regsvr32 /s eapqec.DLL

regsvr32 /s esscli.DLL

regsvr32 /s FastProx.DLL

regsvr32 /s FirewallAPI.DLL

regsvr32 /s kmsvc.DLL

regsvr32 /s lsmproxy.DLL

regsvr32 /s MSCTF.DLL

regsvr32 /s msi.DLL

regsvr32 /s msxml3.DLL

regsvr32 /s ncprov.DLL

regsvr32 /s ole32.DLL

regsvr32 /s OLEACC.DLL

regsvr32 /s OLEAUT32.DLL

regsvr32 /s PROPSYS.DLL

regsvr32 /s QAgent.DLL

regsvr32 /s qagentrt.DLL

regsvr32 /s QUtil.DLL

regsvr32 /s raschap.DLL

regsvr32 /s RASQEC.DLL

regsvr32 /s rastls.DLL

regsvr32 /s repdrvfs.DLL

regsvr32 /s RPCRT4.DLL

regsvr32 /s rsaenh.DLL

regsvr32 /s SHELL32.DLL

regsvr32 /s shsvcs.DLL

regsvr32 /s /i swprv.DLL

regsvr32 /s tschannel.DLL

regsvr32 /s USERENV.DLL

regsvr32 /s vss_ps.DLL

regsvr32 /s wbemcons.DLL

regsvr32 /s wbemcore.DLL

regsvr32 /s wbemess.DLL

regsvr32 /s wbemsvc.DLL

regsvr32 /s WINHTTP.DLL

regsvr32 /s WINTRUST.DLL

regsvr32 /s wmiprvsd.DLL

regsvr32 /s wmisvc.DLL

regsvr32 /s wmiutils.DLL

regsvr32 /s wuaueng.DLL

sfc /SCANFILE=%windir%\system32\catsrv.DLL

sfc /SCANFILE=%windir%\system32\catsrvut.DLL

sfc /SCANFILE=%windir%\system32\CLBCatQ.DLL

net start "COM+ Event System"

 

Takeown /f %windir%\winsxs\filemaps\* /a

icacls %windir%\winsxs\filemaps\*.* /grant "NT AUTHORITY\SYSTEM:(RX)"

icacls %windir%\winsxs\filemaps\*.* /grant "NT Service\trustedinstaller:(F)"

icacls %windir%\winsxs\filemaps\*.* /grant BUILTIN\Users:(RX)

 

Madness's picture

Yes after i´ve done this the backup works fine without any errors.

i will control it these days and post the result here - Thnx for help.

pkh's picture

You should not re-register your VSS dll's if you are using Server 2008.  See this TN

http://support.microsoft.com/kb/940184

in particular note

This article is not for use with Windows Vista, with Windows Server 2008, or with later Windows operating systems. Starting with Windows Vista and with Windows Server 2008, Windows component installation is manifest-based. Trying to manually register specific components, as described in the following steps, can have unexpected results that may require you to reinstall Windows to resolve.

Madness's picture

The backup works fine now. the only thing i can see is that the ASR Writer stays on error - thats the problem with the V:\vddb drive i think.

 

Madness's picture

After 3 days the same error occurs again, i have registered the DLLs above again and restart the server.

But this solution works only 3-4 Days-

Can i delete somewhere the stupid Network Drive in the registry to avoid this problem ? In the prg the drive don´t appear...