Video Screencast Help

System state failures in pure disk

Created: 26 Aug 2014 | 4 comments

Hello All,

it was windows 2008 r1 Client backup is failing with system state(completing with 64%), and getting below errors.

Error: 2: resource child process: snapshot required but there is nothing to snap: no such object
Error: 2: name process: unable to process 'Shadow?Copy?Components': no such object

troubleshooting steps:
We have been checked all writers are in stable state, But still backup is failing with system state error.

Kindly let us know what was the next troubleshooting step to proceed from here.

pure disk version is V6.6.4

Thanks.

Operating Systems:

Comments 4 CommentsJump to latest comment

SymTerry's picture

Hello 

TECH181322 talks about the error your getting but also has  pdrai main: unable to perform operation: no such object

Are you also getting this error? 

Some of the trouble shooting steps it lists:

- verify no other active jobs for the agent
- create a test data selection to backup just shadow copy components, don't include system state as a separate item
- reboot the Window 2008 server
- reinstalled the PD agent
- made sure the anti virus software was not scanning the PD install folder.
- vssadmin listwriters show all writers as stable
- not showing DFSR on the windows agents.
- checking to see if the failing clients have PD installed in a different location from the working clients.

Anil B's picture

yes, we are getting this error as well.

 pdrai main: unable to perform operation: no such object

below steps has been done:

made sure the anti virus software was not scanning the PD install folder.

- verify no other active jobs for the agent
- create a test data selection to backup just shadow copy components, don't include system state as a separate item

vssadmin listwriters show all writers as stable

the above steps are good as of now with the host.

 

Let me know the few more steps please.

SymTerry's picture

Ok so just to verify:

  • Do you have the openfile option set in the pd policy?
  • Have you tried restarting both pd services on the client?
  • Did you check the event logs on the client for error related to vss or puredisk. Look at the event logs for application and system. If you see any, please reply here with those.

 

Anil B's picture

No errors reported at event logs related to vss/vsp.

No option set to openfile in pd policy.

now checking to restart the PD services on the client.

 

Clarify one thing how to check for windows 2003/2008 r1 or r2 clients requires latest vsshotfix or not? Do you have any command for this or how to check.

Please provide the steps.